summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2019-11-26 22:11:22 -0500
committeracerix2019-11-26 22:11:22 -0500
commit065b27b3d83670108a55f83e5f774e9d8b021c3e (patch)
treed758f3a83b0f07babb1b69c64393c29319601aff
parentd6698a2c50090931be6374c4a2c701810876eb5b (diff)
downloadaur-065b27b3d83670108a55f83e5f774e9d8b021c3e.tar.gz
Update to 4.23.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--allow-unsupported-clang.patch26
3 files changed, 46 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8b04a43b4b3..dac4757a4a37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.23.0
+ pkgver = 4.23.1
pkgrel = 1
url = https://www.unrealengine.com/
install = unreal-engine.install
@@ -18,18 +18,20 @@ pkgbase = unreal-engine
depends = xdg-user-dirs
options = strip
options = staticlibs
- source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.23.0-release
+ source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.23.1-release
source = UE4Editor.desktop
source = recompile-version-selector.patch
source = Makefile
source = ignore-clang50-install.patch
source = use-arch-mono.patch
+ source = allow-unsupported-clang.patch
sha256sums = SKIP
sha256sums = 46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118
sha256sums = 1dd876fa48c6fb4fcd4ccbdb8ed4ceccfa294685911e91be58bbc5e95726c279
sha256sums = 9654226ef3318389aa8fe15f3d4d14e7ac2113520ee5ebf2899d42273a2a6fb0
sha256sums = 71a7304deebb00234c323eed9a73cdbd022099ba65f62fc90e78069eceed1f5d
sha256sums = 6b30adf71eeabaf1b2b669aa56c9deba145a4fe7bdd2e77f44b0cb7423162bc0
+ sha256sums = bc4837ead8c89b7e4df2a14aedd62d23f47e7fca08c3f429a267ec4c3b3412d3
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 9dfc62a278ec..03942cfda383 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
# Maintainer: Dylan Ferris <dylan@psilly.com>
# You must register at unrealengine.com and link your github account to access this private repo.
-# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
+# See the wiki for more info: https://wiki.archlinux.org/index.php/Unreal_Engine_4
# The source is over 8 GiB, with an extra 3 GiB of dependencies downloaded in build(), and may take several hours to compile.
-# Allows enlargement of /tmp to fit Unreal.
-# set enlargetmp to any value.
-
pkgname='unreal-engine'
install="$pkgname.install"
-pkgver=4.23.0
+pkgver=4.23.1
# shellcheck disable=SC2034
{
pkgrel=1
@@ -28,16 +25,20 @@ pkgver=4.23.0
'Makefile'
'ignore-clang50-install.patch'
'use-arch-mono.patch'
+ 'allow-unsupported-clang.patch'
)
-sha256sums=('SKIP'
- '46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118'
- '1dd876fa48c6fb4fcd4ccbdb8ed4ceccfa294685911e91be58bbc5e95726c279'
- '9654226ef3318389aa8fe15f3d4d14e7ac2113520ee5ebf2899d42273a2a6fb0'
- '71a7304deebb00234c323eed9a73cdbd022099ba65f62fc90e78069eceed1f5d'
- '6b30adf71eeabaf1b2b669aa56c9deba145a4fe7bdd2e77f44b0cb7423162bc0')
+ sha256sums=(
+ 'SKIP'
+ '46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118'
+ '1dd876fa48c6fb4fcd4ccbdb8ed4ceccfa294685911e91be58bbc5e95726c279'
+ '9654226ef3318389aa8fe15f3d4d14e7ac2113520ee5ebf2899d42273a2a6fb0'
+ '71a7304deebb00234c323eed9a73cdbd022099ba65f62fc90e78069eceed1f5d'
+ '6b30adf71eeabaf1b2b669aa56c9deba145a4fe7bdd2e77f44b0cb7423162bc0'
+ 'bc4837ead8c89b7e4df2a14aedd62d23f47e7fca08c3f429a267ec4c3b3412d3'
+ )
- # Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
+ # Package is 3 Gib smaller with "strip" but it takes a long time and generates many warnings
options=(strip staticlibs)
}
@@ -50,6 +51,7 @@ prepare() {
patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" ignore-clang50-install.patch
patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/SetupMono.sh" use-arch-mono.patch
patch "$srcdir/UnrealEngine/Setup.sh" recompile-version-selector.patch
+ patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Platform/Linux/LinuxToolChain.cs" allow-unsupported-clang.patch
cp "$srcdir/Makefile" "$srcdir/UnrealEngine/Makefile"
@@ -76,7 +78,7 @@ prepare() {
echo "Running setup"
./Setup.sh
- echo "generating project files"
+ echo "Generating project files"
./GenerateProjectFiles.sh -makefile
}
@@ -87,7 +89,7 @@ build() {
# this should work instead of "git clean", but something leftover causes crashes
#make ARGS=-clean
- # -j1 to force one make job; the first time fails if there are multiple jobs
+ # -j1 to force one make job; the first time fails if there are multiple jobs
make -j1
}
diff --git a/allow-unsupported-clang.patch b/allow-unsupported-clang.patch
new file mode 100644
index 000000000000..6f2290d1f12c
--- /dev/null
+++ b/allow-unsupported-clang.patch
@@ -0,0 +1,26 @@
+--- src/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Platform/Linux/LinuxToolChain.cs.old 2019-11-26 21:47:43.158191012 -0500
++++ src/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Platform/Linux/LinuxToolChain.cs 2019-11-26 21:48:30.800848886 -0500
+@@ -174,14 +174,6 @@
+ {
+ throw new BuildException("Unable to build: no compatible clang version found. Please run Setup.sh");
+ }
+- // prevent unknown clangs since the build is likely to fail on too old or too new compilers
+- else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 80 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 60)
+- {
+- throw new BuildException(
+- string.Format("This version of the Unreal Engine can only be compiled with clang 8.0, 7.0 and 6.0. clang {0} may not build it - please use a different version.",
+- CompilerVersionString)
+- );
+- }
+
+ // trust lld only for clang 5.x and above (FIXME: also find if present on the system?)
+ // NOTE: with early version you can run into errors like "failed to compute relocation:" and others
+@@ -565,7 +557,7 @@
+ Result += " -fsanitize=undefined";
+ }
+
+- Result += " -Wall -Werror";
++ Result += " -Wall";
+
+ if (!CompileEnvironment.Architecture.StartsWith("x86_64") && !CompileEnvironment.Architecture.StartsWith("i686"))
+ {