summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2017-01-04 13:54:19 -0500
committeracerix2017-01-04 13:54:19 -0500
commit08c752007d58ef4a951b1f6310ca9d14b5791bcf (patch)
tree945da46940574e70e3e36ea4e6f04eaa64a9767a
parent3378726eb4acb1c227ca3e5057837876512e815d (diff)
downloadaur-08c752007d58ef4a951b1f6310ca9d14b5791bcf.tar.gz
update to 4.14.2, patch for "unused return value" errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
-rw-r--r--ignore-return-value-error.patch11
-rw-r--r--remove-clang35-dependency.patch (renamed from 0001-remove-clang35-dependency.patch)0
4 files changed, 25 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 339dbb8f86f2..f463cce2022e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Dec 11 18:16:16 UTC 2016
+# Wed Jan 4 18:54:17 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.14.1
+ pkgver = 4.14.2
pkgrel = 1
url = https://www.unrealengine.com/
arch = x86_64
@@ -11,19 +11,22 @@ pkgbase = unreal-engine
makedepends = mono
makedepends = dos2unix
makedepends = cmake
+ makedepends = git
depends = icu
depends = xdg-user-dirs
depends = sdl2
depends = qt4
depends = python
- source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.14.1-release
+ source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.14.2-release
source = UE4Editor.desktop
- source = 0001-remove-clang35-dependency.patch
+ source = remove-clang35-dependency.patch
source = IOS-Typo.patch
+ source = ignore-return-value-error.patch
md5sums = SKIP
md5sums = c7fc35a7eb9e23c0a9b7c593f7f9878d
md5sums = 271579e814358390d210d57c724a3b00
md5sums = 3f8fc7334eb41fbe0531f89c0ee2e207
+ md5sums = 183ca1792f46a21461ed6f4c6d621a37
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 627b5bd09125..f798f3fcddca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# The source is over 3 GiB, with an extra 3 GiB of dependencies downloaded in build(), and may take several hours to compile.
pkgname='unreal-engine'
-pkgver=4.14.1
+pkgver=4.14.2
pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
@@ -18,8 +18,9 @@ license=('custom:UnrealEngine')
source=(
"git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=$pkgver-release"
'UE4Editor.desktop'
- '0001-remove-clang35-dependency.patch'
+ 'remove-clang35-dependency.patch'
'IOS-Typo.patch'
+ 'ignore-return-value-error.patch'
)
md5sums=(
@@ -27,14 +28,16 @@ md5sums=(
'c7fc35a7eb9e23c0a9b7c593f7f9878d'
'271579e814358390d210d57c724a3b00'
'3f8fc7334eb41fbe0531f89c0ee2e207'
+ '183ca1792f46a21461ed6f4c6d621a37'
)
-# seems these are no longer necessary and package is 3 Gib smaller with default options
+# seems these are no longer necessary; package is 3 Gib smaller with default options
#options=(!strip staticlibs)
prepare() {
- patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" 0001-remove-clang35-dependency.patch
+ patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" remove-clang35-dependency.patch
patch "$srcdir/UnrealEngine/Engine/Source/Developer/iOS/IOSPlatformEditor/Private/IOSTargetSettingsCustomization.cpp" IOS-Typo.patch
+ patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" ignore-return-value-error.patch
cd $srcdir/UnrealEngine
# help to clean up old builds when there is a new version
diff --git a/ignore-return-value-error.patch b/ignore-return-value-error.patch
new file mode 100644
index 000000000000..5d2faf08dc8e
--- /dev/null
+++ b/ignore-return-value-error.patch
@@ -0,0 +1,11 @@
+--- Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs.old 2017-01-04 13:45:29.669145563 -0500
++++ Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs 2017-01-04 13:45:34.875764475 -0500
+@@ -393,6 +393,8 @@
+ Result += " -Wno-unused-variable";
+ // this will hide the warnings about static functions in headers that aren't used in every single .cpp file
+ Result += " -Wno-unused-function";
++ // suppress errors about ignoring return value of function
++ Result += " -Wno-unused-result";
+ // this hides the "enumeration value 'XXXXX' not handled in switch [-Wswitch]" warnings - we should maybe remove this at some point and add UE_LOG(, Fatal, ) to default cases
+ Result += " -Wno-switch";
+ Result += " -Wno-unknown-pragmas"; // Slate triggers this (with its optimize on/off pragmas)
diff --git a/0001-remove-clang35-dependency.patch b/remove-clang35-dependency.patch
index e4f5fdf6aded..e4f5fdf6aded 100644
--- a/0001-remove-clang35-dependency.patch
+++ b/remove-clang35-dependency.patch