summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2018-10-23 18:59:08 -0500
committerZerophase2018-10-23 19:00:12 -0500
commit2a7406a82e9b8c92697fb22eae9b3c59652faafd (patch)
treeedb973ea915afdfbb99d683a5f1dd957e35cd4d8
parent646b64b553f8cb2c351ba1296a299ae1d6e647c7 (diff)
downloadaur-2a7406a82e9b8c92697fb22eae9b3c59652faafd.tar.gz
Update to 4.20.3
-rw-r--r--.SRCINFO28
-rw-r--r--CodeGenerator-move.patch13
-rw-r--r--Messages-move.patch56
-rw-r--r--NiagaraScriptViewModel-self-assign-fix.patch10
-rw-r--r--PKGBUILD53
-rw-r--r--Platform-bitwise-or.patch11
-rw-r--r--Player-move.patch13
-rw-r--r--SBlueprintPalette.patch13
-rw-r--r--UnrealExporter-move.patch23
-rw-r--r--UnrealSourceFile-move.patch13
-rw-r--r--clang-70-support.patch11
-rw-r--r--no-pie.patch11
12 files changed, 248 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b6702015fc9..fbf67e352ed8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 30 17:17:00 UTC 2018
+# Tue Oct 23 23:58:59 UTC 2018
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.20.2
+ pkgver = 4.20.3
pkgrel = 1
url = https://www.unrealengine.com/
install = unreal-engine.install
@@ -19,9 +19,9 @@ pkgbase = unreal-engine
depends = qt4
depends = python
depends = lld
- options = !strip
+ options = strip
options = staticlibs
- source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.20.2-release
+ source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.20.3-release
source = UE4Editor.desktop
source = ignore-return-value-error.patch
source = only-generate-makefile.patch
@@ -31,6 +31,16 @@ pkgbase = unreal-engine
source = Makefile
source = ignore-clang50-install.patch
source = use-arch-mono.patch
+ source = clang-70-support.patch
+ source = CodeGenerator-move.patch
+ source = UnrealSourceFile-move.patch
+ source = Platform-bitwise-or.patch
+ source = no-pie.patch
+ source = SBlueprintPalette.patch
+ source = Player-move.patch
+ source = UnrealExporter-move.patch
+ source = NiagaraScriptViewModel-self-assign-fix.patch
+ source = Messages-move.patch
sha256sums = SKIP
sha256sums = 46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118
sha256sums = 918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c
@@ -41,6 +51,16 @@ pkgbase = unreal-engine
sha256sums = 9654226ef3318389aa8fe15f3d4d14e7ac2113520ee5ebf2899d42273a2a6fb0
sha256sums = c1bb149410d6871a1858513d6253694452925a892d672f5705b2a7f96e5a1f36
sha256sums = 006bfc6dc6c4258b55768cac34a3c42f033a2777332272d8c47c340282bf400f
+ sha256sums = 3cee7cf7cb8c7b8fc65a423b4e51ea00c8b025784b21838e5def7c14fec60a0c
+ sha256sums = babf3d0def1ae135f68c194124c7ba04f57de0bbe98c53304fabd2e434d1e99e
+ sha256sums = 6b6dad7218e8700abbdc74692079b7e9d2295a656fb05a99330d170abf689c0a
+ sha256sums = be679f8b3b3085bd328e786d84c044f9d9eaa6315ab60d75447dfef5b6f4bd0b
+ sha256sums = 6ba1e4df6c5750db42db8a9731087ae9de8adcf242594d32c9ae162d9ad5c76c
+ sha256sums = 97119e06e91af6dfd54df07bdaea3dc342eb15177ce5c53f3746a8dd09a30768
+ sha256sums = 2557758219e0e8718652e102579d26a67f88ec45e61cc3457b2ebf0710bb036a
+ sha256sums = 83df14d25b75321f80c9132e72d99e7feafd294a78210f284101a5a8298aa38d
+ sha256sums = a0abe52f6ffe9b85b934e85a7077121461fab56f615f1714bdbc12afce5b2e82
+ sha256sums = 2f872c76f998f4e04c1eb221d022848686537e087413bfc016028e1f406e2830
pkgname = unreal-engine
diff --git a/CodeGenerator-move.patch b/CodeGenerator-move.patch
new file mode 100644
index 000000000000..32e2362f4402
--- /dev/null
+++ b/CodeGenerator-move.patch
@@ -0,0 +1,13 @@
+--- CodeGenerator.cpp 2018-10-12 15:09:53.933311716 -0500
++++ CodeGenerator.cpp_new 2018-10-12 21:58:55.111028585 -0500
+@@ -2590,7 +2590,9 @@
+ }
+ }
+
+- return Result;
++ typedef FUHTStringBuilder &FUHTStringBuilderRef;
++ FUHTStringBuilderRef &&Result_ref = Result;
++ return (FUHTStringBuilder&&)Result_ref;
+ }
+
+ void FNativeClassHeaderGenerator::ExportClassFromSourceFileInner(
diff --git a/Messages-move.patch b/Messages-move.patch
new file mode 100644
index 000000000000..26a29e6043e9
--- /dev/null
+++ b/Messages-move.patch
@@ -0,0 +1,56 @@
+--- Messages.h 2018-10-13 13:38:00.289005712 -0500
++++ Messages_new.h 2018-10-14 00:07:54.826558760 -0500
+@@ -19,7 +19,9 @@
+ TArray<uint8> AsData()
+ {
+ FBufferArchive MemAr;
+- return MemAr;
++ typedef FBufferArchive &FBufferArchiveRef;
++ FBufferArchiveRef &&MemAr_ref = MemAr;
++ return (FBufferArchive&&)MemAr_ref;
+ }
+ };
+
+@@ -47,7 +49,9 @@
+ {
+ FBufferArchive MemAr;
+ MemAr << Param1 << Param2;
+- return MemAr;
++ typedef FBufferArchive &FBufferArchiveRef;
++ FBufferArchiveRef &&MemAr_ref = MemAr;
++ return (FBufferArchive&&)MemAr_ref;
+ }
+ };
+
+@@ -79,7 +83,9 @@
+ {
+ FBufferArchive MemAr;
+ MemAr << Param1 << Param2 << Param3;
+- return MemAr;
++ typedef FBufferArchive &FBufferArchiveRef;
++ FBufferArchiveRef &&MemAr_ref = MemAr;
++ return (FBufferArchive&&)MemAr_ref;
+ }
+ };
+
+@@ -115,7 +121,9 @@
+ {
+ FBufferArchive MemAr;
+ MemAr << Param1 << Param2 << Param3 << Param4;
+- return MemAr;
++ typedef FBufferArchive &FBufferArchiveRef;
++ FBufferArchiveRef &&MemAr_ref = MemAr;
++ return (FBufferArchive&&)MemAr_ref;
+ }
+ };
+
+@@ -155,6 +163,8 @@
+ {
+ FBufferArchive MemAr;
+ MemAr << Param1 << Param2 << Param3 << Param4 << Param5;
+- return MemAr;
++ typedef FBufferArchive &FBufferArchiveRef;
++ FBufferArchiveRef &&MemAr_ref = MemAr;
++ return (FBufferArchive&&)MemAr_ref;
+ }
+ };
diff --git a/NiagaraScriptViewModel-self-assign-fix.patch b/NiagaraScriptViewModel-self-assign-fix.patch
new file mode 100644
index 000000000000..76d57d68c858
--- /dev/null
+++ b/NiagaraScriptViewModel-self-assign-fix.patch
@@ -0,0 +1,10 @@
+--- NiagaraScriptViewModel.cpp 2018-10-13 13:38:00.309005882 -0500
++++ NiagaraScriptViewModel_new.cpp 2018-10-13 23:55:08.563280628 -0500
+@@ -298,7 +298,6 @@
+ ENiagaraScriptCompileStatus ScriptStatus = Scripts[i]->GetLastCompileStatus();
+ if (Scripts[i].IsValid() && Scripts[i]->IsCompilable() && Scripts[i]->GetVMExecutableData().IsValid() && Scripts[i]->GetVMExecutableData().ByteCode.Num() == 0) // This is either a brand new script or failed in the past. Since we create a default working script, assume invalid.
+ {
+- LastCompileStatus = LastCompileStatus;
+ Message = TEXT("Please recompile for full error stack.");
+ GraphViewModel->SetErrorTextToolTip(Message);
+ }
diff --git a/PKGBUILD b/PKGBUILD
index be219432acc7..45e24ed4e8d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname='unreal-engine'
install="$pkgname.install"
-pkgver=4.20.2
+pkgver=4.20.3
# shellcheck disable=SC2034
{
pkgrel=1
@@ -32,6 +32,16 @@ pkgver=4.20.2
'Makefile'
'ignore-clang50-install.patch'
'use-arch-mono.patch'
+ 'clang-70-support.patch'
+ 'CodeGenerator-move.patch'
+ 'UnrealSourceFile-move.patch'
+ 'Platform-bitwise-or.patch'
+ 'no-pie.patch'
+ 'SBlueprintPalette.patch'
+ 'Player-move.patch'
+ 'UnrealExporter-move.patch'
+ 'NiagaraScriptViewModel-self-assign-fix.patch'
+ 'Messages-move.patch'
)
sha256sums=('SKIP'
@@ -43,7 +53,17 @@ sha256sums=('SKIP'
'1dd876fa48c6fb4fcd4ccbdb8ed4ceccfa294685911e91be58bbc5e95726c279'
'9654226ef3318389aa8fe15f3d4d14e7ac2113520ee5ebf2899d42273a2a6fb0'
'c1bb149410d6871a1858513d6253694452925a892d672f5705b2a7f96e5a1f36'
- '006bfc6dc6c4258b55768cac34a3c42f033a2777332272d8c47c340282bf400f')
+ '006bfc6dc6c4258b55768cac34a3c42f033a2777332272d8c47c340282bf400f'
+ '3cee7cf7cb8c7b8fc65a423b4e51ea00c8b025784b21838e5def7c14fec60a0c'
+ 'babf3d0def1ae135f68c194124c7ba04f57de0bbe98c53304fabd2e434d1e99e'
+ '6b6dad7218e8700abbdc74692079b7e9d2295a656fb05a99330d170abf689c0a'
+ 'be679f8b3b3085bd328e786d84c044f9d9eaa6315ab60d75447dfef5b6f4bd0b'
+ '6ba1e4df6c5750db42db8a9731087ae9de8adcf242594d32c9ae162d9ad5c76c'
+ '97119e06e91af6dfd54df07bdaea3dc342eb15177ce5c53f3746a8dd09a30768'
+ '2557758219e0e8718652e102579d26a67f88ec45e61cc3457b2ebf0710bb036a'
+ '83df14d25b75321f80c9132e72d99e7feafd294a78210f284101a5a8298aa38d'
+ 'a0abe52f6ffe9b85b934e85a7077121461fab56f615f1714bdbc12afce5b2e82'
+ '2f872c76f998f4e04c1eb221d022848686537e087413bfc016028e1f406e2830')
# Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
options=(strip staticlibs)
@@ -58,9 +78,34 @@ prepare() {
patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" ignore-clang50-install.patch
patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/SetupMono.sh" use-arch-mono.patch
patch "$srcdir/UnrealEngine/Setup.sh" recompile-version-selector.patch
+
+ patch "$ue4src/Runtime/Engine/Private/Player.cpp" Player-move.patch
+ patch "$ue4src/Runtime/Engine/Private/UnrealExporter.cpp" UnrealExporter-move.patch
+
+ plugins="$srcdir/UnrealEngine/Engine/Plugins"
+ niagaraEditor="$plugins/FX/Niagara/Source/NiagaraEditor"
+ patch "$niagaraEditor/Private/ViewModels/NiagaraScriptViewModel.cpp" NiagaraScriptViewModel-self-assign-fix.patch
+
+ remoteSession="$plugins/Experimental/RemoteSession/Source/RemoteSession"
+ patch "$remoteSession/Private/MessageHandler/Messages.h" Messages-move.patch
+
+
+ kismet="$ue4src/Editor/Kismet/Private"
+ patch "$kismet/SBlueprintPalette.cpp" SBlueprintPalette.patch
+
+ uht="$ue4src/Programs/UnrealHeaderTool/Private"
+ patch "$uht/CodeGenerator.cpp" CodeGenerator-move.patch
+ patch "$uht/UnrealSourceFile.cpp" UnrealSourceFile-move.patch
+
+ ubt="$ue4src/Programs/UnrealBuildTool"
+ patch "$ubt/Platform/Linux/LinuxToolChain.cs" no-pie.patch
+
+ hal="$ue4src/Runtime/Core/Public/HAL"
+ patch "$hal/Platform.h" Platform-bitwise-or.patch
+
linuxToolChain="$ue4src/Programs/UnrealBuildTool/Platform/Linux/LinuxToolChain.cs"
patch "$linuxToolChain" ignore-return-value-error.patch
-
+ patch "$linuxToolChain" clang-70-support.patch
cp "$srcdir/Makefile" "$srcdir/UnrealEngine/Makefile"
patch -p0 -i only-generate-makefile.patch
@@ -83,6 +128,8 @@ prepare() {
# clean up old builds before building a new version
#git clean -xdf
+ # TODO check if setup files already exist. Check if file edited recently
+ echo "Running setup"
./Setup.sh
patch "$ue4src/Programs/UnrealBuildTool/Platform/HTML5/HTML5SDKInfo.cs" "$srcdir/html5-build.patch"
diff --git a/Platform-bitwise-or.patch b/Platform-bitwise-or.patch
new file mode 100644
index 000000000000..491d8f224668
--- /dev/null
+++ b/Platform-bitwise-or.patch
@@ -0,0 +1,11 @@
+--- Platform.h 2018-10-11 14:05:07.503192188 -0500
++++ Platform.h_new 2018-10-11 14:52:43.025935194 -0500
+@@ -802,7 +802,7 @@
+ static_assert((!TAreTypesEqual<ANSICHAR, WIDECHAR>::Value), "ANSICHAR and WIDECHAR should be different types.");
+ static_assert((!TAreTypesEqual<ANSICHAR, UCS2CHAR>::Value), "ANSICHAR and CHAR16 should be different types.");
+ static_assert((!TAreTypesEqual<WIDECHAR, UCS2CHAR>::Value), "WIDECHAR and CHAR16 should be different types.");
+- static_assert((TAreTypesEqual<TCHAR, ANSICHAR>::Value || TAreTypesEqual<TCHAR, WIDECHAR>::Value), "TCHAR should either be ANSICHAR or WIDECHAR.");
++ static_assert((TAreTypesEqual<TCHAR, ANSICHAR>::Value | TAreTypesEqual<TCHAR, WIDECHAR>::Value), "TCHAR should either be ANSICHAR or WIDECHAR.");
+
+ static_assert(sizeof(uint8) == 1, "BYTE type size test failed.");
+ static_assert(int32(uint8(-1)) == 0xFF, "BYTE type sign test failed.");
diff --git a/Player-move.patch b/Player-move.patch
new file mode 100644
index 000000000000..188cf64fee12
--- /dev/null
+++ b/Player-move.patch
@@ -0,0 +1,13 @@
+--- Player.cpp 2018-10-13 13:38:00.969011532 -0500
++++ Player_new.cpp 2018-10-13 23:40:51.971677987 -0500
+@@ -64,7 +64,9 @@
+
+ if (!bWriteToLog)
+ {
+- return StrOut;
++ typedef FConsoleOutputDevice &FConsoleOutputDeviceRef;
++ FConsoleOutputDeviceRef &&StrOut_ref = StrOut;
++ return (FConsoleOutputDevice&&)StrOut_ref;
+ }
+
+ return TEXT("");
diff --git a/SBlueprintPalette.patch b/SBlueprintPalette.patch
new file mode 100644
index 000000000000..905785ca5521
--- /dev/null
+++ b/SBlueprintPalette.patch
@@ -0,0 +1,13 @@
+--- SBlueprintPalette.cpp 2018-10-13 13:38:00.569008108 -0500
++++ SBlueprintPalette_new.cpp 2018-10-13 23:05:58.184420516 -0500
+@@ -317,10 +317,6 @@
+ {
+ ToolTipOut = NodeToolTipText;
+ }
+- else
+- {
+- ToolTipOut = ToolTipOut;
+- }
+
+ // Ask node for a palette icon
+ FLinearColor IconLinearColor = FLinearColor::White;
diff --git a/UnrealExporter-move.patch b/UnrealExporter-move.patch
new file mode 100644
index 000000000000..41f32d642c91
--- /dev/null
+++ b/UnrealExporter-move.patch
@@ -0,0 +1,23 @@
+--- UnrealExporter.cpp 2018-10-13 13:38:00.979011618 -0500
++++ UnrealExporter_new.cpp 2018-10-13 23:49:58.100180446 -0500
+@@ -865,7 +865,10 @@
+ Output.Logf(TEXT("Components for '%s':\r\n"), *Object->GetFullName());
+ ExportProperties(NULL, Output, Object->GetClass(), (uint8*)Object, 2, NULL, NULL, Object, PPF_SubobjectsOnly);
+ Output.Logf(TEXT("<--- DONE!\r\n"));
+- return Output;
++
++ typedef FStringOutputDevice &FStringOutputDeviceRef;
++ FStringOutputDeviceRef &&Output_ref = Output;
++ return (FStringOutputDevice&&)Output_ref;
+ }
+
+
+@@ -885,5 +888,7 @@
+ const FExportObjectInnerContext Context;
+ UExporter::ExportToOutputDevice(&Context, Object, NULL, Archive, TEXT("copy"), 0, PPF_Copy | PPF_DebugDump, false);
+
+- return Archive;
++ typedef FStringOutputDevice &FStringOutputDeviceRef;
++ FStringOutputDeviceRef && Archive_ref = Archive;
++ return (FStringOutputDevice&&)Archive_ref;
+ }
diff --git a/UnrealSourceFile-move.patch b/UnrealSourceFile-move.patch
new file mode 100644
index 000000000000..29873f69d59a
--- /dev/null
+++ b/UnrealSourceFile-move.patch
@@ -0,0 +1,13 @@
+--- UnrealSourceFile.cpp 2018-10-12 22:40:20.667309568 -0500
++++ UnrealSourceFile.cpp_new 2018-10-12 22:39:50.387963519 -0500
+@@ -46,7 +46,9 @@
+ }
+ }
+
+- return Out;
++ typedef FStringOutputDevice &FStringOutputDeviceRef;
++ FStringOutputDeviceRef &&Out_ref = Out;
++ return (FStringOutputDevice&&)Out_ref;
+ }
+
+ FString FUnrealSourceFile::GetStrippedFilename() const
diff --git a/clang-70-support.patch b/clang-70-support.patch
new file mode 100644
index 000000000000..4c6adb461f51
--- /dev/null
+++ b/clang-70-support.patch
@@ -0,0 +1,11 @@
+--- LinuxToolChain.cs 2018-10-10 21:03:32.148896937 -0500
++++ LinuxToolChain.cs_new 2018-10-10 21:11:47.556037751 -0500
+@@ -137,7 +137,7 @@
+ throw new BuildException("Unable to build: no compatible clang version found. Please run Setup.sh");
+ }
+ // prevent unknown clangs since the build is likely to fail on too old or too new compilers
+- else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 60 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 38)
++ else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 70 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 38)
+ {
+ throw new BuildException(
+ string.Format("This version of the Unreal Engine can only be compiled with clang 6.0, 5.0, 4.0, 3.9, 3.8. clang {0} may not build it - please use a different version.",
diff --git a/no-pie.patch b/no-pie.patch
new file mode 100644
index 000000000000..f6be2573bc24
--- /dev/null
+++ b/no-pie.patch
@@ -0,0 +1,11 @@
+--- LinuxToolChain.cs 2018-10-12 22:43:55.832656436 -0500
++++ LinuxToolChain.cs_new 2018-10-13 00:06:06.833791928 -0500
+@@ -816,7 +816,7 @@
+ Result += " -Wl,--build-id";
+ if (bSuppressPIE && !LinkEnvironment.bIsBuildingDLL)
+ {
+- Result += " -Wl,-nopie";
++ Result += " -Wl,--no-pie";
+ }
+
+ // whether we actually can do that is checked in CanUseLTO() earlier