summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-05-03 17:43:20 -0400
committeracerix2016-05-03 17:43:20 -0400
commit2c85fe9b5aee745580c89ac9e5856c70f903c025 (patch)
tree068463e5e969aa5b9536fc5089cb87ad6e78e168
parentfa2ac64123caae9f6806340776d28b02f31551b6 (diff)
downloadaur-2c85fe9b5aee745580c89ac9e5856c70f903c025.tar.gz
make the install dir writable to fix segfault
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--UE4Editor.desktop5
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c84535d52360..cdb1764cb5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 2 00:19:26 UTC 2016
+# Tue May 3 21:43:17 UTC 2016
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.11.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
diff --git a/PKGBUILD b/PKGBUILD
index 89e628a12aca..839640b16454 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname='unreal-engine'
pkgver=4.11.2
-pkgrel=1
+pkgrel=2
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
@@ -34,8 +34,15 @@ package() {
install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.pdf"
install -d "$pkgdir/opt/$pkgname"
+
+ # copy the entire build dir, ~22 GiB
+ # @todo only copy what is needed
cp -r * "$pkgdir/opt/$pkgname/"
+ # make the whole thing world writable, otherwise there is a segmentation fault when starting the editor
+ # @todo find out what specifically needs to writable
+ chmod -R a+w "$pkgdir/opt/$pkgname/"
+
install -Dm644 Engine/Content/Editor/Slate/About/UE4Icon.png "$pkgdir/usr/share/pixmaps/UE4Editor.png"
install -Dm644 "$startdir/UE4Editor.desktop" "$pkgdir/usr/share/applications/UE4Editor.desktop"
}
diff --git a/UE4Editor.desktop b/UE4Editor.desktop
index 3f8612663d01..d837d2e1635c 100644
--- a/UE4Editor.desktop
+++ b/UE4Editor.desktop
@@ -2,8 +2,9 @@
Type=Application
Name=Unreal Engine 4 Editor
Comment=Editor for Unreal Engine 4
-Path=/opt/unreal-engine
-Exec=/opt/unreal-engine/Engine/Binaries/Linux/UE4Editor
+Path=/opt/unreal-engine/Engine/Binaries/Linux/
+Exec=/opt/unreal-engine/Engine/Binaries/Linux/UE4Editor %F
+MimeType=text/x-uproject
Icon=UE4Editor
Terminal=false
Categories=Development;