summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2017-10-27 02:16:11 -0500
committerZerophase2017-10-27 02:26:05 -0500
commit36deb9dec32f4300965453716dd491d55570248c (patch)
tree12618f24cc4fc7f745c591b93bc96a4b1b0212da
parentc2667bc8e63afa6b647078026841088e45e6e620 (diff)
downloadaur-36deb9dec32f4300965453716dd491d55570248c.tar.gz
Fixes html5 build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--html5-build.patch11
-rw-r--r--xlocale-crash.patch11
4 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b9611ebfcc6..03fd46b16e63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Oct 26 03:53:17 UTC 2017
+# Fri Oct 27 07:25:33 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.18.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
@@ -24,12 +24,14 @@ pkgbase = unreal-engine
source = disable-pie.patch
source = only-generate-makefile.patch
source = xlocale-crash.patch
+ source = html5-build.patch
sha256sums = SKIP
sha256sums = 46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118
sha256sums = 918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c
sha256sums = 32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b
sha256sums = dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3
- sha256sums = c40dece3a3d5cdf29ae2a2dd6ed442e151856b9ca6c88e7f8ac09d652bfba1f2
+ sha256sums = 66c575805e21ba1dec6da7374f3f8fe62195fd6d271dd6751b600538f1dae9b6
+ sha256sums = 9fd6d16d56fbe0489a2580b86359df84b83a6987b5760a9e57ae0898f51943ac
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 3ad3bb14ae2d..06e92b044dc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname='unreal-engine'
pkgver=4.18.0
# shellcheck disable=SC2034
{
- pkgrel=1
+ pkgrel=2
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
@@ -24,6 +24,7 @@ pkgver=4.18.0
'disable-pie.patch'
'only-generate-makefile.patch'
'xlocale-crash.patch'
+ 'html5-build.patch'
)
sha256sums=('SKIP'
@@ -31,7 +32,8 @@ sha256sums=('SKIP'
'918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c'
'32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b'
'dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855')
+ '66c575805e21ba1dec6da7374f3f8fe62195fd6d271dd6751b600538f1dae9b6'
+ '9fd6d16d56fbe0489a2580b86359df84b83a6987b5760a9e57ae0898f51943ac')
# Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
options=(!strip)
@@ -64,7 +66,9 @@ prepare() {
#git clean -xdf
./Setup.sh
+
patch "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale" "$srcdir/xlocale-crash.patch"
+ patch "$ue4src/Programs/UnrealBuildTool/Platform/HTML5/HTML5SDKInfo.cs" "$srcdir/html5-build.patch"
./GenerateProjectFiles.sh
}
diff --git a/html5-build.patch b/html5-build.patch
new file mode 100644
index 000000000000..49703f574f61
--- /dev/null
+++ b/html5-build.patch
@@ -0,0 +1,11 @@
+--- HTML5SDKInfo.cs 2017-10-27 01:48:21.310579458 -0500
++++ HTML5SDKInfo_new.cs 2017-10-27 02:10:28.642228303 -0500
+@@ -176,7 +176,7 @@
+
+ case UnrealTargetPlatform.Mac:
+ case UnrealTargetPlatform.Linux:
+- return "/usr/bin/python";
++ return "/usr/bin/python2";
+
+ default:
+ return "error_unknown_platform";
diff --git a/xlocale-crash.patch b/xlocale-crash.patch
index e69de29bb2d1..e7bd661c4b3e 100644
--- a/xlocale-crash.patch
+++ b/xlocale-crash.patch
@@ -0,0 +1,11 @@
+--- __locale 2017-10-27 01:51:25.516580511 -0500
++++ __locale_new 2017-10-27 02:21:41.157925656 -0500
+@@ -36,7 +36,7 @@
+ # include <support/newlib/xlocale.h>
+ #elif (defined(__GLIBC__) || defined(__APPLE__) || defined(__FreeBSD__) \
+ || defined(__EMSCRIPTEN__) || defined(__IBMCPP__))
+-# include <xlocale.h>
++# include <locale.h>
+ #elif defined(_LIBCPP_HAS_MUSL_LIBC)
+ # include <support/musl/xlocale.h>
+ #endif // __GLIBC__ || __APPLE__ || __FreeBSD__ || __sun__ || __EMSCRIPTEN__ || __IBMCPP__