summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-06-08 12:48:45 -0400
committeracerix2016-06-08 12:48:45 -0400
commit38eb16ca3def181c46f462cb2aa0bff727b815d1 (patch)
tree6e5bd972672f253b28a753c0fb859176ccdd6bb5
parent284994021b40b8faea471627926bd509b90d0d8d (diff)
downloadaur-38eb16ca3def181c46f462cb2aa0bff727b815d1.tar.gz
don't install leftover stuff from build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD41
2 files changed, 31 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0049813db3d6..a095d7cdd26a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 3 00:17:30 UTC 2016
+# Wed Jun 8 16:48:42 UTC 2016
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.12.0
+ pkgver = 4.12.1
pkgrel = 1
url = https://www.unrealengine.com/
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = unreal-engine
depends = python
options = !strip
options = staticlibs
- source = git+ssh://github.com/EpicGames/UnrealEngine.git#tag=4.12.0-release
+ source = git+ssh://github.com/EpicGames/UnrealEngine.git#tag=4.12.1-release
source = UE4Editor.desktop
md5sums = SKIP
md5sums = 7a2db62e8d0e8e6f26424768c412d356
diff --git a/PKGBUILD b/PKGBUILD
index cebdcd484246..a0b7561ccb20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# You must register at unrealengine.com and link your github account to access this private repo.
# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
-# The source is about 3.8 GiB, with an extra 3.2 GiB of dependencies downloaded in build(), and may take several hours to compile.
+# The source is about 3.78 GiB, with an extra 3.24 GiB of dependencies downloaded in build(), and may take several hours to compile. (sizes as of 4.12.1)
pkgname='unreal-engine'
pkgver=4.12.1
@@ -26,9 +26,9 @@ options=(!strip staticlibs)
build() {
cd $srcdir/UnrealEngine
- #./Setup.sh
- #./GenerateProjectFiles.sh
- #make
+# ./Setup.sh
+# ./GenerateProjectFiles.sh
+# make
}
package() {
@@ -36,19 +36,34 @@ package() {
cd $srcdir/UnrealEngine
+ # license
install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.pdf"
- install -d "$pkgdir/opt/$pkgname"
-
- install -d - "$pkgdir/opt/$pkgname"
-
- # copy the entire build dir, ~22 GiB
- # @todo only copy what is needed
- cp -r * "$pkgdir/opt/$pkgname/"
-
+ # engine
+ install -d "$pkgdir/opt/$pkgname/Engine"
# these folders needs to be writable, otherwise there is a segmentation fault when starting the editor
- chmod -R a+w "$pkgdir/opt/$pkgname/"
+ # @todo probably not all these folders need to be writable and/or installed, and maybe some should be moved to user's home
+ cp -r Engine/Binaries "$pkgdir/opt/$pkgname/Engine/Binaries"
+ cp -r Engine/Build "$pkgdir/opt/$pkgname/Engine/Build"
+ cp -r Engine/Config "$pkgdir/opt/$pkgname/Engine/Config"
+ cp -r Engine/Content "$pkgdir/opt/$pkgname/Engine/Content"
+ install -d "$pkgdir/opt/$pkgname/Engine/DerivedDataCache" # created when UE4Editor is run
+ cp -r Engine/Documentation "$pkgdir/opt/$pkgname/Engine/Documentation"
+ cp -r Engine/Extras "$pkgdir/opt/$pkgname/Engine/Extras"
+ install -d "$pkgdir/opt/$pkgname/Engine/Intermediate" # create without contents
+ cp -r Engine/Plugins "$pkgdir/opt/$pkgname/Engine/Plugins"
+ cp -r Engine/Programs "$pkgdir/opt/$pkgname/Engine/Programs"
+ cp -r Engine/Saved "$pkgdir/opt/$pkgname/Engine/Saved"
+ cp -r Engine/Shaders "$pkgdir/opt/$pkgname/Engine/Shaders"
+ install -d "$pkgdir/opt/$pkgname/Engine/Source" # create without contents
+ chmod -R a+rwX "$pkgdir/opt/$pkgname/Engine"
+
+ # content
+ cp -r FeaturePacks "$pkgdir/opt/$pkgname/FeaturePacks"
+ cp -r Samples "$pkgdir/opt/$pkgname/Samples"
+ cp -r Templates "$pkgdir/opt/$pkgname/Templates"
+ # icon for .desktop file
install -Dm644 Engine/Source/Programs/UnrealVS/Resources/Preview.png "$pkgdir/usr/share/pixmaps/UE4Editor.png"
}