summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2017-11-15 14:31:54 -0600
committerZerophase2017-11-16 21:30:53 -0600
commit4c2ff7815189582049ec65eaa795c6f2973821c2 (patch)
treea5b5cf7e8b71de6a0e63fc98a3a32ee9b76c7112
parent05cfc467fa0fdde3349bfb9910f4df2d5a3260f1 (diff)
downloadaur-4c2ff7815189582049ec65eaa795c6f2973821c2.tar.gz
Update to 4.18.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--xlocale-crash.patch11
3 files changed, 9 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03fd46b16e63..9611d0d13f6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 27 07:25:33 UTC 2017
+# Fri Nov 17 03:30:32 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.18.0
- pkgrel = 2
+ pkgver = 4.18.1
+ pkgrel = 1
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
@@ -18,19 +18,17 @@ pkgbase = unreal-engine
depends = qt4
depends = python
options = !strip
- source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.18.0-release
+ source = git+ssh://git@github.com/EpicGames/UnrealEngine.git#tag=4.18.1-release
source = UE4Editor.desktop
source = ignore-return-value-error.patch
source = disable-pie.patch
source = only-generate-makefile.patch
- source = xlocale-crash.patch
source = html5-build.patch
sha256sums = SKIP
sha256sums = 46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118
sha256sums = 918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c
- sha256sums = 32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b
+ sha256sums = a8bb46ad630c077dd302cd8397f2c8d79d6bb13dbff1cbfbbdad447033ad3c6e
sha256sums = dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3
- sha256sums = 66c575805e21ba1dec6da7374f3f8fe62195fd6d271dd6751b600538f1dae9b6
sha256sums = 9fd6d16d56fbe0489a2580b86359df84b83a6987b5760a9e57ae0898f51943ac
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 64fb83f1f9f5..4beccf705d1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
# The source is over 8 GiB, with an extra 3 GiB of dependencies downloaded in build(), and may take several hours to compile.
pkgname='unreal-engine'
-pkgver=4.18.0
+pkgver=4.18.1
# shellcheck disable=SC2034
{
- pkgrel=2
+ pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
@@ -23,7 +23,6 @@ pkgver=4.18.0
'ignore-return-value-error.patch'
'disable-pie.patch'
'only-generate-makefile.patch'
- 'xlocale-crash.patch'
'html5-build.patch'
)
@@ -32,7 +31,6 @@ sha256sums=('SKIP'
'918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c'
'a8bb46ad630c077dd302cd8397f2c8d79d6bb13dbff1cbfbbdad447033ad3c6e'
'dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3'
- '6ce0247e233d4eafc7ae294482038addeee7fe2064de627e33839bcc4398a549'
'9fd6d16d56fbe0489a2580b86359df84b83a6987b5760a9e57ae0898f51943ac')
# Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
@@ -66,9 +64,9 @@ prepare() {
#git clean -xdf
./Setup.sh
-
+
dos2unix "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale"
- patch "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale" "$srcdir/xlocale-crash.patch"
+ #patch "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale" "$srcdir/xlocale-crash.patch"
patch "$ue4src/Programs/UnrealBuildTool/Platform/HTML5/HTML5SDKInfo.cs" "$srcdir/html5-build.patch"
./GenerateProjectFiles.sh
}
diff --git a/xlocale-crash.patch b/xlocale-crash.patch
deleted file mode 100644
index e7bd661c4b3e..000000000000
--- a/xlocale-crash.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- __locale 2017-10-27 01:51:25.516580511 -0500
-+++ __locale_new 2017-10-27 02:21:41.157925656 -0500
-@@ -36,7 +36,7 @@
- # include <support/newlib/xlocale.h>
- #elif (defined(__GLIBC__) || defined(__APPLE__) || defined(__FreeBSD__) \
- || defined(__EMSCRIPTEN__) || defined(__IBMCPP__))
--# include <xlocale.h>
-+# include <locale.h>
- #elif defined(_LIBCPP_HAS_MUSL_LIBC)
- # include <support/musl/xlocale.h>
- #endif // __GLIBC__ || __APPLE__ || __FreeBSD__ || __sun__ || __EMSCRIPTEN__ || __IBMCPP__