summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2017-10-25 22:40:06 -0500
committerZerophase2017-10-25 22:53:28 -0500
commit4db2b6b221f39fe1eb76434b24df33ed8aa9cc9d (patch)
treef09a4bacdbd49a840532c58c922208b9adc0bdab
parentc890c31fb580f2b35431ed023e2239b25682f0e0 (diff)
downloadaur-4db2b6b221f39fe1eb76434b24df33ed8aa9cc9d.tar.gz
Fixes xlocale-crash.patch line endings
-rw-r--r--.SRCINFO4
-rw-r--r--.gitattributes1
-rw-r--r--PKGBUILD20
-rw-r--r--xlocale-crash.patch15
4 files changed, 23 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2034100c40a8..0b9611ebfcc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Oct 25 22:38:07 UTC 2017
+# Thu Oct 26 03:53:17 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.18.0
@@ -29,7 +29,7 @@ pkgbase = unreal-engine
sha256sums = 918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c
sha256sums = 32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b
sha256sums = dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3
- sha256sums = 6495cfd1b03aef86d0aca15d5389b4d8ee2d745e900a1956391afcbb4a14dafe
+ sha256sums = c40dece3a3d5cdf29ae2a2dd6ed442e151856b9ca6c88e7f8ac09d652bfba1f2
pkgname = unreal-engine
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..51751533d4b9
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+xlocale-crash.patch eol=crlf
diff --git a/PKGBUILD b/PKGBUILD
index 54056593e0de..905ac11ae001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,14 +26,12 @@ pkgver=4.18.0
'xlocale-crash.patch'
)
- sha256sums=(
- 'SKIP'
- '46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118'
- '918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c'
- '32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b'
- 'dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3'
- '6495cfd1b03aef86d0aca15d5389b4d8ee2d745e900a1956391afcbb4a14dafe'
- )
+sha256sums=('SKIP'
+ '46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118'
+ '918dff809a7e815343a8d233f704f52a910b8f01a9cb3d29de541a0334fecc7c'
+ '32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b'
+ 'dba4b1910dd6424d50a8d95a461c5cf3a96f3e7df0b015624d9bf1c97dc317d3'
+ 'c40dece3a3d5cdf29ae2a2dd6ed442e151856b9ca6c88e7f8ac09d652bfba1f2')
# Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
options=(!strip)
@@ -59,8 +57,8 @@ prepare() {
# cd $srcdir/UnrealEngine/Engine/Plugins/Developer && git clone https://github.com/fire/SensibleEditorSourceCodeAccess
# cd $srcdir/UnrealEngine/Engine/Config/Linux && sed -i '10c\PreferredAccessor=SensibleEditorSourceCodeAccessor' LinuxEngine.ini
- pkgbuild_dir="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
- echo "$pkgbuild_dir"
+ #pkgbuild_dir="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"
+ #echo "$pkgbuild_dir"
# shellcheck disable=SC2164
cd "$srcdir/UnrealEngine"
@@ -68,7 +66,7 @@ prepare() {
#git clean -xdf
./Setup.sh
- patch "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale" "$pkgbuild_dir/xlocale-crash.patch"
+ patch "$ue4src/ThirdParty/Linux/LibCxx/include/c++/v1/__locale" "$srcdir/xlocale-crash.patch"
./GenerateProjectFiles.sh
}
diff --git a/xlocale-crash.patch b/xlocale-crash.patch
index 998e1e98514d..b1a171ab262d 100644
--- a/xlocale-crash.patch
+++ b/xlocale-crash.patch
@@ -1,4 +1,11 @@
-39c39
-< # include <xlocale.h>
----
-> # include <locale.h>
+--- __locale 2017-10-25 22:26:36.267094964 -0500
++++ __locale.new 2017-10-25 22:38:20.951904398 -0500
+@@ -36,7 +36,7 @@
+ # include <support/newlib/xlocale.h>
+ #elif (defined(__GLIBC__) || defined(__APPLE__) || defined(__FreeBSD__) \
+ || defined(__EMSCRIPTEN__) || defined(__IBMCPP__))
+-# include <xlocale.h>
++# include <locale.h>
+ #elif defined(_LIBCPP_HAS_MUSL_LIBC)
+ # include <support/musl/xlocale.h>
+ #endif // __GLIBC__ || __APPLE__ || __FreeBSD__ || __sun__ || __EMSCRIPTEN__ || __IBMCPP__