summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2017-09-18 17:39:53 -0500
committerZerophase2017-09-18 17:39:53 -0500
commit7b0b91410d472e9e6518839cd8eb7e25d2613393 (patch)
treefad9a647fdfdd6dba2d76abe5cd21c9f2a5f61ae
parent0b68b3e6fea0b8c2320ea318c53988841da56599 (diff)
downloadaur-7b0b91410d472e9e6518839cd8eb7e25d2613393.tar.gz
update to clang 5.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--only-generate-makefile.patch9
-rw-r--r--support-current-clang.patch15
-rw-r--r--type-constructor-error.patch160
-rw-r--r--wunused-lambda-capture.patch13
6 files changed, 221 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 022dec16697a..72dd0df44b53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Sep 10 23:17:32 UTC 2017
+# Mon Sep 18 22:39:36 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.17.1
- pkgrel = 2
+ pkgrel = 3
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
@@ -22,10 +22,18 @@ pkgbase = unreal-engine
source = UE4Editor.desktop
source = ignore-return-value-error.patch
source = disable-pie.patch
+ source = support-current-clang.patch
+ source = wunused-lambda-capture.patch
+ source = type-constructor-error.patch
+ source = only-generate-makefile.patch
sha256sums = SKIP
sha256sums = 46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118
sha256sums = d0a43ec1958790be11c3260d6b93c8fd29d9c7fd3c3f57574d5807b9390a95fa
sha256sums = 32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b
+ sha256sums = 94874165fd685a4886a5cee6997bcc95e9f41b6d25a037f967171da3825f5e18
+ sha256sums = 9f94c237d7b209a5dd615648756b992d6caf22dff1c63da74ffb108e896d03ff
+ sha256sums = f22a3a508f128d95b8dcb829ef6df8f1f0bb4c90c591771c0b46591a8c393289
+ sha256sums = 9d642938263cb7b0539cdf2509bc2fe7faf05c48a5d319f31e0dc7a02e50d3ae
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index cc98ac36db1b..6fd8b3f85a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname='unreal-engine'
pkgver=4.17.1
-pkgrel=2
+pkgrel=3
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
@@ -20,6 +20,10 @@ source=(
'UE4Editor.desktop'
'ignore-return-value-error.patch'
'disable-pie.patch'
+ 'support-current-clang.patch'
+ 'wunused-lambda-capture.patch'
+ 'type-constructor-error.patch'
+ 'only-generate-makefile.patch'
)
sha256sums=(
@@ -27,14 +31,23 @@ sha256sums=(
'46871ed662a3c97698be609d27da280d9000ec97183f1fa6592986f9910a2118'
'd0a43ec1958790be11c3260d6b93c8fd29d9c7fd3c3f57574d5807b9390a95fa'
'32ab20e37f5595eff73fb7ee7916ecae19a47f72875f448663941621d166c13b'
+ '94874165fd685a4886a5cee6997bcc95e9f41b6d25a037f967171da3825f5e18'
+ '9f94c237d7b209a5dd615648756b992d6caf22dff1c63da74ffb108e896d03ff'
+ 'f22a3a508f128d95b8dcb829ef6df8f1f0bb4c90c591771c0b46591a8c393289'
+ '9d642938263cb7b0539cdf2509bc2fe7faf05c48a5d319f31e0dc7a02e50d3ae'
)
# Package is 3 Gib smaller with "strip" but it's skipped because it takes a long time and generates many warnings
options=(!strip)
prepare() {
+ patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" support-current-clang.patch
patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" ignore-return-value-error.patch
patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" disable-pie.patch
+ patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" wunused-lambda-capture.patch
+
+ patch -p0 -i only-generate-makefile.patch
+ patch -p0 -i type-constructor-error.patch
# Source Code Accessors
diff --git a/only-generate-makefile.patch b/only-generate-makefile.patch
new file mode 100644
index 000000000000..52b6dce36026
--- /dev/null
+++ b/only-generate-makefile.patch
@@ -0,0 +1,9 @@
+--- UnrealEngine/Engine/Build/BatchFiles/Linux/GenerateProjectFiles.sh 2017-09-18 16:43:36.818934026 -0500
++++ - 2017-09-18 16:54:43.349891714 -0500
+@@ -25,5 +25,5 @@
+ /p:Configuration="Development"
+
+ # pass all parameters to UBT
+-mono Binaries/DotNET/UnrealBuildTool.exe -makefile -kdevelopfile -qmakefile -cmakefile -codelitefile "$@"
++mono Binaries/DotNET/UnrealBuildTool.exe -makefile #-kdevelopfile -qmakefile -cmakefile -codelitefile "$@"
+ set +x
diff --git a/support-current-clang.patch b/support-current-clang.patch
new file mode 100644
index 000000000000..83c636446349
--- /dev/null
+++ b/support-current-clang.patch
@@ -0,0 +1,15 @@
+--- LinuxToolChain.cs 2017-09-18 11:35:46.416863571 -0500
++++ LinuxToolChain_new.cs 2017-09-18 11:36:56.715365235 -0500
+@@ -102,10 +102,10 @@
+ throw new BuildException("clang 3.4.x is known to miscompile the engine - refusing to register the Linux toolchain.");
+ }
+ // prevent unknown clangs since the build is likely to fail on too old or too new compilers
+- else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 40 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 35)
++ else if ((CompilerVersionMajor * 10 + CompilerVersionMinor) > 50 || (CompilerVersionMajor * 10 + CompilerVersionMinor) < 35)
+ {
+ throw new BuildException(
+- string.Format("This version of the Unreal Engine can only be compiled with clang 4.0, 3.9, 3.8, 3.7, 3.6 and 3.5. clang {0} may not build it - please use a different version.",
++ string.Format("This version of the Unreal Engine can only be compiled with clang 5.0, 4.0, 3.9, 3.8, 3.7, 3.6 and 3.5. clang {0} may not build it - please use a different version.",
+ CompilerVersionString)
+ );
+ }
diff --git a/type-constructor-error.patch b/type-constructor-error.patch
new file mode 100644
index 000000000000..e74c50398ef0
--- /dev/null
+++ b/type-constructor-error.patch
@@ -0,0 +1,160 @@
+--- UnrealEngine/Engine/Source/Editor/Kismet/Private/DiffUtils.cpp 2017-09-18 10:06:49.748755011 -0500
++++ - 2017-09-18 15:32:42.495191548 -0500
+@@ -669,7 +669,7 @@
+ const auto GenerateWidget = []() -> TSharedRef<SWidget>
+ {
+ return SNew(STextBlock)
+- .ColorAndOpacity(FLinearColor::FLinearColor(.7f, .7f, .7f))
++ .ColorAndOpacity(FLinearColor(.7f, .7f, .7f))
+ .TextStyle(FEditorStyle::Get(), TEXT("BlueprintDif.ItalicText"))
+ .Text(NSLOCTEXT("FBlueprintDifferenceTreeEntry", "NoDifferencesLabel", "No differences detected..."));
+ };
+@@ -688,7 +688,7 @@
+ const auto GenerateWidget = []() -> TSharedRef<SWidget>
+ {
+ return SNew(STextBlock)
+- .ColorAndOpacity(FLinearColor::FLinearColor(.7f, .7f, .7f))
++ .ColorAndOpacity(FLinearColor(.7f, .7f, .7f))
+ .TextStyle(FEditorStyle::Get(), TEXT("BlueprintDif.ItalicText"))
+ .Text(NSLOCTEXT("FBlueprintDifferenceTreeEntry", "AnimBlueprintsNotSupported", "Warning: Detecting differences in Animation Blueprint specific data is not yet supported..."));
+ };
+@@ -722,7 +722,7 @@
+ const auto GenerateWidget = []() -> TSharedRef<SWidget>
+ {
+ return SNew(STextBlock)
+- .ColorAndOpacity(FLinearColor::FLinearColor(.7f, .7f, .7f))
++ .ColorAndOpacity(FLinearColor(.7f, .7f, .7f))
+ .TextStyle(FEditorStyle::Get(), TEXT("BlueprintDif.ItalicText"))
+ .Text(NSLOCTEXT("FBlueprintDifferenceTreeEntry", "WidgetTreeNotSupported", "Warning: Detecting differences in Widget Blueprint specific data is not yet supported..."));
+ };
+--- UnrealEngine/Engine/Plugins/Developer/OneSkyLocalizationService/Source/OneSkyLocalizationService/Private/OneSkyLocalizationServiceOperations.cpp 2017-09-18 10:06:49.198766497 -0500
++++ - 2017-09-18 14:47:14.314913930 -0500
+@@ -1136,7 +1136,7 @@
+ int32 InProjectId = -1;
+ int32 InImportId = -1;
+ int32 InExecutionDelayInSeconds = -1;
+- FDateTime InCreationTimeStamp = FDateTime::FDateTime(1970, 1, 1);
++ FDateTime InCreationTimeStamp = FDateTime(1970, 1, 1);
+
+ if (ShowImportTaskOp.IsValid())
+ {
+--- UnrealEngine/Engine/Source/Editor/Sequencer/Private/SequencerEdMode.cpp 2017-09-18 10:06:49.818753548 -0500
++++ - 2017-09-18 15:30:59.676115828 -0500
+@@ -470,7 +470,7 @@
+ }
+ else if (TrailActor != nullptr)
+ {
+- TrailActor->AddFrameMeshComponent(NewTime, FTransform::FTransform(NewRot, NewPos, FVector::FVector(3.0f)));
++ TrailActor->AddFrameMeshComponent(NewTime, FTransform(NewRot, NewPos, FVector(3.0f)));
+ }
+ }
+ OldTime = NewTime;
+@@ -522,7 +522,7 @@
+
+ for (UMovieScene3DTransformSection* Section : AllSections)
+ {
+- TrailActor->AddKeyMeshActor(NewKeyTime, FTransform::FTransform(NewKeyRot, NewKeyPos, FVector::FVector(3.0f)), Section);
++ TrailActor->AddKeyMeshActor(NewKeyTime, FTransform(NewKeyRot, NewKeyPos, FVector(3.0f)), Section);
+ }
+ }
+
+--- UnrealEngine/Engine/Source/Editor/VREditor/VREditorActions.cpp 2017-09-18 10:06:49.888752087 -0500
++++ - 2017-09-18 15:34:43.700976663 -0500
+@@ -325,7 +325,7 @@
+ {
+ TCHAR CharKey = InChar[CharIndex];
+ const bool bRepeat = false;
+- FCharacterEvent CharacterEvent(CharKey, FModifierKeysState::FModifierKeysState(), 0, bRepeat);
++ FCharacterEvent CharacterEvent(CharKey, FModifierKeysState(), 0, bRepeat);
+ FSlateApplication::Get().ProcessKeyCharEvent(CharacterEvent);
+ }
+
+@@ -348,12 +348,12 @@
+ uint32 KeyCode = KeyCodePtr ? *KeyCodePtr : 0;
+ uint32 CharCode = CharCodePtr ? *CharCodePtr : 0;
+
+- FKeyEvent KeyEvent( Key, FModifierKeysState::FModifierKeysState(), 0, bRepeat, KeyCode, CharCode );
++ FKeyEvent KeyEvent( Key, FModifierKeysState(), 0, bRepeat, KeyCode, CharCode );
+ bool DownResult = FSlateApplication::Get().ProcessKeyDownEvent( KeyEvent );
+
+ if (CharCodePtr)
+ {
+- FCharacterEvent CharacterEvent( CharCode, FModifierKeysState::FModifierKeysState(), 0, bRepeat );
++ FCharacterEvent CharacterEvent( CharCode, FModifierKeysState(), 0, bRepeat );
+ FSlateApplication::Get().ProcessKeyCharEvent( CharacterEvent );
+ }
+ }
+@@ -367,7 +367,7 @@
+ uint32 KeyCode = KeyCodePtr ? *KeyCodePtr : 0;
+ uint32 CharCode = CharCodePtr ? *CharCodePtr : 0;
+
+- FKeyEvent KeyEvent( Key, FModifierKeysState::FModifierKeysState(), 0, false, KeyCode, CharCode );
++ FKeyEvent KeyEvent( Key, FModifierKeysState(), 0, false, KeyCode, CharCode );
+ FSlateApplication::Get().ProcessKeyUpEvent( KeyEvent );
+ }
+
+--- UnrealEngine/Engine/Source/Editor/VREditor/UI/VREditorRadialFloatingUI.cpp 2017-09-18 10:06:49.888752087 -0500
++++ - 2017-09-18 15:04:03.863734470 -0500
+@@ -433,7 +433,7 @@
+ {
+ if (CurrentlyHoveredButton.Get() != nullptr)
+ {
+- const FPointerEvent& SimulatedPointer = FPointerEvent::FPointerEvent();
++ const FPointerEvent& SimulatedPointer = FPointerEvent();
+ CurrentlyHoveredButton->OnMouseLeave(SimulatedPointer);
+ if (CurrentlyHoveredWidget != nullptr)
+ {
+@@ -495,7 +495,7 @@
+ {
+ CurrentlyHoveredButton = StaticCastSharedRef<SButton>(TestWidget);
+ CurrentlyHoveredWidget = WidgetComponents[Index];
+- const FPointerEvent& SimulatedPointer = FPointerEvent::FPointerEvent();
++ const FPointerEvent& SimulatedPointer = FPointerEvent();
+ const FGeometry& ChildGeometry = FGeometry();
+
+ // Simulate mouse entering event for the button if it was not previously hovered
+--- UnrealEngine/Engine/Source/Editor/VREditor/UI/VREditorUISystem.cpp 2017-09-18 10:06:49.888752087 -0500
++++ - 2017-09-18 15:07:15.046308985 -0500
+@@ -1725,7 +1725,7 @@
+ {
+ TSharedRef<SImage> Image = StaticCastSharedRef<SImage>(TestWidget);
+ Image->SetRenderTransformPivot(FVector2D(0.5f, 0.5f));
+- Image->SetRenderTransform(FSlateRenderTransform::FTransform2D(4.0f));
++ Image->SetRenderTransform(FTransform2D(4.0f));
+ }
+
+ // Format the button text
+@@ -1935,7 +1935,7 @@
+ FSlateIcon(),
+ FUIAction
+ (
+- FExecuteAction::CreateStatic( &FVREditorActionCallbacks::SimulateCharacterEntry, FString::FString( TEXT( "-" ) ) )
++ FExecuteAction::CreateStatic( &FVREditorActionCallbacks::SimulateCharacterEntry, FString( TEXT( "-" ) ) )
+ )
+ );
+ MenuBuilder.AddMenuEntry(
+@@ -1944,7 +1944,7 @@
+ FSlateIcon(),
+ FUIAction
+ (
+- FExecuteAction::CreateStatic( &FVREditorActionCallbacks::SimulateCharacterEntry, FString::FString( TEXT( "." ) ) )
++ FExecuteAction::CreateStatic( &FVREditorActionCallbacks::SimulateCharacterEntry, FString( TEXT( "." ) ) )
+ )
+ );
+ MenuBuilder.AddMenuEntry(
+@@ -2418,7 +2418,7 @@
+ {
+ TSharedRef<SButton> Button = StaticCastSharedRef<SButton>(TestWidget);
+ Button->SetRenderTransformPivot(FVector2D(0.5f, 0.5f));
+- Button->SetRenderTransform(FSlateRenderTransform::FTransform2D(2.0f));
++ Button->SetRenderTransform(FTransform2D(2.0f));
+ }
+ const bool bWithSceneComponent = false;
+ PreviewPanel->SetSlateWidget(WidgetToDraw);
+@@ -2475,4 +2475,4 @@
+ }
+ }
+
+-#undef LOCTEXT_NAMESPACE
+\ No newline at end of file
++#undef LOCTEXT_NAMESPACE
diff --git a/wunused-lambda-capture.patch b/wunused-lambda-capture.patch
new file mode 100644
index 000000000000..d7d57c33805e
--- /dev/null
+++ b/wunused-lambda-capture.patch
@@ -0,0 +1,13 @@
+--- Programs/UnrealBuildTool/Linux/LinuxToolChain.cs 2017-09-18 13:23:56.529341978 -0500
++++ - 2017-09-18 13:38:41.330879953 -0500
+@@ -390,6 +390,10 @@
+ {
+ Result += " -Wno-undefined-var-template"; // not really a good warning to disable
+ }
++ if(CompilerVersionGreaterOrEqual(5,0,0))
++ {
++ Result += " -Wno-unused-lambda-capture";
++ }
+ }
+
+ Result += " -Wno-unused-variable";