summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-06-02 20:17:32 -0400
committeracerix2016-06-02 20:17:32 -0400
commit9f3ca698693a7a6fd3f86cd31351522babf91b9c (patch)
tree1ca045e48eb43e4af2c5f43adb54494c26794a50
parent2a319e41c91552823de05afc4f3f71d4e1261bd9 (diff)
downloadaur-9f3ca698693a7a6fd3f86cd31351522babf91b9c.tar.gz
Update to 4.12
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD14
-rw-r--r--setup-depend-clang35.patch11
3 files changed, 14 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e6d177a6e84..0049813db3d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
# Generated by mksrcinfo v8
-# Thu May 12 00:57:37 UTC 2016
+# Fri Jun 3 00:17:30 UTC 2016
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
- pkgver = 4.11.2
- pkgrel = 3
+ pkgver = 4.12.0
+ pkgrel = 1
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
- makedepends = clang35
+ makedepends = clang
makedepends = mono
makedepends = dos2unix
makedepends = cmake
- depends = icu53
+ depends = icu
depends = xdg-user-dirs
+ depends = sdl2
+ depends = qt4
+ depends = python
options = !strip
options = staticlibs
- source = git+ssh://github.com/EpicGames/UnrealEngine.git#tag=4.11.2-release
+ source = git+ssh://github.com/EpicGames/UnrealEngine.git#tag=4.12.0-release
source = UE4Editor.desktop
- source = setup-depend-clang35.patch
md5sums = SKIP
md5sums = 7a2db62e8d0e8e6f26424768c412d356
- md5sums = 0aef7bb2dbb1aeb5c65d3f90ca89009d
pkgname = unreal-engine
diff --git a/PKGBUILD b/PKGBUILD
index 7245bd670217..836f4ce4ab14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
# Maintainer: Dylan Ferris <dylan@psilly.com>
# You must register at unrealengine.com and link your github account to access this private repo.
-# For more info, see: https://wiki.archlinux.org/index.php/Unreal_Engine_4
+# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
# The source is about 3.8 GiB, with an extra 3.2 GiB of dependencies downloaded in build(), and may take several hours to compile.
pkgname='unreal-engine'
-pkgver=4.11.2
-pkgrel=3
+pkgver=4.12.0
+pkgrel=1
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
-makedepends=('clang35' 'mono' 'dos2unix' 'cmake')
-depends=('icu53' 'xdg-user-dirs')
+makedepends=('clang' 'mono' 'dos2unix' 'cmake')
+depends=('icu' 'xdg-user-dirs' 'sdl2' 'qt4' 'python')
license=('custom:UnrealEngine')
source=(
"git+ssh://github.com/EpicGames/UnrealEngine.git#tag=$pkgver-release"
'UE4Editor.desktop'
- 'setup-depend-clang35.patch'
)
md5sums=(
'SKIP'
'7a2db62e8d0e8e6f26424768c412d356'
- '0aef7bb2dbb1aeb5c65d3f90ca89009d'
)
options=(!strip staticlibs)
build() {
- patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" setup-depend-clang35.patch
-
cd $srcdir/UnrealEngine
./Setup.sh
./GenerateProjectFiles.sh
diff --git a/setup-depend-clang35.patch b/setup-depend-clang35.patch
deleted file mode 100644
index cbb23eb7f516..000000000000
--- a/setup-depend-clang35.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh 2016-05-08 12:58:34.474342800 +0300
-+++ Setup.sh 2016-05-09 10:42:49.026013000 +0300
-@@ -124,7 +124,7 @@
-
- # Arch Linux
- if [[ "$ID" == "arch" ]] || [[ "$ID_LIKE" == "arch" ]]; then
-- DEPS="clang mono python sdl2 qt4 dos2unix cmake"
-+ DEPS="clang35 mono python sdl2 qt4 dos2unix cmake"
- MISSING=false
- for DEP in $DEPS; do
- if ! pacman -Qs $DEP > /dev/null 2>&1; then