summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZerophase2017-05-08 21:24:26 -0500
committerZerophase2017-05-08 21:24:52 -0500
commitcb9679056636e7358cdffda76b5a5b9b4ec2b8a8 (patch)
treead60553883fa53453b9f474fad329c13321e8f45
parentfa2d87acd090ef199875e59fb90cf9cb4ca9c5f5 (diff)
downloadaur-cb9679056636e7358cdffda76b5a5b9b4ec2b8a8.tar.gz
Updates Unreal 4.15.2 to support Clang 4.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--LMStats.patch18
-rw-r--r--PKGBUILD12
-rw-r--r--ParticleEmitterInstances.patch11
5 files changed, 47 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421eb4ef9bbd..2fe90041c294 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Tue May 2 19:49:56 UTC 2017
+# Tue May 9 00:47:21 UTC 2017
pkgbase = unreal-engine
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.15.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.unrealengine.com/
arch = x86_64
license = custom:UnrealEngine
- makedepends = clang<4.0.0
+ makedepends = clang
makedepends = mono
makedepends = dos2unix
makedepends = cmake
@@ -22,10 +22,14 @@ pkgbase = unreal-engine
source = UE4Editor.desktop
source = remove-clang35-dependency.patch
source = ignore-return-value-error.patch
+ source = ParticleEmitterInstances.patch
+ source = LMStats.patch
md5sums = SKIP
md5sums = c7fc35a7eb9e23c0a9b7c593f7f9878d
md5sums = 271579e814358390d210d57c724a3b00
md5sums = a5bb2f9ebc7379b603e3293880dc5c12
+ md5sums = 21da50059f3b805d2dc78638efac0b1b
+ md5sums = abe70f602445e9465c1eff2769bc7d61
pkgname = unreal-engine
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72b292003222
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+unreal-engine-*
+UnrealEngine/*
diff --git a/LMStats.patch b/LMStats.patch
new file mode 100644
index 000000000000..f5433afd0011
--- /dev/null
+++ b/LMStats.patch
@@ -0,0 +1,18 @@
+--- LMStats.h 2017-05-08 18:49:02.041178135 -0500
++++ LMStats_new.h 2017-05-08 19:12:24.930813731 -0500
+@@ -7,7 +7,7 @@
+ // basic stuff needed by everybody
+ #pragma warning( disable: 4799 ) // function '...' has no EMMS instruction)
+
+-#if PLATFORM_MAC || PLATFORM_LINUX
++#if PLATFORM_MAC || PLATFORM_LINUX && !__has_builtin(__builtin_ia32_rdtsc)
+ inline unsigned long long __rdtsc()
+ {
+ unsigned long long Low, High;
+@@ -197,4 +197,4 @@
+ float& Value;
+ };
+
+-}
+\ No newline at end of file
++}
diff --git a/PKGBUILD b/PKGBUILD
index 796dd4825255..61a4d830be00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@
pkgname='unreal-engine'
pkgver=4.15.2
-pkgrel=1
+pkgrel=2
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64')
url='https://www.unrealengine.com/'
-makedepends=('clang<4.0.0' 'mono' 'dos2unix' 'cmake' 'git')
+makedepends=('clang' 'mono' 'dos2unix' 'cmake' 'git')
depends=('icu' 'xdg-user-dirs' 'sdl2' 'qt4' 'python')
conflicts=('hardening-wrapper')
license=('custom:UnrealEngine')
@@ -21,6 +21,8 @@ source=(
'UE4Editor.desktop'
'remove-clang35-dependency.patch'
'ignore-return-value-error.patch'
+ 'ParticleEmitterInstances.patch'
+ 'LMStats.patch'
)
md5sums=(
@@ -28,11 +30,15 @@ md5sums=(
'c7fc35a7eb9e23c0a9b7c593f7f9878d'
'271579e814358390d210d57c724a3b00'
'a5bb2f9ebc7379b603e3293880dc5c12'
+ '21da50059f3b805d2dc78638efac0b1b'
+ 'abe70f602445e9465c1eff2769bc7d61'
)
prepare() {
patch "$srcdir/UnrealEngine/Engine/Build/BatchFiles/Linux/Setup.sh" remove-clang35-dependency.patch
patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealBuildTool/Linux/LinuxToolChain.cs" ignore-return-value-error.patch
+ patch "$srcdir/UnrealEngine/Engine/Source/Runtime/Engine/Private/Particles/ParticleEmitterInstances.cpp" ParticleEmitterInstances.patch
+ patch "$srcdir/UnrealEngine/Engine/Source/Programs/UnrealLightmass/Private/LightmassCore/Misc/LMStats.h" LMStats.patch
cd $srcdir/UnrealEngine
@@ -61,7 +67,7 @@ package() {
cd $srcdir/UnrealEngine
# license
- install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.pdf"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.md"
# engine
install -d "$pkgdir/opt/$pkgname/Engine"
diff --git a/ParticleEmitterInstances.patch b/ParticleEmitterInstances.patch
new file mode 100644
index 000000000000..3e2badf2de25
--- /dev/null
+++ b/ParticleEmitterInstances.patch
@@ -0,0 +1,11 @@
+--- ParticleEmitterInstances.cpp 2017-05-08 18:17:52.511829490 -0500
++++ ParticleEmitterInstance_new.cpp 2017-05-08 18:17:40.082100083 -0500
+@@ -377,7 +377,7 @@
+ {
+ check(ParticleModule);
+ uint8* PrepInstData = GetModuleInstanceData(ParticleModule);
+- check(PrepInstData > 0); // Shouldn't be in the list if it doesn't have data
++ check(PrepInstData != nullptr); // Shouldn't be in the list if it doesn't have data
+ ParticleModule->PrepPerInstanceBlock(this, (void*)PrepInstData);
+ }
+