summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeko-san2023-06-23 13:28:36 -0500
committerNeko-san2023-06-23 13:28:36 -0500
commitcf97af848136b021f96672e0348ffd7255483e4a (patch)
treea1979a187d297c4dcc0ac0896f0f6ea252b8c5a7
parentd8e906267d0a0051997da6901745cecba43e5724 (diff)
downloadaur-cf97af848136b021f96672e0348ffd7255483e4a.tar.gz
Added a clarifying comment in the bash file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xunreal-engine-5.sh4
3 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c52fd161b189..fabc6d7bb424 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -43,7 +43,7 @@ pkgbase = unreal-engine
source = use_system_clang.patch
source = unreal-engine-5-pacman-cache.hook
source = ue5editor.svg
- sha256sums = 2ce4f82af94311656c0bed179cb36349df917f5d59793693ccdc7618e5cf2c3c
+ sha256sums = b3d5f90730116a1a92b17b39f511561cb37fc87b3a78a2e7fe892dca007a1ff4
sha256sums = c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca
sha256sums = b0a57db9a44d0001dc76ca8504d93e273af30093c6a993a5969d82b0ace54b98
sha256sums = 9386160a91594abeeaf4fe02fea562e7a4ead4c6f9a258c2a37b2e5f10e7deca
diff --git a/PKGBUILD b/PKGBUILD
index 5f30756db6f1..c682abd3785f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,7 @@ source=('unreal-engine-5.sh'
'use_system_clang.patch'
'unreal-engine-5-pacman-cache.hook'
'ue5editor.svg')
-sha256sums=('2ce4f82af94311656c0bed179cb36349df917f5d59793693ccdc7618e5cf2c3c'
+sha256sums=('b3d5f90730116a1a92b17b39f511561cb37fc87b3a78a2e7fe892dca007a1ff4'
'c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca'
'b0a57db9a44d0001dc76ca8504d93e273af30093c6a993a5969d82b0ace54b98'
'9386160a91594abeeaf4fe02fea562e7a4ead4c6f9a258c2a37b2e5f10e7deca'
diff --git a/unreal-engine-5.sh b/unreal-engine-5.sh
index 0b8d47f56493..ced6fcf4eb47 100755
--- a/unreal-engine-5.sh
+++ b/unreal-engine-5.sh
@@ -1,5 +1,9 @@
#! /usr/bin/bash
+## I keep getting this question/comment, so I'll explain the reason for this here for those who feel compelled to ask again:
+# This file mainly exists to stop stubborn people who have a bad habit of running everything as root and to make sure specific paths exists to avoid arbitrary legacy compatibility issues.
+# It also assists with determining user-chosen custom install locations and ensuring the path to the editor binary path isn't entirely lost in the event 'UnrealEdior' is ever relocated to somewhere else for any arbitrary reason upstream decides.
+
if [ "$(id -u)" -eq 0 ]; then
echo "ERROR: Run this as an unprivileged user; not as root."
return;