summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeko-san2023-02-22 19:30:54 -0600
committerNeko-san2023-02-22 19:30:54 -0600
commit4056d8dea91b13b830f344728b7e57c8b11851fd (patch)
tree16c762abf0606faaccef200a9b0e522b88da4127
parent53d6889ccdf9659daed8474075912c0f0493cc2d (diff)
downloadaur-4056d8dea91b13b830f344728b7e57c8b11851fd.tar.gz
Bumped pkgrel; fixed cloning the 4.27.2 tag directly
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd551495ede1..54ed0cba317c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unreal-engine-4
pkgdesc = A 3D game engine by Epic Games which can be used non-commercially for free.
pkgver = 4.27.2
- pkgrel = 10
+ pkgrel = 11
url = https://www.unrealengine.com/
arch = x86_64
arch = x86_64_v2
diff --git a/PKGBUILD b/PKGBUILD
index d8a7f0435bfc..81359a7f6a22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# If you want to turn on additional patches there are switches below.
pkgname=unreal-engine-4
pkgver=4.27.2
-pkgrel=10
+pkgrel=11
pkgdesc='A 3D game engine by Epic Games which can be used non-commercially for free.'
arch=('x86_64' 'x86_64_v2' 'x86_64_v3' 'x86_64_v4' 'aarch64')
url=https://www.unrealengine.com/
@@ -112,13 +112,8 @@ prepare() {
# Download Unreal Engine source or update if the folder exists
if [[ ! -d "${pkgname}" ]]
then
- base_pkgver=$(echo ${pkgver} | cut -d '.' -f 1-2)
- git clone --depth=1 --branch="${base_pkgver}-release" git@github.com:EpicGames/UnrealEngine "${pkgname}"
+ git clone --depth=1 --branch ${pkgver}-release git@github.com:EpicGames/UnrealEngine "${pkgname}"
cd "${pkgname}" || return
- rm -f .git/index.lock
- git fetch --depth=1 origin tag ${pkgver}-release
- git reset --hard ${pkgver}-release
-
else
cd "${pkgname}" || return
CURRENT_CLONED_VERSION="$(git describe --tags)"