summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeko-san2022-11-12 12:36:08 -0600
committerNeko-san2022-11-12 12:36:08 -0600
commit6b5822807c6c297ca47fbfbab8cae105f049fd45 (patch)
treec98a34d17ac16aee5e5262417e8f9d40f0565e5c
parent3bea4349ddca15184e4b705af138a29b20f387a2 (diff)
downloadaur-6b5822807c6c297ca47fbfbab8cae105f049fd45.tar.gz
Corrected a .desktop issue with the launch script referencing the wrong binary
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xunreal-engine-4.sh4
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 532a9cbc85e9..114f7f0306c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,7 +40,7 @@ pkgbase = unreal-engine-4
source = clang_path_fix.patch
source = ccache_executor.patch
source = unreal-engine-4-pacman-cache.hook
- sha256sums = cc0e9128b6857fb7d84c5140b378ec19a9d0a049968beca1bcbc7a0c16bb0e2f
+ sha256sums = c8771291d5ca38696686b06ad7affab496f5ab1b9c5570bd104c9542905a404e
sha256sums = c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca
sha256sums = 960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90
sha256sums = 33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3
diff --git a/PKGBUILD b/PKGBUILD
index 5e361f6fdccd..07d0c08184d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=('unreal-engine-4.sh'
'clang_path_fix.patch'
'ccache_executor.patch'
'unreal-engine-4-pacman-cache.hook')
-sha256sums=('cc0e9128b6857fb7d84c5140b378ec19a9d0a049968beca1bcbc7a0c16bb0e2f'
+sha256sums=('c8771291d5ca38696686b06ad7affab496f5ab1b9c5570bd104c9542905a404e'
'c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca'
'960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90'
'33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3'
diff --git a/unreal-engine-4.sh b/unreal-engine-4.sh
index e64b3a9420ae..1fd3837a0158 100755
--- a/unreal-engine-4.sh
+++ b/unreal-engine-4.sh
@@ -29,8 +29,8 @@ fi
UE4desktopFileChecksum="$(sha256sum "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop" | cut -f 1 -d ' ')"
if [ "${UE4desktopFileChecksum}" == "ChecksumPlaceholder" ]; then
- UE4editorLocation=$(find InstalledLocationPlaceholder -type f -iname 'UnrealEditor')
- UE4editorPath=$(${UE4editorLocation} | sed 's/UnrealEditor//')
+ UE4editorLocation=$(find InstalledLocationPlaceholder -type f -iname 'UE4Editor')
+ UE4editorPath=$(${UE4editorLocation} | sed 's/UE4Editor//')
sed -i "7c\Exec=${UE4editorLocation} %F" "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop"
sed -i "14c\Path=${UE4editorPath}" "${HOME}/local/share/applications/com.unrealengine.UE4Editor.desktop"