summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-08-31 10:34:48 -0400
committeracerix2016-08-31 10:34:48 -0400
commit32b68f9054dedfdf57b890f88c88e63a7d883e42 (patch)
tree2e253b45a0b98e8c8735303a79733518dbdec7b4
parentf437168359f9ec69a412315012016e09dda28142 (diff)
downloadaur-32b68f9054dedfdf57b890f88c88e63a7d883e42.tar.gz
update for new clang
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf7891b93399..b61555041483 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dylan Ferris <dylan@psilly.com>
# You must register at unrealengine.com and link your github account to access this private repo.
-# For more info, see: https://wiki.archlinux.org/index.php/Unreal_Engine_4
+# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
pkgname='unreal-tournament-4'
pkgver=2532759
@@ -9,15 +9,15 @@ pkgrel=1
pkgdesc='A first-person shooter by Epic Games based on Unreal Engine 4.'
arch=('x86_64')
url='https://www.epicgames.com/unrealtournament/'
-makedepends=('clang35' 'mono' 'dos2unix' 'cmake' 'lsb-release')
-depends=('icu53' 'xdg-user-dirs')
+makedepends=('clang' 'mono' 'dos2unix' 'cmake')
+depends=('icu' 'xdg-user-dirs' 'sdl2' 'qt4' 'python')
license=('custom:UnrealTournament')
source=(
- git+ssh://github.com/EpicGames/UnrealTournament.git#tag=$pkgver
- UnrealTournament.desktop
+ "git+ssh://github.com/EpicGames/UnrealTournament.git#tag=$pkgver"
+ 'UnrealTournament.desktop'
)
md5sums=(
- SKIP
+ 'SKIP'
'4ab9fb5f8c4b6c6c3fdb8d2e79399b9e'
)
options=(!strip staticlibs)
@@ -26,6 +26,7 @@ build() {
cd $srcdir/UnrealTournament
./Setup.sh
+ ./GenerateProjectFiles.sh
# Seems the Linux Setup.sh is missing from the main Setup.sh
# This is from UnrealEngine's but causes build() to fail for some reason, although it works when running manually
@@ -33,10 +34,7 @@ build() {
#./Setup.sh "$@"
popd > /dev/null
- ./GenerateProjectFiles.sh
-
- make UE4Game-Linux-Shipping UE4Game-Linux-Test UnrealPak CrashReportClient ShaderCompileWorker UnrealLightmass
- make -j1 ShaderCompileWorker
+ make
}
package() {
@@ -44,15 +42,14 @@ package() {
cd $srcdir/UnrealTournament
+ # license
install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealTournament/LICENSE.pdf"
- install -d "$pkgdir/opt/$pkgname"
-
# copy the entire build dir
# @todo only copy what is needed
cp -r * "$pkgdir/opt/$pkgname/"
- # make the whole thing world writable, otherwise there is a segmentation fault when starting the editor
+ # make the whole thing world writable
# @todo find out what specifically needs to writable
chmod -R a+w "$pkgdir/opt/$pkgname/"