summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-05-06 14:13:39 -0400
committeracerix2016-05-06 14:13:39 -0400
commit4d7e140886be0cbcff6e4d6695adff1dd68f885c (patch)
tree6703d77cf224d6e2ce81e257e0fc2fd2491939ca
downloadaur-4d7e140886be0cbcff6e4d6695adff1dd68f885c.tar.gz
Init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD64
-rw-r--r--UnrealTournament.desktop10
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ebdb86c1dbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri May 6 18:13:21 UTC 2016
+pkgbase = unreal-tournament-4
+ pkgdesc = A first-person shooter by Epic Games based on Unreal Engine 4.
+ pkgver = 2532759
+ pkgrel = 1
+ url = https://www.epicgames.com/unrealtournament/
+ arch = x86_64
+ license = custom:UnrealEngine
+ makedepends = clang35
+ makedepends = mono
+ makedepends = dos2unix
+ makedepends = cmake
+ makedepends = lsb-release
+ depends = icu53
+ depends = xdg-user-dirs
+ options = !strip
+ options = staticlibs
+ source = git+ssh://github.com/EpicGames/UnrealTournament.git#tag=2532759
+ source = UnrealTournament.desktop
+ md5sums = SKIP
+ md5sums = 24b13aa960b3d5ae1275c847edc8455a
+
+pkgname = unreal-tournament-4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7e9743a2fe2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Dylan Ferris <dylan@psilly.com>
+
+# You must register at unrealengine.com and link your github account to access this private repo.
+# For more info, see: https://wiki.archlinux.org/index.php/Unreal_Engine_4
+
+pkgname='unreal-tournament-4'
+pkgver=2532759
+pkgrel=1
+pkgdesc='A first-person shooter by Epic Games based on Unreal Engine 4.'
+arch=('x86_64')
+url='https://www.epicgames.com/unrealtournament/'
+makedepends=('clang35' 'mono' 'dos2unix' 'cmake' 'lsb-release')
+depends=('icu53' 'xdg-user-dirs')
+license=('custom:UnrealEngine')
+source=(
+ git+ssh://github.com/EpicGames/UnrealTournament.git#tag=$pkgver
+ UnrealTournament.desktop
+)
+md5sums=(
+ SKIP
+ '24b13aa960b3d5ae1275c847edc8455a'
+)
+options=(!strip staticlibs)
+
+build() {
+ cd $srcdir/UnrealTournament
+
+ ./Setup.sh
+
+ # Seems the Linux Setup.sh is missing from the main Setup.sh
+ # This is from UnrealEngine's but causes build() to fail for some reason, although it works when running manually
+ pushd Engine/Build/BatchFiles/Linux > /dev/null
+ #./Setup.sh "$@"
+ popd > /dev/null
+
+ ./GenerateProjectFiles.sh
+
+ make UE4Editor UE4Game UnrealPak CrashReportClient ShaderCompileWorker UnrealLightmass
+ make -j1 ShaderCompileWorker
+}
+
+package() {
+ install -Dm644 UnrealTournament.desktop "$pkgdir/usr/share/applications/UnrealTournament.desktop"
+
+ cd $srcdir/UnrealTournament
+
+ install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealEngine/LICENSE.pdf"
+
+ install -d "$pkgdir/opt/$pkgname"
+
+ # copy the entire build dir
+ # @todo only copy what is needed
+ cp -r * "$pkgdir/opt/$pkgname/"
+
+ # make the whole thing world writable, otherwise there is a segmentation fault when starting the editor
+ # @todo find out what specifically needs to writable
+ chmod -R a+w "$pkgdir/opt/$pkgname/"
+
+ # @todo refer to install info here: https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=ut4
+
+ install -Dm644 Engine/Content/Editor/Slate/About/UE4Icon.png "$pkgdir/usr/share/pixmaps/UnrealTournament.png"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/UnrealTournament.desktop b/UnrealTournament.desktop
new file mode 100644
index 000000000000..dc9d239ac78c
--- /dev/null
+++ b/UnrealTournament.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=Unreal Tournament
+Comment=A first-person shooter
+Path=/opt/unreal-tournament/Engine/Binaries/Linux/
+Exec=/opt/unreal-tournament/Engine/Binaries/Linux/UE4-Linux-Shipping UnrealTournament
+Icon=UnrealTournament
+Terminal=false
+Categories=Game;
+