summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2017-11-08 22:11:42 -0500
committeracerix2017-11-08 22:11:42 -0500
commit7d560689dab51cfdbb57b1a128a7c8a2c116586e (patch)
tree5049334ffca40e6d78307ce5e4e6641909fa98f4
parent2e9b574ee579806a72cb4ee31fc8fb86767d9e16 (diff)
downloadaur-7d560689dab51cfdbb57b1a128a7c8a2c116586e.tar.gz
update to use latest github commit instead of latest github release. Epic isn't creating github releases for this, they just commit the stable versions.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66f3eee7ffac..58b2a24b7fe6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Aug 31 14:37:30 UTC 2016
+# Thu Nov 9 03:11:37 UTC 2017
pkgbase = unreal-tournament-4
pkgdesc = A first-person shooter by Epic Games based on Unreal Engine 4.
pkgver = 2532759
@@ -11,17 +11,17 @@ pkgbase = unreal-tournament-4
makedepends = mono
makedepends = dos2unix
makedepends = cmake
+ makedepends = git
depends = icu
depends = xdg-user-dirs
depends = sdl2
depends = qt4
depends = python
- options = !strip
options = staticlibs
source = git+ssh://git@github.com/EpicGames/UnrealTournament.git#tag=2532759
source = UnrealTournament.desktop
- md5sums = SKIP
- md5sums = 4ab9fb5f8c4b6c6c3fdb8d2e79399b9e
+ sha256sums = SKIP
+ sha256sums = d0f041443a6c60ad9d1a7c1381b270df4b0576009f13328a4b024868b5387d7b
pkgname = unreal-tournament-4
diff --git a/PKGBUILD b/PKGBUILD
index c8a92fd235cd..3204836c0fb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,38 +9,44 @@ pkgrel=1
pkgdesc='A first-person shooter by Epic Games based on Unreal Engine 4.'
arch=('x86_64')
url='https://www.epicgames.com/unrealtournament/'
-makedepends=('clang' 'mono' 'dos2unix' 'cmake')
+makedepends=('clang' 'mono' 'dos2unix' 'cmake' 'git')
depends=('icu' 'xdg-user-dirs' 'sdl2' 'qt4' 'python')
license=('custom:UnrealTournament')
source=(
"git+ssh://git@github.com/EpicGames/UnrealTournament.git#tag=$pkgver"
'UnrealTournament.desktop'
)
-md5sums=(
+sha256sums=(
'SKIP'
- '4ab9fb5f8c4b6c6c3fdb8d2e79399b9e'
+ 'd0f041443a6c60ad9d1a7c1381b270df4b0576009f13328a4b024868b5387d7b'
)
-options=(!strip staticlibs)
+options=(staticlibs)
-build() {
- cd $srcdir/UnrealTournament
+pkgver() {
+ cd "$srcdir/UnrealTournament"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/UnrealTournament"
+
+ # clean up old builds before building a new version
+ #git clean -xdf
./Setup.sh
./GenerateProjectFiles.sh
+}
- # Seems the Linux Setup.sh is missing from the main Setup.sh
- # This is from UnrealEngine's but causes build() to fail for some reason, although it works when running manually
- pushd Engine/Build/BatchFiles/Linux > /dev/null
- #./Setup.sh "$@"
- popd > /dev/null
+build() {
+ cd "$srcdir/UnrealTournament"
- make
+ make -j1
}
package() {
install -Dm644 UnrealTournament.desktop "$pkgdir/usr/share/applications/UnrealTournament.desktop"
- cd $srcdir/UnrealTournament
+ cd "$srcdir/UnrealTournament"
# license
install -Dm644 LICENSE.pdf "$pkgdir/usr/share/licenses/UnrealTournament/LICENSE.pdf"
@@ -50,7 +56,7 @@ package() {
cp -r * "$pkgdir/opt/$pkgname/"
# make the whole thing world writable
- # @todo find out what specifically needs to writable
+ # @todo find out what actually needs to writable
chmod -R a+w "$pkgdir/opt/$pkgname/"
# @todo refer to install info here: https://aur.archlinux.org/cgit/aur.git/plain/PKGBUILD?h=ut4