summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:36:11 +0200
committerM0Rf302015-06-17 16:36:11 +0200
commitc52af945b9013a0ccb2aece7ef9e2a3467967ae0 (patch)
treee94b08134f0c827299c62b4d41be2dc4ca0597df
downloadaur-c52af945b9013a0ccb2aece7ef9e2a3467967ae0.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD39
-rw-r--r--install46
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6429d4fb7910
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = unrealtournament-bonuspack2
+ pkgdesc = Bonuspack 2: The Digital Extremes Pack for Unreal Tournament.
+ pkgver = 20000104
+ pkgrel = 2
+ url = http://www.unrealtournament2004.com/utgoty/
+ install = install
+ arch = i686
+ arch = x86_64
+ groups = unrealtournament
+ groups = unrealtournament-bonuspacks
+ license = custom
+ makedepends = umodunpack
+ depends = unrealtournament
+ conflicts = ut1999-bonuspack2
+ source = http://downloads.unrealadmin.org/UnrealTournament/BonusPack/utbonuspack2.zip
+ source = install
+ md5sums = 5cf174dab9f91827da9935231c8d1ea6
+ md5sums = 4c08119de5a5f1be0baf6e6abf2ef7e0
+
+pkgname = unrealtournament-bonuspack2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10e86b6c5c37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Mantainer: M0Rf30
+
+pkgname=unrealtournament-bonuspack2
+pkgver=20000104
+pkgrel=2
+pkgdesc="Bonuspack 2: The Digital Extremes Pack for Unreal Tournament."
+arch=('i686' 'x86_64')
+url="http://www.unrealtournament2004.com/utgoty/"
+license=('custom')
+groups=(unrealtournament unrealtournament-bonuspacks)
+depends=(unrealtournament)
+makedepends=(umodunpack)
+conflicts=(ut1999-bonuspack2)
+install=install
+source=(http://downloads.unrealadmin.org/UnrealTournament/BonusPack/utbonuspack2.zip
+ install)
+
+package() {
+ cd "$srcdir"
+ install --mode=644 -D -- CTF-HallOfGiants.unr \
+ "$pkgdir/opt/ut/Maps/CTF-HallOfGiants.unr" || return 1
+ install --mode=644 -D -- CTF-Orbital.unr \
+ "$pkgdir/opt/ut/Maps/CTF-Orbital.unr" || return 1
+
+ # Cannot unpack directly. Umodpack wants to apply some .ini changes.
+ umodunpack --base "$pkgdir/opt/ut" --extract "de.int" DE.umod \
+ || return 1
+ umodunpack --base "$pkgdir/opt/ut" --extract "de.u" DE.umod \
+ || return 1
+ umodunpack --base "$pkgdir/opt/ut" \
+ --extract "demutators-readme.txt" DE.umod || return 1
+ umodunpack --base "$pkgdir/opt/ut" --extract "de-logo.bmp" \
+ DE.umod || return 1
+ chmod -R -- 644 $pkgdir/opt/ut/*/*
+}
+
+md5sums=('5cf174dab9f91827da9935231c8d1ea6'
+ '4c08119de5a5f1be0baf6e6abf2ef7e0')
+
diff --git a/install b/install
new file mode 100644
index 000000000000..79bcda5c23ef
--- /dev/null
+++ b/install
@@ -0,0 +1,46 @@
+## arg 1: the new package version
+pre_install() {
+ return
+}
+
+## arg 1: the new package version
+post_install() {
+ cat << __EOF__
+Add the following to the respective sections of your UnrealTournament.ini:
+ [Engine.GameEngine]
+ ServerPackages=De
+ [Editor.EditorEngine]
+ EditPackages=De
+__EOF__
+
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ return
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ return
+}
+
+## arg 1: the old package version
+pre_remove() {
+ return
+}
+
+## arg 1: the old package version
+post_remove() {
+ cat << __EOF__
+Remove the following from the respective sections of your UnrealTournament.ini:
+ [Engine.GameEngine]
+ ServerPackages=De
+ [Editor.EditorEngine]
+ EditPackages=De
+__EOF__
+}
+
+# vim: filetype=sh