summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgloriouseggroll2017-03-26 13:49:53 -0400
committergloriouseggroll2017-03-26 13:49:53 -0400
commit1b6b7814f1d9a4ac9da78f3b3969b9e6939518d3 (patch)
treebf391045bf556b71e346963cdde275dbc83db7bb
downloadaur-1b6b7814f1d9a4ac9da78f3b3969b9e6939518d3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO26
-rw-r--r--LICENSE.pdfbin0 -> 86187 bytes
-rw-r--r--PKGBUILD59
-rw-r--r--UnrealTournament4.desktop11
-rw-r--r--ut43
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24e418e8ed6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = unrealtournament4
+ pkgdesc = A first-person shooter by Epic Games based on Unreal Engine 4.
+ pkgver = 3315666
+ pkgrel = 1
+ url = https://www.epicgames.com/unrealtournament/
+ arch = x86_64
+ license = custom:UnrealTournament
+ depends = icu
+ depends = xdg-user-dirs
+ depends = sdl2
+ depends = qt4
+ depends = python
+ noextract = UnrealTournament-Client-XAN-3315666-Linux.zip
+ options = !strip
+ options = staticlibs
+ source = https://s3.amazonaws.com/unrealtournament/UnrealTournament-Client-XAN-3315666-Linux.zip
+ source = UnrealTournament4.desktop
+ source = LICENSE.pdf
+ source = ut4
+ sha512sums = ce54fd540b9098071af00711b76f7bbde5708cfc905bddec5056ebeb0c4f332236b5918954f8d50d70a782856b2606de2e9e3b5b9b977c97d7e8e6f00b15b877
+ sha512sums = 27666828f8eeee115166fe867143c1dcc8e1ca8d243d2471c2f832daa24372135a705fb97d645148f7fd92e013febe6e16d30202ce57eaf2e21b0549f14966f3
+ sha512sums = 0182493a86ee18274c77a4d89776425e1a1e0d0b40c2a797f0fee75bdaad8d9c4511ccab7ad2dd39fbd2fb1aa811d7706677b08a09c553b1348822c1265aa846
+ sha512sums = 5283964cc6985956d88e4044203067f1f4ac886b6dfb2c7b35a5f3721f9a4f2dd5a5a5abf941fac3bb2f01244434d6a2be18e856bab4150ecebcd58c2d732bfc
+
+pkgname = unrealtournament4
+
diff --git a/LICENSE.pdf b/LICENSE.pdf
new file mode 100644
index 000000000000..aa80f7eebaf3
--- /dev/null
+++ b/LICENSE.pdf
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5739d5ceeb0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Thomas Crider <gloriouseggroll@protonmail.com>
+
+# This package is the pre-compiled alpha release version of Unreal Tournament on Unreal Engine 4 posted regularly on the Unreal Tournament forums.
+# The newest release is always at the top of the announcements section, which can be found here:
+# https://www.epicgames.com/unrealtournament/forums/forumdisplay.php?55-Announcements
+# It is advised to download a snapshot of this package and use makepkg -i and pacman -U, as the package is larger than the default /tmp size
+# Please also note that extracting the zip and compressing the package can take quite a long time, as the zip file is over 10GB.
+# The source code can be found here on their github:
+# https://github.com/EpicGames/UnrealTournament/tree/release
+# Please note in order to view the Epic Games github you must register at unrealengine.com and link your github account to access this private repo.
+# @see https://wiki.archlinux.org/index.php/Unreal_Engine_4
+
+pkgname='unrealtournament4'
+pkgver=3315666
+pkgrel=1
+pkgdesc='A first-person shooter by Epic Games based on Unreal Engine 4.'
+arch=('x86_64')
+url='https://www.epicgames.com/unrealtournament/'
+depends=('icu' 'xdg-user-dirs' 'sdl2' 'qt4' 'python')
+license=('custom:UnrealTournament')
+source=(
+ "https://s3.amazonaws.com/unrealtournament/UnrealTournament-Client-XAN-${pkgver}-Linux.zip"
+ 'UnrealTournament4.desktop'
+ 'LICENSE.pdf'
+ 'ut4'
+)
+noextract=("UnrealTournament-Client-XAN-${pkgver}-Linux.zip")
+sha512sums=(
+ 'ce54fd540b9098071af00711b76f7bbde5708cfc905bddec5056ebeb0c4f332236b5918954f8d50d70a782856b2606de2e9e3b5b9b977c97d7e8e6f00b15b877'
+ '27666828f8eeee115166fe867143c1dcc8e1ca8d243d2471c2f832daa24372135a705fb97d645148f7fd92e013febe6e16d30202ce57eaf2e21b0549f14966f3'
+ '0182493a86ee18274c77a4d89776425e1a1e0d0b40c2a797f0fee75bdaad8d9c4511ccab7ad2dd39fbd2fb1aa811d7706677b08a09c553b1348822c1265aa846'
+ '5283964cc6985956d88e4044203067f1f4ac886b6dfb2c7b35a5f3721f9a4f2dd5a5a5abf941fac3bb2f01244434d6a2be18e856bab4150ecebcd58c2d732bfc'
+)
+options=(!strip staticlibs)
+
+package() {
+ # First create directories for bsdtar, the game icon, and the Saved folder
+ install -d "$pkgdir"{/opt/$pkgname/LinuxNoEditor/UnrealTournament/Saved/,/usr/share/pixmaps/}
+
+ # Next extract the game files from the zip directly into pkgdir
+ bsdtar -xf "UnrealTournament-Client-XAN-${pkgver}-Linux.zip" -C "${pkgdir}/opt/${pkgname}/"
+
+ # Next install the game shortcuts and license
+ cd ${pkgdir}
+ install -Dm644 "${srcdir}/UnrealTournament4.desktop" -t "usr/share/applications/"
+ install -Dm644 "${srcdir}/ut4" -t "usr/bin/"
+ install -Dm644 "${srcdir}/LICENSE.pdf" -t "usr/share/licenses/$pkgname/"
+ install -Dm644 "opt/${pkgname}/LinuxNoEditor/Engine/Content/Slate/Icons/DefaultAppIcon.png" "usr/share/pixmaps/UnrealTournament.png"
+
+
+ # Set permissions
+ chgrp -R games "opt/${pkgname}"
+ chmod -R a+rw "opt/${pkgname}/LinuxNoEditor/UnrealTournament/Saved"
+ chmod +x "opt/${pkgname}/LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Shipping"
+ chmod +x "opt/${pkgname}/LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Test"
+ chmod +x "usr/bin/ut4"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/UnrealTournament4.desktop b/UnrealTournament4.desktop
new file mode 100644
index 000000000000..ba95c683ed62
--- /dev/null
+++ b/UnrealTournament4.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Name=Unreal Tournament
+Comment=A first-person shooter
+Path=/opt/unrealtournament4/LinuxNoEditor/Engine/Binaries/Linux/
+Exec=/opt/unrealtournament4/LinuxNoEditor/Engine/Binaries/Linux/UE4-Linux-Shipping UnrealTournament
+Icon=UnrealTournament
+Terminal=false
+Categories=Game;
+
+Name[en_US]=Unreal Tournament 4
diff --git a/ut4 b/ut4
new file mode 100644
index 000000000000..eac69092ce3a
--- /dev/null
+++ b/ut4
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/unrealtournament4/LinuxNoEditor/Engine/Binaries/Linux
+./UE4-Linux-Shipping UnrealTournament