summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892017-06-26 07:11:43 +0200
committerPhoton892017-06-26 07:11:43 +0200
commit62f89c5fba286a8229481cb61989bf493593280e (patch)
tree397284e2d16fa6b78b8ed179ed28121da361c569
parent37c38f5cfcb9241005b031ccf79a2ec8f141b5a2 (diff)
downloadaur-62f89c5fba286a8229481cb61989bf493593280e.tar.gz
Added gendesk as makedepend, updated to 1.2.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b48757087717..c4146832e2a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = unreel
pkgdesc = A GUI to create Reveal presentations
- pkgver = 1.0.3
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/linux-man/unreel
arch = i686
arch = x86_64
license = GPL3
makedepends = npm
+ makedepends = gendesk
depends = gconf
depends = libnotify
depends = libappindicator-gtk2
depends = libxtst
depends = nss
- source = https://github.com/linux-man/unreel/archive/v1.0.3.tar.gz
+ source = https://github.com/linux-man/unreel/archive/v1.2.0.tar.gz
source = unreel.xml
- md5sums = d6f0fed0c194bd3ded5733712f51c429
+ md5sums = 05cb07af5272ad7e5724c8705827c51c
md5sums = 6aaa81cb3511288c44ffb8e4fe9e2b5f
pkgname = unreel
diff --git a/PKGBUILD b/PKGBUILD
index d2ee0993322e..857895e1ea75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Based on PKGBUILD for wire-desktop by Conor Anderson
pkgname=unreel
-pkgver=1.0.3
+pkgver=1.2.0
pkgrel=1
pkgdesc="A GUI to create Reveal presentations"
arch=('i686' 'x86_64')
url="https://github.com/linux-man/unreel"
license=('GPL3')
depends=('gconf' 'libnotify' 'libappindicator-gtk2' 'libxtst' 'nss')
-makedepends=('npm')
+makedepends=('npm' 'gendesk')
source=("https://github.com/linux-man/unreel/archive/v$pkgver.tar.gz" "unreel.xml")
-md5sums=('d6f0fed0c194bd3ded5733712f51c429'
+md5sums=('05cb07af5272ad7e5724c8705827c51c'
'6aaa81cb3511288c44ffb8e4fe9e2b5f')
prepare() {
gendesk -f -n --name=Unreel --pkgname="${pkgname}" --pkgdesc="${pkgdesc}" --exec="${pkgname}" --categories="Office" --mimetypes="application/reel"
@@ -53,4 +53,4 @@ package() {
"${pkgdir}/usr/share/icons/hicolor/512x512/mimetypes/application-reel.png"
install -d "${pkgdir}/usr/share/mime/packages"
install -Dm644 "${srcdir}/${pkgname}.xml" "${pkgdir}/usr/share/mime/packages/${pkgname}.xml"
-} \ No newline at end of file
+}