summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGareth Latty2019-04-30 04:40:32 +0100
committerGareth Latty2019-04-30 04:40:32 +0100
commit844cae8e640e1de9c554078cc4fd845f5244ecfc (patch)
tree5232ae7e262c2d1aec67bdb61dc1ef295b557edb
parentcfb74e0774b1b639f6c12f410661d0b4927f5bc9 (diff)
downloadaur-844cae8e640e1de9c554078cc4fd845f5244ecfc.tar.gz
Bump to 2.0.1.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 27 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b2b9173750..475d55630be2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = unrpa
pkgdesc = Extract files from the RPA archive format (from Ren'Py visual novels).
- pkgver = 1.6
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/Lattyware/unrpa
arch = any
license = GPL3
- depends = python
- source = unrpa-1.6.tar.gz::https://github.com/Lattyware/unrpa/archive/1.6.tar.gz
- source = https://github.com/Lattyware/unrpa/releases/download/1.6/unrpa-1.6.tar.gz.asc
+ makedepends = python-setuptools
+ depends = python3
+ optdepends = python-uncompyle6: ZiX archive support
+ source = unrpa-2.0.1.tar.gz::https://github.com/Lattyware/unrpa/archive/2.0.1.tar.gz
+ source = https://github.com/Lattyware/unrpa/releases/download/2.0.1/unrpa-2.0.1.tar.gz.asc
validpgpkeys = 92A57AA673039A4491E6D80E5BDD8CFCA5F0551E
- sha256sums = 3d9669f54edbe4f3020075d8cfe5672e6e72f8df79898a1e0aaecee1e4caa9a6
- sha256sums = SKIP
+ sha256sums = adbd5830e88e60a13bfb192bddfca37bfd922d40d1e5d061a1fb3b21a608163d
+ sha256sums = fa987df68ecbb24db36f97535596d1b32dd70ef0b4fab7175c9ba8b3204e1ebe
pkgname = unrpa
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a909d8029be0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.asc
+*.tar.gz
+*.tar.xz
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9d40f85b1014..2c9ec6b92b5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Gareth Latty <gareth@lattyware.co.uk>
pkgname=unrpa
-pkgver=1.6
+pkgver=2.0.1
pkgrel=1
pkgdesc="Extract files from the RPA archive format (from Ren'Py visual novels)."
arch=("any")
url="https://github.com/Lattyware/unrpa"
license=("GPL3")
-depends=("python")
+depends=("python3")
+makedepends=("python-setuptools")
+optdepends=("python-uncompyle6: ZiX archive support")
source=("$pkgname-$pkgver.tar.gz::https://github.com/Lattyware/$pkgname/archive/$pkgver.tar.gz"
"https://github.com/Lattyware/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz.asc")
validpgpkeys=("92A57AA673039A4491E6D80E5BDD8CFCA5F0551E")
-sha256sums=("3d9669f54edbe4f3020075d8cfe5672e6e72f8df79898a1e0aaecee1e4caa9a6"
- "SKIP")
+sha256sums=("adbd5830e88e60a13bfb192bddfca37bfd922d40d1e5d061a1fb3b21a608163d"
+ "fa987df68ecbb24db36f97535596d1b32dd70ef0b4fab7175c9ba8b3204e1ebe")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
package() {
- mkdir -p "$pkgdir/usr/bin"
- install -m 0755 "$srcdir/$pkgname-$pkgver/unrpa" "$pkgdir/usr/bin"
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}