summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 14:47:28 +0200
committerPiotr Rogoża2015-06-14 14:47:28 +0200
commit4b398ab7c47c9d7e43523f989e020c16a4474c26 (patch)
tree5b44695b2de92664850e0cb9a1ad615630548a7d
downloadaur-unsermake.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--unsermake-python2.patch24
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecaaf3919dd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = unsermake
+ pkgdesc = A replacement for automake
+ pkgver = 20070824
+ pkgrel = 4
+ url = http://wiki.kde.org/tiki-index.php?page=unsermake
+ arch = any
+ license = GPL
+ makedepends = python2>=2.6
+ depends = python2>=2.6
+ source = http://ranger.befunk.com/fink/unsermake/unsermake-20070824.tar.bz2
+ source = unsermake-python2.patch
+ md5sums = b794f83bdc3f6205d1fd731da4e96d89
+ md5sums = 101fca1c17ef31d928065f5bc646af9f
+
+pkgname = unsermake
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb3b648a2896
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+
+pkgname=unsermake
+pkgver=20070824
+pkgrel=4
+pkgdesc="A replacement for automake"
+arch=('any')
+url="http://wiki.kde.org/tiki-index.php?page=unsermake"
+license=('GPL')
+makedepends=('python2>=2.6')
+depends=('python2>=2.6')
+source=(http://ranger.befunk.com/fink/unsermake/$pkgname-$pkgver.tar.bz2 unsermake-python2.patch)
+
+build() {
+ _python_version=$(python2 -V 2>&1 | cut -d' ' -f2 | cut -b1-3)
+ cd ${srcdir}
+ cp unsermake-python2.patch unsermake-python${_python_version}.patch
+ sed -e "s/__version__/${_python_version}/g" -i unsermake-python${_python_version}.patch
+
+ cd ${srcdir}/$pkgname
+ patch -Np1 -i ../unsermake-python${_python_version}.patch || return 1
+ install -D -m755 unsermake ${pkgdir}/usr/bin/unsermake
+
+ mkdir -p ${pkgdir}/usr/lib/python${_python_version}/site-packages/unsermake
+ install -m644 *.py *.um ${pkgdir}/usr/lib/python${_python_version}/site-packages/unsermake/
+}
+md5sums=('b794f83bdc3f6205d1fd731da4e96d89'
+ '101fca1c17ef31d928065f5bc646af9f')
diff --git a/unsermake-python2.patch b/unsermake-python2.patch
new file mode 100644
index 000000000000..bae8a2d12592
--- /dev/null
+++ b/unsermake-python2.patch
@@ -0,0 +1,24 @@
+--- unsermake-20060706.orig/unsermake 2006-07-07 01:07:51.000000000 +0800
++++ unsermake-20060706/unsermake 2007-07-24 11:35:39.000000000 +0800
+@@ -1,16 +1,12 @@
+-#! /bin/sh
++#!/bin/bash
+
+-self="$0"
+-if test -L "$self"; then
+- try=`readlink $self 2>/dev/null` && self=$try
+-fi
+-mods=`dirname $self`
+-directory=`dirname $mods`
+-mod=`basename $mods`
++mods=/usr/lib/python__version__/site-packages/unsermake
++directory=/usr/lib/python__version__/site-packages/unsermake
++mod=unsermake
+ if test -n "$PYTHONPATH"; then
+ export PYTHONPATH=$directory:$PYTHONPATH
+ else
+ export PYTHONPATH=$directory
+ fi
+-exec python -c "import $mod; $mod.main()" --modules $mods "$@"
++exec python2.6 -c "import $mod; $mod.main()" --modules $mods "$@"
+