summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:01:49 +0200
committeroli2015-06-12 22:01:49 +0200
commitfeadd40edd30edacf036b630864cd52abdba79f0 (patch)
treec42c6e4d3381cc9d9e0bbfbaa881bc3bc51e6080
downloadaur-feadd40edd30edacf036b630864cd52abdba79f0.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..824ed838c9a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = untrunc-git
+ pkgdesc = restore a damaged (truncated) mp4, m4v, mov, 3gp video
+ pkgver = r30.c74920f
+ pkgrel = 1
+ url = https://github.com/ponchio/untrunc
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = ffmpeg
+ source = untrunc-git::git+https://github.com/ponchio/untrunc.git
+ md5sums = SKIP
+
+pkgname = untrunc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ebc6fc4ce83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=untrunc-git
+pkgver=r30.c74920f
+pkgrel=1
+pkgdesc="restore a damaged (truncated) mp4, m4v, mov, 3gp video"
+arch=('x86_64' 'i686')
+url="https://github.com/ponchio/untrunc"
+license=('GPL2')
+depends=('ffmpeg')
+source=("${pkgname}"::'git+https://github.com/ponchio/untrunc.git')
+md5sums=(SKIP)
+
+build() {
+ cd $srcdir/$pkgname
+ git submodule init
+ git submodule update
+ make
+}
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 $srcdir/$pkgname/untrunc $pkgdir/usr/bin/untrunc
+}