summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraihan20002023-09-13 19:19:49 +0530
committerraihan20002023-09-13 19:19:49 +0530
commita10053dc159b58485d22fe6ac26c5f1177fc7853 (patch)
treee53b746974acb92b7354c935cd9e0899535caa6c
downloadaur-a10053dc159b58485d22fe6ac26c5f1177fc7853.tar.gz
add unudhcpd from pmOS
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f197fd71fd3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = unudhcpd
+ pkgdesc = Extremely basic DHCP server that only issues 1 IP address to any client
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://gitlab.com/postmarketOS/unudhcpd
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = meson
+ source = https://gitlab.com/postmarketOS/unudhcpd/-/archive/0.2.1/unudhcpd-0.2.1.tar.gz
+ sha256sums = c404424a65e6341ef04300e7408a2edad1481ce8841f541e20e058800e7b5485
+
+pkgname = unudhcpd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9907cffb5f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Raihan Ahamed <raihan1999ahamed@gmail.com>
+
+pkgname=unudhcpd
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Extremely basic DHCP server that only issues 1 IP address to any client"
+url="https://gitlab.com/postmarketOS/unudhcpd"
+arch=('any')
+license=('GPL-3.0-or-later')
+makedepends=('meson')
+source=("https://gitlab.com/postmarketOS/unudhcpd/-/archive/$pkgver/unudhcpd-$pkgver.tar.gz")
+sha256sums=('c404424a65e6341ef04300e7408a2edad1481ce8841f541e20e058800e7b5485')
+
+build() {
+ cd $pkgname-$pkgver
+ arch-meson output
+ meson compile -C output
+}
+
+check() {
+ cd $pkgname-$pkgver
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ cd $pkgname-$pkgver
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}