summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViech2023-06-24 13:05:22 +0200
committerViech2023-06-24 13:05:22 +0200
commit328bc805e0b3c298db453549403dacce7f34f8e6 (patch)
tree07a558d056560561a8b11a431838ab35debe1842
parent7f53e442ac5bafa72fdcb764928a551c65781839 (diff)
downloadaur-328bc805e0b3c298db453549403dacce7f34f8e6.tar.gz
Tentatively add AArch64 support.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34fe0c7d43fc..e4e7edf5670e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = unvanquished
pkgdesc = A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.
pkgver = 0.54.0
- pkgrel = 3
+ pkgrel = 4
url = https://www.unvanquished.net
install = unvanquished.install
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cmake
depends = unvanquished-data>=0.54.0
diff --git a/PKGBUILD b/PKGBUILD
index 5f20151545f3..4ea0e835dce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
pkgname=unvanquished
pkgver=0.54.0
-pkgrel=3
+pkgrel=4
pkgdesc='A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url='https://www.unvanquished.net'
license=('GPL3')
makedepends=('cmake')
@@ -147,6 +147,11 @@ package() {
install -m 755 nacl_helper_bootstrap "${pkgdir}/usr/lib/unvanquished/"
install -m 755 nacl_loader "${pkgdir}/usr/lib/unvanquished/"
+ if [ "${CARCH}" == "aarch64" ]; then
+ install -m 755 nacl_helper_bootstrap-armhf "${pkgdir}/usr/lib/unvanquished/"
+ cp -r lib-armhf "${pkgdir}/usr/lib/unvanquished/"
+ fi
+
cd "${srcdir}/${_unvanquished}/dist/configs"
install -m 644 game/maprotation.cfg "${pkgdir}/etc/unvanquished/"