summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViech2022-04-30 10:15:52 +0200
committerViech2022-04-30 10:15:52 +0200
commit71ac9e0c5f62670ddda46747176dc4b2e961e519 (patch)
tree0e5f1eafc7d0a033bbf9b8fbdb0d7dc8333ad3d7
parenta6e2204f967a87c2d6140d789839792aba89c8d1 (diff)
downloadaur-71ac9e0c5f62670ddda46747176dc4b2e961e519.tar.gz
Fix a compilation issue with breakpad.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c006f47551e7..439dffbbc705 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = unvanquished
pkgdesc = A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.
pkgver = 0.52.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.unvanquished.net
install = unvanquished.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c9c2dfba39d6..37bd2287a7c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=unvanquished
pkgver=0.52.1
-pkgrel=1
+pkgrel=2
pkgdesc='A team-based, fast-paced, fps/rts hybrid game which pits aliens against humans.'
arch=('x86_64')
url='https://www.unvanquished.net'
@@ -76,6 +76,10 @@ prepare() {
# Link the NaCL SDK in the Dæmon source tree.
ln -sfr "${_naclsdk}" "${_daemon}/external_deps/${_naclsdk}"
+
+ # Patch breakpad.
+ # TODO: This is fixed upstream; remove this with the next release.
+ sed -i 's/16384, SIGSTKSZ/16384u, static_cast<unsigned>(SIGSTKSZ)/g' $(find ${_breakpad} -name "exception_handler.cc")
}
build() {