summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatrio2021-09-07 00:10:01 +0300
committerNatrio2021-09-07 00:10:01 +0300
commit1fbc603a685856c271afff1f1545c7be9cfb9db6 (patch)
treeb7d4b53f90438f8dbabe8049f3696f6620cacbd7
parent11d6e3741e26621265bd0371dbc937e7246f181e (diff)
downloadaur-unzip-natspec.tar.gz
Syncing with unzip, avoiding -Werror=format-security from the new CFLAGS default
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--csiz-underflow.patch2
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc32ba02378..29632a52a8df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = unzip-natspec
pkgdesc = Unpacks .zip archives with non-latin filenames, using libnatspec patch from AltLinux.
pkgver = 6.0
- pkgrel = 6
- url = http://www.info-zip.org/
+ pkgrel = 7
+ url = https://www.info-zip.org/
arch = i686
arch = x86_64
arch = armv7h
@@ -13,7 +13,7 @@ pkgbase = unzip-natspec
depends = libnatspec
provides = unzip
conflicts = unzip
- source = http://downloads.sourceforge.net/infozip/unzip60.tar.gz
+ source = https://downloads.sourceforge.net/infozip/unzip60.tar.gz
source = unzip-6.0-alt-natspec.patch
source = overflow-fsize.patch
source = cve20149636.patch
@@ -35,4 +35,3 @@ pkgbase = unzip-natspec
sha256sums = SKIP
pkgname = unzip-natspec
-
diff --git a/PKGBUILD b/PKGBUILD
index 3050f10dea00..6a7d57680a53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
pkgname=unzip-natspec
pkgver=6.0
-pkgrel=6
+pkgrel=7
pkgdesc="Unpacks .zip archives with non-latin filenames, using libnatspec patch from AltLinux."
arch=('i686' 'x86_64' 'armv7h' 'armv6h')
-url="http://www.info-zip.org/"
+url="https://www.info-zip.org/"
license=('custom')
depends=('bzip2' 'bash' 'libnatspec')
conflicts=('unzip')
provides=('unzip')
-source=('http://downloads.sourceforge.net/infozip/unzip60.tar.gz'
+source=('https://downloads.sourceforge.net/infozip/unzip60.tar.gz'
'unzip-6.0-alt-natspec.patch'
'overflow-fsize.patch'
'cve20149636.patch'
@@ -37,7 +37,7 @@ build() {
patch -p1 -i ${srcdir}/empty-input.patch || return 1 # FS#46955
patch -p1 -i ${srcdir}/csiz-underflow.patch || return 1 # FS#46955
patch -p1 -i ${srcdir}/nextbyte-overflow.patch || return 1 # FS#46955
- export CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -DACORN_FTYPE_NFS \
+ export CFLAGS="${CFLAGS//-Werror=format-security/} -D_FILE_OFFSET_BITS=64 -DACORN_FTYPE_NFS \
-DWILD_STOP_AT_DIR -DLARGE_FILE_SUPPORT -DUNICODE_SUPPORT \
-DUNICODE_WCHAR -DUTF8_MAYBE_NATIVE -DNO_LCHMOD -DDATE_FORMAT=DF_YMD \
-DUSE_BZIP2 -DNATIVE -DNOMEMCPY -DNO_SETLOCALE"
diff --git a/csiz-underflow.patch b/csiz-underflow.patch
index 52321c208a1a..45afbdd683a6 100644
--- a/csiz-underflow.patch
+++ b/csiz-underflow.patch
@@ -17,7 +17,7 @@ Suggested-by: Stefan Cornelius
- if (G.pInfo->encrypted)
+ if (G.pInfo->encrypted) {
-+ if (csiz_decrypted <= 12) {
++ if (csiz_decrypted < 12) {
+ /* handle the error now to prevent unsigned overflow */
+ Info(slide, 0x401, ((char *)slide,
+ LoadFarStringSmall(ErrUnzipNoFile),