summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Rooyakkers2018-12-06 15:52:45 -0500
committerLucas Rooyakkers2018-12-06 15:52:45 -0500
commit1457daa41735fe20d5ed81d1eb44c6df31aa5269 (patch)
tree17cedff63d5b3ebd7d3c34ea53400e0fb284e96a
parentd9df9475ddb59a09d811ae66f55e412225d16d6b (diff)
downloadaur-1457daa41735fe20d5ed81d1eb44c6df31aa5269.tar.gz
Version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa49a81e2a9f..d8151b885365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = up-git
pkgdesc = Ultimate Plumber is a tool for writing Linux pipes with instant live preview
- pkgver = 1
- pkgrel = 6
+ pkgver = 5873371
+ pkgrel = 1
url = https://github.com/akavel/up
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index cbc2884687e9..de55b6595f43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Mainintainer : Lucas Rooyakkers <lucas dot rooyakkers at pm dot me>
pkgname=up-git
-pkgver=1
-pkgrel=6
+pkgver=5873371
+pkgrel=1
license=('Apache')
pkgdesc="Ultimate Plumber is a tool for writing Linux pipes with instant live preview"
url="https://github.com/akavel/up"
@@ -12,6 +12,11 @@ makedepends=('go')
source=("${pkgname}::git+${url}")
sha1sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ echo $(git describe --always | sed 's/-/./g')
+}
+
build() {
cd ${pkgname}
go build