summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Rooyakkers2018-10-24 18:38:22 -0400
committerLucas Rooyakkers2018-10-24 18:38:22 -0400
commit3a9d17aab44660493c78725f8ca6324ec9a17ebb (patch)
tree91fad494e0a3c45b8ce3178a484f02424205191a
downloadaur-3a9d17aab44660493c78725f8ca6324ec9a17ebb.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73dbb0f5734c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = up-git
+ pkgdesc = Ultimate Plumber is a tool for writing Linux pipes with instant live preview
+ pkgver = 1
+ pkgrel = 4
+ url = https://github.com/akavel/up
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ provides = up
+ conflicts = up
+ source = up-git::git+https://github.com/akavel/up
+ sha1sums = SKIP
+
+pkgname = up-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aff0bef9d43e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+up*
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..512221845cd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Mainintainer : Lucas Rooyakkers <lucas dot rooyakkers at pm dot me>
+pkgname=up-git
+pkgver=1
+pkgrel=4
+license=('Apache')
+pkgdesc="Ultimate Plumber is a tool for writing Linux pipes with instant live preview"
+url="https://github.com/akavel/up"
+arch=('x86_64')
+provides=('up')
+conflicts=('up')
+makedepends=('go')
+source=("${pkgname}::git+${url}")
+sha1sums=('SKIP')
+
+build() {
+ cd ${pkgname}
+ go build
+}
+
+package() {
+ cd ${pkgname}
+ install -Dm755 "up" "$pkgdir/usr/bin/up"
+}
+