summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-03-19 14:08:47 +0100
committerL.G. Sarmiento2018-03-19 14:08:47 +0100
commitbde7b2039d1e6c0ddabf66324e40540d7fc0afe6 (patch)
treedde49a2344433d46c170c5d8efaf9de4d420abf9
parentfc58dae030c1b4bb9368d9ddee94b9fd5356572a (diff)
downloadaur-bde7b2039d1e6c0ddabf66324e40540d7fc0afe6.tar.gz
source changed extension
-rw-r--r--.SRCINFO15
-rw-r--r--Dscanor.Makefile.patch13
-rw-r--r--PKGBUILD65
-rw-r--r--gfortran_i686.patch47
-rw-r--r--gfortran_x86_64.patch38
5 files changed, 52 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54753c01e07b..05ab564d672c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
# Generated by mksrcinfo v8
-# Tue Sep 5 08:17:36 UTC 2017
+# Mon Mar 19 13:02:47 UTC 2018
pkgbase = upak
pkgdesc = HRIBF Data Acquisition and analysis.
pkgver = 10.6.8
- pkgrel = 7
+ pkgrel = 8
url = ftp://ftp.phy.ornl.gov/pub/upak/README.html
install = upak.install
- arch = i686
arch = x86_64
license = unknown
makedepends = gcc-fortran>=4.2
@@ -15,13 +14,11 @@ pkgbase = upak
depends = bash
options = staticlibs
options = emptydirs
- source = ftp://ftp.phy.ornl.gov/pub/upak/upak-src.tgz
- source = gfortran_x86_64.patch
- source = gfortran_i686.patch
+ source = ftp://ftp.phy.ornl.gov/pub/upak/upak-src.tar.gz
+ source = Dscanor.Makefile.patch
source = upak.install
- md5sums = c167fd178279d88e05320c7e580b05b4
- md5sums = cb904633d49f17c707515646c2bd2338
- md5sums = d1accbca0c14b8499870577b3e2fe05f
+ md5sums = bcdddfd685f4a19cd93452be18de238b
+ md5sums = ec5128392e9f7b52a3e5dc5650cd7de5
md5sums = 7d8e9e7ec0f6ed54683a65f640899e20
pkgname = upak
diff --git a/Dscanor.Makefile.patch b/Dscanor.Makefile.patch
new file mode 100644
index 000000000000..7516284a48e0
--- /dev/null
+++ b/Dscanor.Makefile.patch
@@ -0,0 +1,13 @@
+--- src/upak/Dscanor/Makefile 2015-04-01 21:22:29.000000000 +0200
++++ Dscanor.Makefile 2018-03-19 12:17:52.857454246 +0100
+@@ -22,8 +22,8 @@ install: scanor scanof
+ install -d $(INSTALLDIR)
+ install -p scanor.o $(INSTALLDIR)
+ rm -f *.exe scanor
+- install -p scanor.hhirf.make $(INSTALLDIR)
++ install -p scanor.gfortran.make $(INSTALLDIR)
+ install -p scanof.o $(INSTALLDIR)
+ rm -f *.exe scanof
+- install -p scanof.hhirf.make $(INSTALLDIR)
++ install -p scanof.gfortran.make $(INSTALLDIR)
+ install -p scanor.hep $(INSTALLDIR)
diff --git a/PKGBUILD b/PKGBUILD
index 311ff513076b..5838f905102a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,66 +2,67 @@
pkgname=upak
pkgver=10.6.8
-pkgrel=7
+pkgrel=8
pkgdesc="HRIBF Data Acquisition and analysis."
url="ftp://ftp.phy.ornl.gov/pub/upak/README.html"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('unknown')
depends=('libx11' 'tcsh' 'bash')
makedepends=('gcc-fortran>=4.2')
options=(staticlibs emptydirs)
-source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tgz"
- "gfortran_x86_64.patch"
- "gfortran_i686.patch"
+source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tar.gz"
+ "Dscanor.Makefile.patch"
"upak.install")
-md5sums=('c167fd178279d88e05320c7e580b05b4'
- 'cb904633d49f17c707515646c2bd2338'
- 'd1accbca0c14b8499870577b3e2fe05f'
+md5sums=('bcdddfd685f4a19cd93452be18de238b'
+ 'ec5128392e9f7b52a3e5dc5650cd7de5'
'7d8e9e7ec0f6ed54683a65f640899e20')
install="${pkgname}.install"
prepare() {
- msg 'patch main Makefile'
- cd "${srcdir}/${pkgname}"
- if [ ${CARCH} == 'x86_64' ]; then
- patch -Np2 < ${srcdir}/gfortran_x86_64.patch
- else
- patch -Np2 < ${srcdir}/gfortran_i686.patch
- fi
+ #
+ # diff -puN src/upak/Dscanor/Makefile Dscanor.Makefile > Dscanor.Makefile.patch
+ #
+ msg 'patch Dscanor Makefile'
+ cd "${srcdir}/${pkgname}/Dscanor"
+ patch -Np3 < ${srcdir}/Dscanor.Makefile.patch
}
package() {
- ##compile
+ ## compile
cd "${srcdir}/${pkgname}"
make clean
make -j1 INSTALLDIR="${pkgdir}/usr/bin" all
- #libraries
- [ -d ${pkgdir}/usr/lib ] || install -d ${pkgdir}/usr/lib
- install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
- rm -f ${pkgdir}/usr/bin/*.{a,o}
-
- #documentation
+ ## documentation (0)
_DOCDIR=${pkgdir}/usr/share/doc/${pkgname}
[ -d ${_DOCDIR} ] || install -d ${_DOCDIR}
- install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat} ${_DOCDIR}
- #correct the location of the doc dir and change executable permissions
+ # correct the location of the doc dir and change executable permissions
install -m644 ${pkgdir}/usr/bin/doc/* ${_DOCDIR}
rm -rf ${pkgdir}/usr/bin/doc
- cd "${srcdir}/${pkgname}"
- install -m644 Dreadme/README-Apr07 ${_DOCDIR}
- install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
- install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
+ # correct the location of the file and create DOC dir
+ install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f} ${_DOCDIR}
+
+ #clean bin directory from what is already placed in the doc dir.
+ rm -f ${pkgdir}/usr/bin/*.{hep,ps,dat,make,f}
- #clean bin directory from everything else already placed in the doc dir.
- rm -f ${pkgdir}/usr/bin/*.*
+ ## libraries
+ _LIBDIR=${pkgdir}/usr/lib
+ [ -d ${_LIBDIR} ] || install -d ${_LIBDIR}
- msg 'Change permissions to the usual 755 for bin files'
- chmod 755 ${pkgdir}/usr/bin/*
+ install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
+
+ #clean bin directory from what is already placed in the lib dir.
+ rm -f ${pkgdir}/usr/bin/*.{a,o}
+
+ ## others
+ cd "${srcdir}/${pkgname}"
+ install -m644 Dreadme/README-Apr07 ${_DOCDIR}
+ install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
+ install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
}
diff --git a/gfortran_i686.patch b/gfortran_i686.patch
deleted file mode 100644
index 17e29dd66bcf..000000000000
--- a/gfortran_i686.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- src/upak/Makefile 2014-08-24 00:02:31.000000000 +0200
-+++ Makefile.i686 2015-09-14 13:28:55.797679917 +0200
-@@ -8,7 +8,7 @@
- # Mac/Intel Pentium = 32
- # Intel Pentium64 = 64
- # Dec ALPHA = 64
--export PTRSIZE=64
-+export PTRSIZE=32
- #
- ###-BYTEORDER-###
- # The byte order is processor dependent
-@@ -32,22 +32,22 @@ export FENDIAN = -DLITTLEENDIAN
- #
- #--Gfortran - must be gcc >=4.2 (gcc42 and gcc42-shlibs on Mac Fink)
- # MacOS version
--export F77= /sw/bin/gfortran-fsf-4.9
--export CC=/sw/bin/gcc-fsf-4.9
--export OPT= -O
--export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
--export CARGS= $(FENDIAN)
--export FLIBS= -L/sw/lib -lgfortran -lgcc
--export INSTALLDIR= ../../hhirf
--#
--#--Gfortran - must be gcc >=4.2
--# LINUX version
--#export F77= gfortran
--#export CC=gcc
-+#export F77= /sw/bin/gfortran-fsf-4.9
-+#export CC=/sw/bin/gcc-fsf-4.9
- #export OPT= -O
- #export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
- #export CARGS= $(FENDIAN)
--#export FLIBS= -lgfortran -lgcc
-+#export FLIBS= -L/sw/lib -lgfortran -lgcc
-+#export INSTALLDIR= ../../hhirf
-+#
-+#--Gfortran - must be gcc >=4.2
-+# LINUX version
-+export F77= gfortran
-+export CC=gcc
-+export OPT= -O -fPIC
-+export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
-+export CARGS= $(FENDIAN)
-+export FLIBS= -lgfortran -lgcc
- #export INSTALLDIR= /usr/hhirf
- #
- #--G77
diff --git a/gfortran_x86_64.patch b/gfortran_x86_64.patch
deleted file mode 100644
index c4f9eedfbcd3..000000000000
--- a/gfortran_x86_64.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/upak/Makefile 2014-08-24 00:02:31.000000000 +0200
-+++ Makefile.x86_64 2015-09-14 13:48:33.382449685 +0200
-@@ -32,22 +32,22 @@ export FENDIAN = -DLITTLEENDIAN
- #
- #--Gfortran - must be gcc >=4.2 (gcc42 and gcc42-shlibs on Mac Fink)
- # MacOS version
--export F77= /sw/bin/gfortran-fsf-4.9
--export CC=/sw/bin/gcc-fsf-4.9
--export OPT= -O
--export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
--export CARGS= $(FENDIAN)
--export FLIBS= -L/sw/lib -lgfortran -lgcc
--export INSTALLDIR= ../../hhirf
--#
--#--Gfortran - must be gcc >=4.2
--# LINUX version
--#export F77= gfortran
--#export CC=gcc
-+#export F77= /sw/bin/gfortran-fsf-4.9
-+#export CC=/sw/bin/gcc-fsf-4.9
- #export OPT= -O
- #export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
- #export CARGS= $(FENDIAN)
--#export FLIBS= -lgfortran -lgcc
-+#export FLIBS= -L/sw/lib -lgfortran -lgcc
-+#export INSTALLDIR= ../../hhirf
-+#
-+#--Gfortran - must be gcc >=4.2
-+# LINUX version
-+export F77= gfortran
-+export CC=gcc
-+export OPT= -O -fPIC
-+export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
-+export CARGS= $(FENDIAN)
-+export FLIBS= -lgfortran -lgcc
- #export INSTALLDIR= /usr/hhirf
- #
- #--G77