summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:39:19 +0200
committerL.G. Sarmiento2015-06-14 19:39:19 +0200
commitdcce72aba0056a4275c2cafd86eec6c4df063569 (patch)
treee32e763e578f02c4735b45d035c92a4ad6fa1a1b
downloadaur-dcce72aba0056a4275c2cafd86eec6c4df063569.tar.gz
Initial import
-rw-r--r--.AURINFO23
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD62
-rw-r--r--gfortran_i686.patch46
-rw-r--r--gfortran_x86_64.patch37
-rw-r--r--upak.install24
6 files changed, 219 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..4a26bc29d700
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,23 @@
+pkgbase = upak
+ pkgdesc = HRIBF Data Acquisition and analysis.
+ pkgver = 10.6.8
+ pkgrel = 5
+ url = ftp://ftp.phy.ornl.gov/pub/upak/README.html
+ install = upak.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = gcc-fortran>=4.2
+ depends = libx11
+ depends = gcc-libs
+ depends = tcsh
+ depends = bash
+ source = ftp://ftp.phy.ornl.gov/pub/upak/upak-src.tgz
+ source = gfortran_x86_64.patch
+ source = gfortran_i686.patch
+ source = upak.install
+ options = staticlibs
+ options = emptydirs
+
+pkgname = upak
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2263fea94d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = upak
+ pkgdesc = HRIBF Data Acquisition and analysis.
+ pkgver = 10.6.8
+ pkgrel = 5
+ url = ftp://ftp.phy.ornl.gov/pub/upak/README.html
+ install = upak.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = gcc-fortran>=4.2
+ depends = libx11
+ depends = gcc-libs
+ depends = tcsh
+ depends = bash
+ options = staticlibs
+ options = emptydirs
+ source = ftp://ftp.phy.ornl.gov/pub/upak/upak-src.tgz
+ source = gfortran_x86_64.patch
+ source = gfortran_i686.patch
+ source = upak.install
+ md5sums = 8ea938e72020b75cf1ca356d27821823
+ md5sums = fe89246ccc894cee04f20e590bab1b36
+ md5sums = a11d01b14c15731d21ee009de8dd3a9a
+ md5sums = 1f5d22a84125d8cbcc6ee2fdfe73ffd4
+
+pkgname = upak
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74713f1ced8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Luis Sarmiento <lgsarmientop-ala-unal.edu.co>
+
+pkgname=upak
+pkgver=10.6.8
+pkgrel=5
+pkgdesc="HRIBF Data Acquisition and analysis."
+url="ftp://ftp.phy.ornl.gov/pub/upak/README.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=('libx11' 'gcc-libs' 'tcsh' 'bash')
+makedepends=('gcc-fortran>=4.2')
+options=(staticlibs emptydirs)
+source=("ftp://ftp.phy.ornl.gov/pub/${pkgname}/${pkgname}-src.tgz"
+ "gfortran_x86_64.patch"
+ "gfortran_i686.patch"
+ "upak.install")
+md5sums=('8ea938e72020b75cf1ca356d27821823'
+ 'fe89246ccc894cee04f20e590bab1b36'
+ 'a11d01b14c15731d21ee009de8dd3a9a'
+ '1f5d22a84125d8cbcc6ee2fdfe73ffd4')
+install="${pkgname}.install"
+package() {
+
+msg 'patch main Makefile'
+ cd "${srcdir}/${pkgname}"
+ if [ ${CARCH} == 'x86_64' ]; then
+ patch -Np2 < ${srcdir}/gfortran_x86_64.patch
+ else
+ patch -Np2 < ${srcdir}/gfortran_i686.patch
+ fi
+
+##compile
+ cd "${srcdir}/${pkgname}"
+ make clean
+ make -j1 INSTALLDIR="${pkgdir}/usr/bin" all
+
+#libraries
+ [ -d ${pkgdir}/usr/lib ] || install -d ${pkgdir}/usr/lib
+ install -Dm644 ${pkgdir}/usr/bin/*.{a,o} ${pkgdir}/usr/lib/
+# rm -f ${pkgdir}/usr/bin/*.{a,o}
+
+#documentation
+ _DOCDIR=${pkgdir}/usr/share/doc/${pkgname}
+ [ -d ${_DOCDIR} ] || install -d ${_DOCDIR}
+ install -Dm644 ${pkgdir}/usr/bin/*.{hep,ps,dat} ${_DOCDIR}
+
+#correct the location of the doc dir and change executable permissions
+ install -m644 ${pkgdir}/usr/bin/doc/* ${_DOCDIR}
+ rm -rf ${pkgdir}/usr/bin/doc
+
+ cd "${srcdir}/${pkgname}"
+ install -m644 Dreadme/README-Apr07 ${_DOCDIR}
+ install -m644 Dreadme/readme.{tex,doc} ${_DOCDIR}
+ install -m644 Dreadme/dvd.{tex,doc} ${_DOCDIR}
+
+#clean bin directory from everything else already placed in the doc dir.
+ rm -f ${pkgdir}/usr/bin/*.*
+
+msg 'Change permissions to the usual 755 for bin files'
+ chmod 755 ${pkgdir}/usr/bin/*
+
+}
diff --git a/gfortran_i686.patch b/gfortran_i686.patch
new file mode 100644
index 000000000000..f7f4be5b8131
--- /dev/null
+++ b/gfortran_i686.patch
@@ -0,0 +1,46 @@
+--- src/upak/Makefile 2012-07-24 12:56:59.786829293 -0500
++++ nsrc/upak/Makefile 2012-07-24 12:59:29.556410520 -0500
+@@ -8,7 +8,7 @@
+ # Mac/Intel Pentium = 32
+ # Intel Pentium64 = 64
+ # Dec ALPHA = 64
+-export PTRSIZE=64
++export PTRSIZE=32
+ #
+ ###-BYTEORDER-###
+ # The byte order is processor dependent
+@@ -32,22 +32,22 @@
+ #
+ #--Gfortran - must be gcc >=4.2 (gcc42 and gcc42-shlibs on Mac Fink)
+ # MacOS version
+-export F77= gfortran
+-export CC=/sw/bin/gcc-4
+-export OPT= -O
+-export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
+-export CARGS= $(FENDIAN)
+-export FLIBS= -L/sw/lib -lgfortran -lgcc
+-export INSTALLDIR= ../../hhirf
+-#
+-#--Gfortran - must be gcc >=4.2
+-# LINUX version
+ #export F77= gfortran
+-#export CC=gcc
++#export CC=/sw/bin/gcc-4
+ #export OPT= -O
+ #export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
+ #export CARGS= $(FENDIAN)
+-#export FLIBS= -lgfortran -lgcc
++#export FLIBS= -L/sw/lib -lgfortran -lgcc
++#export INSTALLDIR= ../../hhirf
++#
++#--Gfortran - must be gcc >=4.2
++# LINUX version
++export F77= gfortran
++export CC=gcc
++export OPT= -O
++export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
++export CARGS= $(FENDIAN)
++export FLIBS= -lgfortran -lgcc
+ #export INSTALLDIR= /usr/hhirf
+ #
+ #--G77
diff --git a/gfortran_x86_64.patch b/gfortran_x86_64.patch
new file mode 100644
index 000000000000..249fd8587b08
--- /dev/null
+++ b/gfortran_x86_64.patch
@@ -0,0 +1,37 @@
+--- src/upak/Makefile 2012-01-25 23:23:11.000000000 -0500
++++ nsrc/upak/Makefile 2012-07-24 12:16:23.815817171 -0500
+@@ -32,22 +32,22 @@
+ #
+ #--Gfortran - must be gcc >=4.2 (gcc42 and gcc42-shlibs on Mac Fink)
+ # MacOS version
+-export F77= gfortran
+-export CC=/sw/bin/gcc-4
+-export OPT= -O
+-export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
+-export CARGS= $(FENDIAN)
+-export FLIBS= -L/sw/lib -lgfortran -lgcc
+-export INSTALLDIR= ../../hhirf
+-#
+-#--Gfortran - must be gcc >=4.2
+-# LINUX version
+ #export F77= gfortran
+-#export CC=gcc
++#export CC=/sw/bin/gcc-4
+ #export OPT= -O
+ #export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
+ #export CARGS= $(FENDIAN)
+-#export FLIBS= -lgfortran -lgcc
++#export FLIBS= -L/sw/lib -lgfortran -lgcc
++#export INSTALLDIR= ../../hhirf
++#
++#--Gfortran - must be gcc >=4.2
++# LINUX version
++export F77= gfortran
++export CC=gcc
++export OPT= -O
++export FARGS= $(FENDIAN) -DGFORTRAN -fno-automatic -fsecond-underscore -fno-range-check
++export CARGS= $(FENDIAN)
++export FLIBS= -lgfortran -lgcc
+ #export INSTALLDIR= /usr/hhirf
+ #
+ #--G77
diff --git a/upak.install b/upak.install
new file mode 100644
index 000000000000..f8f336ad8999
--- /dev/null
+++ b/upak.install
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+post_upgrade() {
+ _help_warning
+
+}
+
+post_install() {
+ _help_warning
+}
+
+_help_warning() {
+
+ cat <<EOF
+>>> NOTE: Remember to set properly your help path. By default upak is expecting the
+>>> help to be located in /usr/hhirf/damm.hep or to be pointed out in explicitly
+>>> in the file: ${HOME}/upak_help_path.
+>>>
+>>> You can set your help path by typing in a terminal the following:
+>>>
+>>> echo "/usr/share/doc/upak/" > ${HOME}/upak_help_path
+>>>
+EOF
+}