summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2015-07-05 21:05:14 +0200
committerChris Warrick2015-07-05 21:05:14 +0200
commit10262f89cf61d5ea42eb58ad6f312508fc302961 (patch)
tree6c55e11146e085e2f223b72ddf4f1afd07b115fa
downloadaur-10262f89cf61d5ea42eb58ad6f312508fc302961.tar.gz
upass v0.1.0
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e6927420deb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = upass
+ pkgdesc = Console UI for pass
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Kwpolska/upass
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-setuptools
+ depends = python-urwid
+ depends = python-pyperclip
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/u/upass/upass-0.1.0.tar.gz
+ md5sums = ce41bbe2961dd7d655870149ead54871
+
+pkgname = upass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf3105fc1aa9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=upass
+_pyname=upass
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Console UI for pass'
+arch=('any')
+url='https://github.com/Kwpolska/upass'
+license=('BSD')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('ce41bbe2961dd7d655870149ead54871')
+depends=('python' 'python-setuptools' 'python-urwid' 'python-pyperclip')
+
+prepare() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+}
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: