aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Cho2023-12-28 11:09:19 +0900
committerXavier Cho2023-12-28 11:09:19 +0900
commit19a22911b94c40ca59d787b77382ef28643f8be1 (patch)
tree522fb23b165f98eae97012114eea50e91497c32b
parent3a01da38cecaee9b0e5fb0b7da4bb69a60fa9ef6 (diff)
downloadaur-19a22911b94c40ca59d787b77382ef28643f8be1.tar.gz
Delete Python 3.11 patch which is no longer needed
-rw-r--r--.SRCINFO4
-rw-r--r--1001-python11.patch32
-rw-r--r--PKGBUILD6
3 files changed, 3 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b32f078c1c52..ba82e03bb436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upbge-git
pkgdesc = Uchronia Project Blender Game Engine fork of Blender Game Engine
- pkgver = 136340.df8f20a0abb
+ pkgver = 137410.f523c32ec73
pkgrel = 1
url = https://upbge.org/
arch = i686
@@ -68,7 +68,6 @@ pkgbase = upbge-git
source = 0001-use-github.com-for-make-update-git.patch
source = 0003-usd-python.patch
source = 0004-fix-opencollada-pcre.patch
- source = 1001-python11.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -79,6 +78,5 @@ pkgbase = upbge-git
sha256sums = 0bb8ac4cba0ac00999790087c51e601d185b78a96081f08a7c7afb8c0f4b0d7c
sha256sums = c2db51a83a8d573aa76c760f10e541c84b108d64d05c9647681c4e633b3d0397
sha256sums = 6beedc541e33288a282f57cd2bd09860f333154027b6175e9f61cce49b8db5df
- sha256sums = ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff
pkgname = upbge-git
diff --git a/1001-python11.patch b/1001-python11.patch
deleted file mode 100644
index f617f1d2a227..000000000000
--- a/1001-python11.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/source/gameengine/GameLogic/SCA_PythonController.cpp b/source/gameengine/GameLogic/SCA_PythonController.cpp
-index c66bcc722d4..a2c0eee4efc 100644
---- a/source/gameengine/GameLogic/SCA_PythonController.cpp
-+++ b/source/gameengine/GameLogic/SCA_PythonController.cpp
-@@ -36,7 +36,6 @@
-
- #ifdef WITH_PYTHON
- # include "compile.h"
--# include "eval.h"
- # include "py_capi_utils.h"
- #endif // WITH_PYTHON
-
-diff --git a/source/gameengine/VideoTexture/Texture.cpp b/source/gameengine/VideoTexture/Texture.cpp
-index bbf4fbb2965..34a58799880 100644
---- a/source/gameengine/VideoTexture/Texture.cpp
-+++ b/source/gameengine/VideoTexture/Texture.cpp
-@@ -445,11 +445,11 @@ EXP_PYMETHODDEF_DOC(Texture, refresh, "Refresh texture from source")
- * "refresh" method), because the depsgraph has not been warned yet. */
- bool needs_notifier = m_source && (
- #ifdef WITH_FFMPEG
-- _Py_IS_TYPE(&m_source->ob_base, &VideoFFmpegType) ||
-- _Py_IS_TYPE(&m_source->ob_base, &ImageFFmpegType) ||
-+ Py_IS_TYPE(&m_source->ob_base, &VideoFFmpegType) ||
-+ Py_IS_TYPE(&m_source->ob_base, &ImageFFmpegType) ||
- #endif // WITH_FFMPEG
-- _Py_IS_TYPE(&m_source->ob_base, &ImageMixType) ||
-- _Py_IS_TYPE(&m_source->ob_base, &ImageViewportType));
-+ Py_IS_TYPE(&m_source->ob_base, &ImageMixType) ||
-+ Py_IS_TYPE(&m_source->ob_base, &ImageViewportType));
- if (needs_notifier) {
- /* This update notifier will be flushed next time
- * BKE_scene_graph_update_tagged will be called */
diff --git a/PKGBUILD b/PKGBUILD
index a39f83b21adf..046c1327b7e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
_fragment="${FRAGMENT:-#branch=master}"
pkgname=upbge-git
-pkgver=136340.df8f20a0abb
+pkgver=137410.f523c32ec73
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=('i686' 'x86_64')
@@ -51,7 +51,6 @@ source=("upbge::git+https://github.com/UPBGE/upbge${_fragment}"
'0001-use-github.com-for-make-update-git.patch'
'0003-usd-python.patch' #add missing python headers when building against python enabled usd.
'0004-fix-opencollada-pcre.patch' #fix broken search for opencollada pcre
- '1001-python11.patch' #support Python 3.11
)
sha256sums=('SKIP'
'SKIP'
@@ -62,8 +61,7 @@ sha256sums=('SKIP'
'b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a'
'0bb8ac4cba0ac00999790087c51e601d185b78a96081f08a7c7afb8c0f4b0d7c'
'c2db51a83a8d573aa76c760f10e541c84b108d64d05c9647681c4e633b3d0397'
- '6beedc541e33288a282f57cd2bd09860f333154027b6175e9f61cce49b8db5df'
- 'ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff')
+ '6beedc541e33288a282f57cd2bd09860f333154027b6175e9f61cce49b8db5df')
pkgver() {
cd "$srcdir/upbge"