aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Cho2023-09-04 17:59:07 +0900
committerXavier Cho2023-09-04 17:59:07 +0900
commit1c24046368e186601e0d3741d2b3b1d079e1ef99 (patch)
treee345098cb499fbc2798ae2ad2d68cb9682a1fb2f
parent4f6e6d8efa91f580c01e7a0ab9b7d1bb59e7f063 (diff)
downloadaur-1c24046368e186601e0d3741d2b3b1d079e1ef99.tar.gz
Update Embree patch to fix build problem
-rw-r--r--PKGBUILD2
-rw-r--r--embree.patch34
2 files changed, 18 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5753f0794164..9052004cc549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -56,7 +56,7 @@ sha256sums=(
"ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff"
"5b98624ec2ce39fdb33836527343d026edbb63c948850b20c1c20c019d24f434"
"155c04f971d3f45618a89fa73d91e21ba493ae24029475e18192c49c3fcd8cb4"
- "e34fa6034ca065cdddc380ef7fb1ab094349203dc6d63b2526cdf4740b1eaf02")
+ "a35710a189324679322e74b65754993831fe0ac7db3f9a774a1b799afba6cd08")
pkgver() {
cd "$srcdir/upbge"
diff --git a/embree.patch b/embree.patch
index 5afa3bf3cfb0..55e933d9934a 100644
--- a/embree.patch
+++ b/embree.patch
@@ -1,8 +1,8 @@
diff --git a/build_files/cmake/Modules/FindEmbree.cmake b/build_files/cmake/Modules/FindEmbree.cmake
-index c7f9bc5b220..4e3bcdca897 100644
+index 8d64e09e0f9..f56841976cc 100644
--- a/build_files/cmake/Modules/FindEmbree.cmake
+++ b/build_files/cmake/Modules/FindEmbree.cmake
-@@ -10,6 +10,9 @@
+@@ -11,6 +11,9 @@
# EMBREE_ROOT_DIR, The base directory to search for Embree.
# This can also be an environment variable.
# EMBREEFOUND, If false, do not try to use Embree.
@@ -10,13 +10,13 @@ index c7f9bc5b220..4e3bcdca897 100644
+# also defined, but not for general use are
+# EMBREE_LIBRARY, where to find the Embree library.
- # If EMBREE_ROOT_DIR was defined in the environment, use it.
- IF(NOT EMBREE_ROOT_DIR AND NOT $ENV{EMBREE_ROOT_DIR} STREQUAL "")
-@@ -103,14 +106,23 @@ FOREACH(COMPONENT ${_embree_FIND_COMPONENTS})
- LIST(APPEND _embree_LIBRARIES "${EMBREE_${UPPERCOMPONENT}_LIBRARY}")
- ENDFOREACH()
+ # If `EMBREE_ROOT_DIR` was defined in the environment, use it.
+ if(DEFINED EMBREE_ROOT_DIR)
+@@ -108,14 +111,23 @@ foreach(COMPONENT ${_embree_FIND_COMPONENTS})
+ list(APPEND _embree_LIBRARIES "${EMBREE_${UPPERCOMPONENT}_LIBRARY}")
+ endforeach()
-+FIND_LIBRARY(EMBREE_LIBRARY
++find_library(EMBREE_LIBRARY
+ NAMES
+ embree4
+ HINTS
@@ -27,22 +27,22 @@ index c7f9bc5b220..4e3bcdca897 100644
+
# handle the QUIETLY and REQUIRED arguments and set EMBREE_FOUND to TRUE if
# all listed variables are TRUE
- INCLUDE(FindPackageHandleStandardArgs)
- FIND_PACKAGE_HANDLE_STANDARD_ARGS(Embree DEFAULT_MSG
+ include(FindPackageHandleStandardArgs)
+ find_package_handle_standard_args(Embree DEFAULT_MSG
- _embree_LIBRARIES EMBREE_INCLUDE_DIR)
+ EMBREE_LIBRARY EMBREE_INCLUDE_DIR)
- IF(EMBREE_FOUND)
-- SET(EMBREE_LIBRARIES ${_embree_LIBRARIES})
-+ SET(EMBREE_LIBRARIES ${EMBREE_LIBRARY})
- SET(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
- ENDIF()
+ if(EMBREE_FOUND)
+- set(EMBREE_LIBRARIES ${_embree_LIBRARIES})
++ set(EMBREE_LIBRARIES ${EMBREE_LIBRARY})
+ set(EMBREE_INCLUDE_DIRS ${EMBREE_INCLUDE_DIR})
+ endif()
diff --git a/intern/cycles/blender/CMakeLists.txt b/intern/cycles/blender/CMakeLists.txt
-index ceb024ba5e7..d3320545c1f 100644
+index dcc960bef4b..56fb56cca6f 100644
--- a/intern/cycles/blender/CMakeLists.txt
+++ b/intern/cycles/blender/CMakeLists.txt
-@@ -80,6 +80,12 @@ if(WITH_CYCLES_LOGGING)
+@@ -83,6 +83,12 @@ if(WITH_CYCLES_LOGGING)
)
endif()