aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier Cho2023-09-04 18:27:48 +0900
committerXavier Cho2023-09-04 18:27:48 +0900
commitbaf2cb5f037a883899c19bea90b647f440c5ca72 (patch)
treef989cd29b82983d6b4f6e9b751725fd13cd0cca3
parent65a31c772113187ecf898f5bce19ecdd68412fae (diff)
downloadaur-baf2cb5f037a883899c19bea90b647f440c5ca72.tar.gz
Fix issue with detecting USD
Disabling Hydra support to fix build problem for now.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--usd.patch (renamed from usd_python.patch)14
3 files changed, 26 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a17e1547d5c0..b8aa71a056df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upbge-git
pkgdesc = Uchronia Project Blender Game Engine fork of Blender Game Engine
- pkgver = 129501.11ca6b54643
+ pkgver = 133373.00f0df37d6f
pkgrel = 1
url = https://upbge.org/
install = upbge.install
@@ -34,6 +34,7 @@ pkgbase = upbge-git
depends = openimageio
depends = opencolorio
depends = libdecor
+ depends = openexr
depends = openvdb
depends = opencollada
depends = opensubdiv
@@ -62,7 +63,7 @@ pkgbase = upbge-git
source = blender-dev-tools.git::git+https://projects.blender.org/blender/blender-dev-tools.git
source = upbge.desktop
source = python11.patch
- source = usd_python.patch
+ source = usd.patch
source = SelectCudaComputeArch.patch
source = embree.patch
sha256sums = SKIP
@@ -72,8 +73,8 @@ pkgbase = upbge-git
sha256sums = SKIP
sha256sums = b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a
sha256sums = ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff
- sha256sums = 5b98624ec2ce39fdb33836527343d026edbb63c948850b20c1c20c019d24f434
+ sha256sums = 344259c0cb968f12a9aba1a995dc40f386bab2f65e118c9c2e46c192c6b65c84
sha256sums = 155c04f971d3f45618a89fa73d91e21ba493ae24029475e18192c49c3fcd8cb4
- sha256sums = e34fa6034ca065cdddc380ef7fb1ab094349203dc6d63b2526cdf4740b1eaf02
+ sha256sums = a35710a189324679322e74b65754993831fe0ac7db3f9a774a1b799afba6cd08
pkgname = upbge-git
diff --git a/PKGBUILD b/PKGBUILD
index 141f0f3b3c50..3ce9b8ed2fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
#shellcheck disable=SC2015
pkgname=upbge-git
-pkgver=129501.11ca6b54643
+pkgver=133373.00f0df37d6f
pkgrel=1
pkgdesc="Uchronia Project Blender Game Engine fork of Blender Game Engine"
arch=("i686" "x86_64")
@@ -43,7 +43,7 @@ source=(
"blender-dev-tools.git::git+https://projects.blender.org/blender/blender-dev-tools.git"
upbge.desktop
python11.patch
- usd_python.patch
+ usd.patch
SelectCudaComputeArch.patch
embree.patch)
sha256sums=(
@@ -54,7 +54,7 @@ sha256sums=(
"SKIP"
"b5c9bf4fa265389db4b3f23e96d74cc86c51d908b8943eb80967614d8af1ea1a"
"ae81c77dd41736bbcf65e31fa77477979b214004be3423e10eddef7af3f12dff"
- "5b98624ec2ce39fdb33836527343d026edbb63c948850b20c1c20c019d24f434"
+ "344259c0cb968f12a9aba1a995dc40f386bab2f65e118c9c2e46c192c6b65c84"
"155c04f971d3f45618a89fa73d91e21ba493ae24029475e18192c49c3fcd8cb4"
"a35710a189324679322e74b65754993831fe0ac7db3f9a774a1b799afba6cd08")
@@ -128,10 +128,12 @@ build() {
fi
# check for universal scene descriptor
- _USD_PKG=$(pacman -Qq usd=21.02 2>/dev/null) || true
+ _USD_PKG=$(pacman -Qq usd>/dev/null) || true
if [ "$_USD_PKG" != "" ]; then
_CMAKE_FLAGS+=( -DWITH_USD=ON
- -DUSD_ROOT=/usr )
+ -DUSD_ROOT_DIR=/usr/lib )
+ else
+ _CMAKE_FLAGS+=( -DWITH_HYDRA=OFF )
fi
(2>&1 CUDAHOSTCXX="$CUDAHOSTCXX" cmake -S "$srcdir/upbge" -B build --fresh \
diff --git a/usd_python.patch b/usd.patch
index 854da3d69da6..bc14274d1fa8 100644
--- a/usd_python.patch
+++ b/usd.patch
@@ -1,3 +1,17 @@
+diff --git a/build_files/cmake/Modules/FindUSD.cmake b/build_files/cmake/Modules/FindUSD.cmake
+index f3b7d88a073..e77c0651e71 100644
+--- a/build_files/cmake/Modules/FindUSD.cmake
++++ b/build_files/cmake/Modules/FindUSD.cmake
+@@ -46,7 +46,7 @@ endif()
+ # See https://github.com/PixarAnimationStudios/USD/blob/release/CHANGELOG.md#2111---2021-11-01
+ find_library(USD_LIBRARY
+ NAMES
+- usd_usd_m usd_usd_ms usd_m usd_ms
++ usd_usd
+ ${PXR_LIB_PREFIX}usd
+ NAMES_PER_DIR
+ HINTS
+
diff --git a/source/blender/io/usd/CMakeLists.txt b/source/blender/io/usd/CMakeLists.txt
index 568ed4c7641..c847adbd077 100644
--- a/source/blender/io/usd/CMakeLists.txt