summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Toloza2019-03-27 10:31:36 -0500
committerEduard Toloza2019-03-27 10:31:36 -0500
commit024e327d65c99062442d22300532d843624f0f3e (patch)
tree6010aec17cdf7139ad74b350db9c510629b61ad7
parent2179d681cc5c3de400e1fd8c9e85ed468a5ee932 (diff)
downloadaur-024e327d65c99062442d22300532d843624f0f3e.tar.gz
Remove install file and fix PKGBUILD style.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
-rw-r--r--upcheck.install3
3 files changed, 11 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e0d57e07160..e56be59551e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = upcheck
pkgdesc = Checker for ArchLinux available updates and send it via notify-rust.
pkgver = 0.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/edu4rdshl/upcheck
- install = upcheck.install
arch = x86_64
license = GPL3
depends = pacman-contrib
source = https://gitlab.com/edu4rdshl/upcheck/-/archive/0.1.1/upcheck-0.1.1.tar.gz
- source = upcheck.install
sha512sums = 208443c757528396e82980bf31654f5d1802abcd090422a2ceff7bfbfb512e5173f20e5eca5f0d53b8e38c747b1909940d69970e61b5f894923b02f0cf16b948
- sha512sums = SKIP
pkgname = upcheck
diff --git a/PKGBUILD b/PKGBUILD
index bde229d84246..3dd2c3573ba3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
-# Maintainer: Eduard Toloza edu4rdshl@securityhacklabs.net
+# Maintainer: Eduard Toloza <tolosaeduard@gmail.com>
pkgname=upcheck
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc='Checker for ArchLinux available updates and send it via notify-rust.'
arch=('x86_64')
-url="https://gitlab.com/edu4rdshl/upcheck"
+url='https://gitlab.com/edu4rdshl/upcheck'
license=('GPL3')
depends=('pacman-contrib')
-source=("https://gitlab.com/edu4rdshl/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "$pkgname.install")
-sha512sums=('208443c757528396e82980bf31654f5d1802abcd090422a2ceff7bfbfb512e5173f20e5eca5f0d53b8e38c747b1909940d69970e61b5f894923b02f0cf16b948'
- 'SKIP')
-install="$pkgname.install"
+source=("https://gitlab.com/edu4rdshl/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('208443c757528396e82980bf31654f5d1802abcd090422a2ceff7bfbfb512e5173f20e5eca5f0d53b8e38c747b1909940d69970e61b5f894923b02f0cf16b948')
package() {
- cd $pkgname-$pkgver
- install -dm 755 "$pkgdir/usr/lib/systemd/user/"
+ cd "${pkgname}-${pkgver}"
+ install -dm 755 "${pkgdir}/usr/lib/systemd/user/"
- install -Dm 755 bin/$pkgname "$pkgdir/usr/bin/$pkgname"
- install -Dm 755 README.md "$pkgdir/usr/share/doc/$pkgname/README"
- cp $pkgname.{service,timer} "$pkgdir/usr/lib/systemd/user/"
+ install -Dm 755 bin/"${pkgname}" "{$pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
+ cp "${pkgname}".{service,timer} "${pkgdir}/usr/lib/systemd/user/"
}
diff --git a/upcheck.install b/upcheck.install
deleted file mode 100644
index d18e30698a18..000000000000
--- a/upcheck.install
+++ /dev/null
@@ -1,3 +0,0 @@
-post_install () {
- echo ">> To get upcheck working automatically, you need to enable the upcheck.timer unit via systemd."
-}