summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2015-09-11 22:42:55 -0700
committerpyamsoft2015-09-11 22:46:18 -0700
commit4a1bf01dccb619bae4f6476b2534bee1ce7a8e8a (patch)
treecc39faeacc87c99e3ff3ae2b8fe61e8ad7b0197a
downloadaur-4a1bf01dccb619bae4f6476b2534bee1ce7a8e8a.tar.gz
Initial pkgbuild commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b101df11153
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = update-hosts-git
+ pkgdesc = Generate a hosts file based on multiple sources (git)
+ pkgver = 1.0.0.git
+ pkgrel = 1
+ url = https://github.com/pyamsoft/update-hosts.git
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = coreutils
+ depends = gawk
+ depends = sed
+ depends = grep
+ optdepends = curl: Default download client
+ optdepends = wget: Optional download client
+ provides = update-hosts
+ conflicts = update-hosts
+ source = update-hosts::git+https://github.com/pyamsoft/update-hosts.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = update-hosts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0b32b6064b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+##
+# Maintainer: pyamsoft <pyam(dot)soft(at)gmail(dot)com>
+##
+
+pkgname=update-hosts-git
+_gitname=update-hosts
+pkgdesc="Generate a hosts file based on multiple sources (git)"
+pkgver=r47.8aaa35e
+pkgrel=1
+arch=('i686' 'x86_64')
+makedepends=('git')
+depends=('coreutils' 'gawk' 'sed' 'grep')
+optdepends=('curl: Default download client' 'wget: Optional download client')
+provides=('update-hosts')
+conflicts=('update-hosts')
+license=('MIT')
+url="https://github.com/pyamsoft/update-hosts.git"
+
+##
+# The SHA256 is constantly changing since this is
+# pulled from git so skip the verification check
+##
+sha256sums=('SKIP')
+source=("${_gitname}::git+${url}#branch=master")
+
+###############################################################################
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ # From
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function
+ # If there are no tags then use number of revisions since beginning of the history:
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+}
+