summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2020-06-12 15:48:26 +0600
committerMubashshir2020-06-12 15:48:26 +0600
commiteb62000d438676d6e5805a62b59e0f3d3ca75b2b (patch)
treea588b745caedc38f39ad75bff110827166ad0e8c
downloadaur-eb62000d438676d6e5805a62b59e0f3d3ca75b2b.tar.gz
init
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d04088457b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = update-notifier
+ pkgdesc = A simple pacman update notifier
+ pkgver = 0.7.7
+ pkgrel = 3
+ url = https://github.com/Chrysostomus/update-notifier
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = awk
+ depends = dunst>=1.3.2-2
+ depends = libnotify
+ depends = fakeroot
+ optdepends = yaourt: for AUR support
+ optdepends = gnome-terminal: for integration with gnome-update-notifications
+ optdepends = pamac: for graphical update actions
+ source = git://github.com/Chrysostomus/update-notifier
+ source = pamac-update.patch::https://github.com/Chrysostomus/update-notifier/pull/23/commits/2467f6f1c8e6e1e47db95ac24d1070cc8ebcd24f.patch
+ md5sums = SKIP
+ md5sums = b40a0af64008acba4efcdf00f8f2bac9
+
+pkgname = update-notifier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25be94ab49e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+pkgname=update-notifier
+pkgver=0.7.7
+pkgrel=3
+pkgdesc="A simple pacman update notifier"
+arch=(any)
+url="https://github.com/Chrysostomus/$pkgname"
+license=('MIT')
+depends=('awk'
+ 'dunst>=1.3.2-2'
+ 'libnotify'
+ 'fakeroot')
+optdepends=('yaourt: for AUR support'
+ 'gnome-terminal: for integration with gnome-update-notifications'
+ 'pamac: for graphical update actions')
+makedepends=('git')
+source=("git://github.com/Chrysostomus/$pkgname"
+ 'pamac-update.patch::https://github.com/Chrysostomus/update-notifier/pull/23/commits/2467f6f1c8e6e1e47db95ac24d1070cc8ebcd24f.patch')
+md5sums=('SKIP'
+ 'b40a0af64008acba4efcdf00f8f2bac9')
+
+prepare() {
+ cd $pkgname
+ patch -p1 -i ../pamac-update.patch
+}
+
+package () {
+ cd "$srcdir"
+ install -Dm755 "$srcdir/$pkgname/update-notifier" "$pkgdir/usr/bin/update-notifier"
+ install -Dm755 "$srcdir/$pkgname/update-checker" "$pkgdir/usr/bin/update-checker"
+ install -Dm755 "$srcdir/$pkgname/update-check" "$pkgdir/usr/bin/update-check"
+ install -Dm755 "$srcdir/$pkgname/update-command" "$pkgdir/usr/bin/update-command"
+ install -Dm755 "$srcdir/$pkgname/update-help" "$pkgdir/usr/bin/update-help"
+}