summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Deininger2016-03-06 01:28:55 -0800
committerJeremy Deininger2016-03-06 01:28:55 -0800
commit0d981d3dd8e65d4aa58dae2095a641d451ad3e54 (patch)
tree7085e69e0e2cc51b33dd80a6ef882a654cf913c3
parenteb163df07d6e36d774d755570732892c31cc959f (diff)
downloadaur-0d981d3dd8e65d4aa58dae2095a641d451ad3e54.tar.gz
fixing git pkgver
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD5
2 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5be45ae7aa2e..72ec936913dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,3 +15,20 @@ pkgbase = update-ssh-keys
pkgname = update-ssh-keys
+# Generated by makepkg 5.0.0
+# Sun Mar 6 09:28:14 UTC 2016
+pkgbase = update-ssh-keys
+ pkgdesc = SSH Key helper binary from github.com/coreos/update-ssh-keys
+ pkgver = r21.206b3aa
+ pkgrel = 1
+ url = https://github.com/coreos/update-ssh-keys
+ arch = x86_64
+ license = apache
+ makedepends = go
+ provides = update-ssh-keys
+ replaces = update-ssh-keys
+ source = update-ssh-keys::git+https://github.com/coreos/update-ssh-keys
+ md5sums = SKIP
+
+pkgname = update-ssh-keys
+
diff --git a/PKGBUILD b/PKGBUILD
index ab2839c63d11..1151d9f67e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=update-ssh-keys
-pkgver=0.0.1
+pkgver=r21.206b3aa
pkgrel=1
pkgdesc="SSH Key helper binary from github.com/coreos/update-ssh-keys"
arch=('x86_64')
@@ -13,9 +13,10 @@ md5sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
build() {
cd "$pkgname"
./build