summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Deininger2016-02-17 18:46:58 -0800
committerJeremy Deininger2016-02-17 18:46:58 -0800
commiteb163df07d6e36d774d755570732892c31cc959f (patch)
treeb722e962f7878c6cff8afb48d2d2dfd75c3a7888
downloadaur-eb163df07d6e36d774d755570732892c31cc959f.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5be45ae7aa2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Feb 18 02:46:49 UTC 2016
+pkgbase = update-ssh-keys
+ pkgdesc = SSH Key helper binary from github.com/coreos/update-ssh-keys
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/coreos/update-ssh-keys
+ arch = x86_64
+ license = apache
+ makedepends = go
+ provides = update-ssh-keys
+ replaces = update-ssh-keys
+ source = update-ssh-keys::git+https://github.com/coreos/update-ssh-keys
+ md5sums = SKIP
+
+pkgname = update-ssh-keys
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ab2839c63d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=update-ssh-keys
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="SSH Key helper binary from github.com/coreos/update-ssh-keys"
+arch=('x86_64')
+url="https://github.com/coreos/update-ssh-keys"
+license=(apache)
+makedepends=('go')
+provides=('update-ssh-keys')
+replaces=('update-ssh-keys')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./build
+}
+
+package() {
+ cd "${pkgname}"
+ mkdir -p ${pkgdir}/usr/bin
+ cp bin/* ${pkgdir}/usr/bin
+}
+
+# vim:set ts=2 sw=2 et: