summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 04:39:04 -0600
committerBrian Bidulock2015-06-10 04:39:04 -0600
commit1651f5acc0ebefd842549a6866ad9ccd478b48ca (patch)
tree1a7a9268de4b59bf20306d662caec5253814a566
downloadaur-1651f5acc0ebefd842549a6866ad9ccd478b48ca.tar.gz
initial version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rwxr-xr-xupdategeoip39
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e7ea862a575
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = updategeoip
+ pkgdesc = Updates geoip with the free country- and city-databases by MaxMind.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://aur.archlinux.org/packages.php?ID=23225
+ arch = any
+ license = GPL
+ depends = bash
+ source = updategeoip
+ md5sums = 752d9e6b1e71840881089a8e43a9d8f1
+
+pkgname = updategeoip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7765b803f056
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Contributor: Rorschach
+
+pkgname=updategeoip
+pkgver=1.0
+pkgrel=1
+pkgdesc="Updates geoip with the free country- and city-databases by MaxMind."
+url="http://aur.archlinux.org/packages.php?ID=23225"
+arch=('any')
+license="GPL"
+depends=('bash')
+source=(updategeoip)
+md5sums=('752d9e6b1e71840881089a8e43a9d8f1')
+
+build() {
+ install -Dm755 updategeoip $pkgdir/usr/bin/updategeoip
+}
diff --git a/updategeoip b/updategeoip
new file mode 100755
index 000000000000..0d0b9e2a3a92
--- /dev/null
+++ b/updategeoip
@@ -0,0 +1,39 @@
+#!/bin/bash
+#
+# Updates geoip with the free country- and
+# city databases provided by maxmind.com
+#
+# Copyright (c) 2008 by Rorschach
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+# THE SOFTWARE.
+
+
+
+PATH_TO_DB=/usr/share/GeoIP
+
+cd /tmp
+
+wget http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz
+wget http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
+
+gunzip GeoIP.dat.gz
+gunzip GeoLiteCity.dat.gz
+
+sudo mv GeoIP.dat $PATH_TO_DB/GeoIP.dat
+sudo mv GeoLiteCity.dat $PATH_TO_DB/GeoIPCity.dat