summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaoph2018-09-01 13:28:46 -0400
committernaoph2018-09-01 13:28:46 -0400
commitc73fd7c1e262cc165e5b88c4db5a6f4fb0330149 (patch)
tree948eb2a0101a1c36eda09a0e6d4ddb0578de93f6
downloadaur-c73fd7c1e262cc165e5b88c4db5a6f4fb0330149.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6e9c3ed91eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = upl-git
+ pkgdesc = A tiny script for uploading files to webservers over SSH
+ pkgver = 0.1.r0.g042c169
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/naoph/upl
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-yaml
+ depends = scp
+ provides = upl
+ conflicts = upl
+ source = upl-git::git+https://github.com/naoph/upl.git
+ md5sums = SKIP
+
+pkgname = upl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a78c2704589a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Naomi Phillips <naoph@cryptolab.net>
+pkgname=upl-git
+_pkgname=upl
+pkgver=0.1.r0.g042c169
+pkgrel=1
+epoch=1
+pkgdesc="A tiny script for uploading files to webservers over SSH"
+arch=('any')
+url="https://github.com/naoph/upl"
+license=('GPL')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=('python' 'python-yaml' 'scp')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/naoph/upl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 "upl" "$pkgdir/usr/bin/upl"
+}