summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoreleaserbot2022-05-14 08:27:55 +0000
committergoreleaserbot2022-05-14 08:27:55 +0000
commitca2c297d6633aa56a3ba3979ef3f39137f202233 (patch)
treeb75db6de95f316468cfa962592a6c2e37bead6df
downloadaur-ca2c297d6633aa56a3ba3979ef3f39137f202233.tar.gz
Update to v2.12.0
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee340dd9aebf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = uplift-bin
+ pkgdesc = Semantic versioning the easy way. Powered by Conventional Commits. Built for use with CI
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = https://upliftci.dev
+ license = MIT
+ conflicts = uplift
+ provides = uplift
+ arch = aarch64
+ source_aarch64 = https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-arm64.tar.gz
+ sha256sums_aarch64 = 8406963a42234361857b0dffc8418e8432e00327f33444eb951d858e64dd4a2f
+ arch = armv7h
+ source_armv7h = https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-arm.tar.gz
+ sha256sums_armv7h = 402b0ceb7ea19a1a3fadf2b2ef162e2e5a8969fa333f051f3a5828dd79facad3
+ arch = i686
+ source_i686 = https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-i386.tar.gz
+ sha256sums_i686 = bbc21403615ff74b30a08965a1053fc054e112b58e170d82350af1c7e3d898c6
+ arch = x86_64
+ source_x86_64 = https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-x86_64.tar.gz
+ sha256sums_x86_64 = c0d657a961fb1f84875871f8d617d727deca68b1f35b78e0e88254874f761533
+
+pkgname = uplift-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb7469aef693
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Paul T <paul dot t at gembaadvantage dot com>
+
+pkgname='uplift-bin'
+pkgver=2.12.0
+pkgrel=1
+pkgdesc='Semantic versioning the easy way. Powered by Conventional Commits. Built for use with CI'
+url='https://upliftci.dev'
+arch=('aarch64' 'armv7h' 'i686' 'x86_64')
+license=('MIT')
+provides=('uplift')
+conflicts=('uplift')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-arm64.tar.gz")
+sha256sums_aarch64=('8406963a42234361857b0dffc8418e8432e00327f33444eb951d858e64dd4a2f')
+
+source_armv7h=("${pkgname}_${pkgver}_armv7h.tar.gz::https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-arm.tar.gz")
+sha256sums_armv7h=('402b0ceb7ea19a1a3fadf2b2ef162e2e5a8969fa333f051f3a5828dd79facad3')
+
+source_i686=("${pkgname}_${pkgver}_i686.tar.gz::https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-i386.tar.gz")
+sha256sums_i686=('bbc21403615ff74b30a08965a1053fc054e112b58e170d82350af1c7e3d898c6')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/gembaadvantage/uplift/releases/download/v2.12.0/uplift_2.12.0_linux-x86_64.tar.gz")
+sha256sums_x86_64=('c0d657a961fb1f84875871f8d617d727deca68b1f35b78e0e88254874f761533')
+
+package() {
+ # bin
+ install -Dm755 "./uplift" "${pkgdir}/usr/bin/uplift"
+ # license
+ install -Dm644 "./LICENSE.md" "${pkgdir}/usr/share/licenses/uplift/LICENSE"
+ # completions
+ mkdir -p "${pkgdir}/usr/share/bash-completion/completions/"
+ mkdir -p "${pkgdir}/usr/share/zsh/site-functions/"
+ mkdir -p "${pkgdir}/usr/share/fish/vendor_completions.d/"
+ install -Dm644 "./completions/uplift.bash" "${pkgdir}/usr/share/bash-completion/completions/uplift"
+ install -Dm644 "./completions/uplift.zsh" "${pkgdir}/usr/share/zsh/site-functions/_uplift"
+ install -Dm644 "./completions/uplift.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/uplift.fish"
+}