summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2016-10-29 11:14:34 -0700
committerEric Anderson2016-10-29 11:14:34 -0700
commit0b1b82c907a0a3204dbd584bd08d15c5ab8c2e5a (patch)
tree95996bea24d0cf9e35e567ce1eebd3fdc0c17f32
parent2967a5bee6f1b8494e66ab572ed08fa4e06dab6f (diff)
downloadaur-0b1b82c907a0a3204dbd584bd08d15c5ab8c2e5a.tar.gz
Modernize PKGBUILD and depend on libjpeg6-turbo instead of libjpeg
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a7c481a743b..fd788ea2b1e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
+# Generated by mksrcinfo v8
+# Sat Oct 29 18:14:03 UTC 2016
pkgbase = uplink-hib
pkgdesc = A futuristic computer crime game (requires uplink from Humble Bundle)
pkgver = 1.6_1
- pkgrel = 7
+ pkgrel = 8
url = http://www.introversion.co.uk/uplink
arch = i686
arch = x86_64
license = custom
depends = mesa
- depends = libjpeg6
+ depends = libjpeg6-turbo
depends = sdl_mixer
depends = libtiff3
depends = freetype2
conflicts = uplink
source = uplink.desktop
- source = hib://uplink_1.6-1_i386.tar.gz
- md5sums = e4c6a0050cb3a0894fb5c70a46c51414
- md5sums = db4f1b9506cff9e348dd52709f6a8ad7
+ sha256sums = 4998ac81d6fd071355cd421b3206c69470f929613dfcc97361a12194e8cfbfaa
+ source_i686 = hib://uplink_1.6-1_i386.tar.gz
+ md5sums_i686 = db4f1b9506cff9e348dd52709f6a8ad7
+ source_x86_64 = hib://uplink_1.6-1_amd64.tar.gz
+ md5sums_x86_64 = 8ee01e7d0d688339fbd84e2005d4625b
pkgname = uplink-hib
diff --git a/PKGBUILD b/PKGBUILD
index da4f0548e5bc..7dc13d08e445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,19 @@ pkgname=uplink-hib
_pkgname=uplink
pkgver=1.6_1
_pkgver=1.6-1
-pkgrel=7
+pkgrel=8
pkgdesc='A futuristic computer crime game (requires uplink from Humble Bundle)'
arch=('i686' 'x86_64')
url='http://www.introversion.co.uk/uplink'
license=('custom')
-depends=('mesa' 'libjpeg6' 'sdl_mixer' 'libtiff3' 'freetype2')
+depends=('mesa' 'libjpeg6-turbo' 'sdl_mixer' 'libtiff3' 'freetype2')
conflicts=('uplink')
-if [ "$CARCH" = "x86_64" ]; then
- _gamepkg="${_pkgname}_${_pkgver}_amd64.tar.gz"
- _gamepkgsum='8ee01e7d0d688339fbd84e2005d4625b'
- _archi='x64'
- _aarchi='x86_64'
- _libi='lib64'
-else
- _gamepkg="${_pkgname}_${_pkgver}_i386.tar.gz"
- _gamepkgsum='db4f1b9506cff9e348dd52709f6a8ad7'
- _archi='x86'
- _aarchi='x86'
- _libi='lib'
-fi
-source=("${_pkgname}.desktop" "hib://${_gamepkg}")
-md5sums=('e4c6a0050cb3a0894fb5c70a46c51414' "${_gamepkgsum}")
+source=("${_pkgname}.desktop")
+sha256sums=('4998ac81d6fd071355cd421b3206c69470f929613dfcc97361a12194e8cfbfaa')
+source_x86_64=("hib://${_pkgname}_${_pkgver}_amd64.tar.gz")
+md5sums_x86_64=('8ee01e7d0d688339fbd84e2005d4625b')
+source_i686=("hib://${_pkgname}_${_pkgver}_i386.tar.gz")
+md5sums_i686=('db4f1b9506cff9e348dd52709f6a8ad7')
# You can download the Humble Indie Bundle file manually, or you can configure
# DLAGENTS in makepkg.conf to auto-download.
#
@@ -40,6 +31,16 @@ md5sums=('e4c6a0050cb3a0894fb5c70a46c51414' "${_gamepkgsum}")
DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download the file manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf"; echo "Read this PKGBUILD for more info."; exit 1')
PKGEXT='.pkg.tar.gz'
+if [ "$CARCH" = "x86_64" ]; then
+ _archi='x64'
+ _aarchi='x86_64'
+ _libi='lib64'
+else
+ _archi='x86'
+ _aarchi='x86'
+ _libi='lib'
+fi
+
package() {
cd "${srcdir}/${_pkgname}-${_archi}"
@@ -47,7 +48,7 @@ package() {
cp -r . "${pkgdir}/opt/${_pkgname}"
# Use system-provided libraries where possible. Use provided mikmod since the
- # system version is too new. Use provided SDL_mixer since it crashes with
+ # system so version is too new. Use provided SDL_mixer since it crashes with
# newer versions.
rm "${pkgdir}/opt/${_pkgname}/${_libi}/libjpeg.so.62"
rm "${pkgdir}/opt/${_pkgname}/${_libi}/libjpeg.so.62.0.0"