summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipp Andjelo2016-07-24 19:01:58 +0200
committerFilipp Andjelo2016-07-24 19:01:58 +0200
commit81e1c0455c9cf90494e79edbe15578d2a4d2879c (patch)
tree63d16e35bf57cf058499f2067f9875f517997638
downloadaur-81e1c0455c9cf90494e79edbe15578d2a4d2879c.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a2c793e8877
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by makepkg 5.0.1
+# Sun Jul 24 15:50:01 UTC 2016
+pkgbase = upm
+ pkgdesc = Universal Password Manager
+ pkgver = 1.14
+ pkgrel = 1
+ url = http://upm.sourceforge.net/
+ arch = any
+ license = GPL2
+ depends = java-runtime
+ source = http://downloads.sourceforge.net/project/upm/upm-1.14/upm-1.14.tar.gz
+ sha256sums = 44b321b3e026f1bddfa91937c47c5079d3739843062e69a4cd5868190fcae526
+
+pkgname = upm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6dfe3bdd293f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Filipp Andjelo <filipp at andjelo dot de>
+
+pkgname=upm
+pkgver=1.14
+pkgrel=1
+pkgdesc="Universal Password Manager"
+arch=('any')
+url="http://upm.sourceforge.net/"
+license=('GPL2')
+depends=('java-runtime')
+source=("http://downloads.sourceforge.net/project/upm/upm-${pkgver}/upm-${pkgver}.tar.gz")
+sha256sums=('44b321b3e026f1bddfa91937c47c5079d3739843062e69a4cd5868190fcae526')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ for f in *.jar; do
+ install -Dm 644 $f ${pkgdir}/usr/lib/upm/$f
+ done
+ install -Dm 755 upm.sh ${pkgdir}/usr/lib/upm/upm.sh
+ install -Dm 644 README.txt ${pkgdir}/usr/share/doc/upm/README.txt
+ install -Dm 644 upm.png ${pkgdir}/usr/share/pixmaps/upm.png
+ install -d ${pkgdir}/usr/bin/
+ ln -s /usr/lib/upm/upm.sh ${pkgdir}/usr/bin/upm
+
+ for f in server/http/*.php; do
+ install -Dm 644 $f ${pkgdir}/usr/share/webapps/upm/$(basename $f)
+ done
+
+
+}