summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2020-07-03 03:29:11 -0400
committerLeo P2020-07-03 03:29:11 -0400
commit3c4bbfcaa4a2156be97aa5e074a136d5a209074e (patch)
tree32d0a088269c1ec2daae5d63e6577d922e3da248
parent1a712b3ddec0242d2627131f58b782a33dda62f0 (diff)
downloadaur-3c4bbfcaa4a2156be97aa5e074a136d5a209074e.tar.gz
bump to v0.99.11
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5264ef573253..0e5057f41d7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = upower-nocritical
pkgdesc = Abstraction for enumerating power devices, listening to device events and querying history and statistics (With a patch to disable low battery action)
- pkgver = 0.99.10
+ pkgver = 0.99.11
pkgrel = 1
url = http://upower.freedesktop.org
arch = i686
@@ -19,7 +19,7 @@ pkgbase = upower-nocritical
provides = upower
conflicts = upower
backup = etc/UPower/UPower.conf
- source = git+https://gitlab.freedesktop.org/upower/upower.git#commit=215049e7b80c5f24cb35cd229a445c6cf19bd381
+ source = git+https://gitlab.freedesktop.org/upower/upower.git#commit=e1548bba61206a05bbc318b3d49ae24571755ac6
source = 0001-Add-a-critical-action-Ignore.patch
md5sums = SKIP
md5sums = 69fbeb7e5906a59fd39f702d01f83815
diff --git a/PKGBUILD b/PKGBUILD
index 42112f39131e..93399ddc270f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Star Brilliant <m13253@hotmail.com>
+# Contributor: Star Brilliant <m13253@hotmail.com>
pkgname=upower-nocritical
_pkgname=upower
-pkgver=0.99.10
+pkgver=0.99.11
pkgrel=1
pkgdesc="Abstraction for enumerating power devices, listening to device events and querying history and statistics (With a patch to disable low battery action)"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ makedepends=('intltool' 'docbook-xsl' 'gobject-introspection' 'python2' 'git' 'g
provides=('upower')
conflicts=('upower')
backup=('etc/UPower/UPower.conf')
-_commit=215049e7b80c5f24cb35cd229a445c6cf19bd381 # tags/UPOWER_0_99_10^0
+_commit=e1548bba61206a05bbc318b3d49ae24571755ac6 # tags/UPOWER_0_99_11^0
source=("git+https://gitlab.freedesktop.org/upower/upower.git#commit=$_commit"
0001-Add-a-critical-action-Ignore.patch)
md5sums=('SKIP'
@@ -28,19 +28,19 @@ pkgver() {
prepare() {
cd $_pkgname
patch -p1 < "$srcdir/0001-Add-a-critical-action-Ignore.patch"
+ sed -e 's|libplist >= 0.12|libplist-2.0 >= 2.2|' -i configure.ac # support libplist 2.2
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
cd $_pkgname
-
- NOCONFIGURE=1 ./autogen.sh
-
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --libexecdir=/usr/lib/$_pkgname \
- --disable-static
+ --libexecdir=/usr/lib \
+ --disable-static \
+ --enable-gtk-doc
make
}