summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-06-20 14:01:47 +0200
committerbegin-theadventure2023-06-20 14:01:47 +0200
commit2e3eafc2fe83cf47bef5754f26085b247fc783de (patch)
tree5da9a2d613df0049c680859c2dcf2706b6a6d6c2
parent40d272a225f910d0fd470401afa39681e32d59a1 (diff)
downloadaur-2e3eafc2fe83cf47bef5754f26085b247fc783de.tar.gz
Adopt Package, 1.1.2, update source and depends, cleanup
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 27 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82b220972dd9..8d566b7986c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = upscaler-git
- pkgdesc = Upscale and enhance images
- pkgver = 1.0.0.r0.g712c262
+ pkgdesc = Upscale and enhance images (latest commit)
+ pkgver = 1.1.2
pkgrel = 1
- url = https://gitlab.com/TheEvilSkeleton/Upscaler
- arch = x86_64
+ url = https://gitlab.gnome.org/World/Upscaler
+ arch = any
license = GPL3
checkdepends = appstream-glib
- makedepends = git
makedepends = blueprint-compiler
+ makedepends = git
makedepends = meson
depends = libadwaita
+ depends = python-cffi
depends = python-gobject
+ depends = python-vulkan
depends = realesrgan-ncnn-vulkan
provides = upscaler
conflicts = upscaler
- source = upscaler::git+https://gitlab.com/TheEvilSkeleton/Upscaler.git
- b2sums = SKIP
+ source = git+https://gitlab.gnome.org/World/Upscaler.git
+ sha256sums = SKIP
pkgname = upscaler-git
diff --git a/PKGBUILD b/PKGBUILD
index 0cb4ff618222..cd8e57d27123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
-# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: Igor Dyatlov <dyatlov.igor@protonmail.com>
-pkgname=upscaler-git
-pkgver=1.0.0.r0.g712c262
+_pkgname=upscaler
+pkgname=$_pkgname-git
+pkgver=1.1.2
pkgrel=1
-pkgdesc="Upscale and enhance images"
-arch=('x86_64')
-url="https://gitlab.com/TheEvilSkeleton/Upscaler"
+pkgdesc="Upscale and enhance images (latest commit)"
+arch=('any')
+url="https://gitlab.gnome.org/World/Upscaler"
license=('GPL3')
-depends=('libadwaita' 'python-gobject' 'realesrgan-ncnn-vulkan')
-makedepends=('git' 'blueprint-compiler' 'meson')
+depends=('libadwaita' 'python-cffi' 'python-gobject' 'python-vulkan' 'realesrgan-ncnn-vulkan')
+makedepends=('blueprint-compiler' 'git' 'meson')
checkdepends=('appstream-glib')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=(${pkgname%-git}::git+$url.git)
-b2sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(git+$url.git)
+sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
+ cd Upscaler
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "${pkgname%-git}" build
+ arch-meson Upscaler build
meson compile -C build
}
@@ -31,4 +33,6 @@ check() {
package() {
meson install -C build --destdir "$pkgdir"
+ install -Dm644 Upscaler/README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm644 Upscaler/COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
}