summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-11-16 20:58:55 +0300
committerIgor Dyatlov2022-11-16 20:58:55 +0300
commit40d272a225f910d0fd470401afa39681e32d59a1 (patch)
treebf1e7f6756a13b66d0ddba38685091deeb58df3d
downloadaur-40d272a225f910d0fd470401afa39681e32d59a1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82b220972dd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = upscaler-git
+ pkgdesc = Upscale and enhance images
+ pkgver = 1.0.0.r0.g712c262
+ pkgrel = 1
+ url = https://gitlab.com/TheEvilSkeleton/Upscaler
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = blueprint-compiler
+ makedepends = meson
+ depends = libadwaita
+ depends = python-gobject
+ depends = realesrgan-ncnn-vulkan
+ provides = upscaler
+ conflicts = upscaler
+ source = upscaler::git+https://gitlab.com/TheEvilSkeleton/Upscaler.git
+ b2sums = SKIP
+
+pkgname = upscaler-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cb4ff618222
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=upscaler-git
+pkgver=1.0.0.r0.g712c262
+pkgrel=1
+pkgdesc="Upscale and enhance images"
+arch=('x86_64')
+url="https://gitlab.com/TheEvilSkeleton/Upscaler"
+license=('GPL3')
+depends=('libadwaita' 'python-gobject' 'realesrgan-ncnn-vulkan')
+makedepends=('git' 'blueprint-compiler' 'meson')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(${pkgname%-git}::git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson "${pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}