summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2022-12-24 22:59:19 -0500
committerKevin MacMartin2022-12-24 22:59:19 -0500
commit1fad435ec167be7c6f964d44b98dc1eb8b00fc12 (patch)
tree3fd49364c105ca7edec8f9c2d5507e4cbc0b5966
parent409fa8298c84b4a1f586a63e9b91f62c9ffb4bab (diff)
downloadaur-1fad435ec167be7c6f964d44b98dc1eb8b00fc12.tar.gz
Update to 2.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5542aaea8320..6639a0875dbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = upscayl-bin
pkgdesc = Free and Open Source AI Image Upscaler
- pkgver = 1.5.5
- pkgrel = 2
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/upscayl/upscayl
arch = i686
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = upscayl-bin
provides = upscayl
conflicts = upscayl
options = !strip
- source = https://github.com/upscayl/upscayl/releases/download/v1.5.5/Upscayl-1.5.5.AppImage
- sha512sums = 161c864fce65009234c5950358b4869fbb0899d931d03e394431a9fe5027c00281705713c6fb0e33cd30f6d37687538e53167f6c3d116ee1749cff7cff8b5147
+ source = https://github.com/upscayl/upscayl/releases/download/v2.0.0/upscayl-2.0.0-linux.AppImage
+ sha512sums = f6b6940336afd969c2b9b83150c5166dff4611f8c6b0260fe1cd46095bfb2c594229d606a2ea43206ec9b5590a1ffda6708717c35171b67784ab63ff6966fcd7
pkgname = upscayl-bin
diff --git a/PKGBUILD b/PKGBUILD
index 528a1bdc9be4..cd72a6f741ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname=upscayl
pkgname=$_pkgname-bin
-pkgver=1.5.5
-pkgrel=2
+pkgver=2.0.0
+pkgrel=1
pkgdesc='Free and Open Source AI Image Upscaler'
url='https://github.com/upscayl/upscayl'
license=('AGPL3')
@@ -14,18 +14,18 @@ makedepends=('util-linux')
provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
-source=("https://github.com/upscayl/upscayl/releases/download/v${pkgver}/Upscayl-${pkgver}.AppImage")
-sha512sums=('161c864fce65009234c5950358b4869fbb0899d931d03e394431a9fe5027c00281705713c6fb0e33cd30f6d37687538e53167f6c3d116ee1749cff7cff8b5147')
+source=("https://github.com/upscayl/upscayl/releases/download/v${pkgver}/upscayl-${pkgver}-linux.AppImage")
+sha512sums=('f6b6940336afd969c2b9b83150c5166dff4611f8c6b0260fe1cd46095bfb2c594229d606a2ea43206ec9b5590a1ffda6708717c35171b67784ab63ff6966fcd7')
prepare() {
[[ -d squashfs-root ]] && rm -rf squashfs-root
- chmod 755 Upscayl-${pkgver}.AppImage
- ./Upscayl-${pkgver}.AppImage --appimage-extract
+ chmod 755 upscayl-${pkgver}-linux.AppImage
+ ./upscayl-${pkgver}-linux.AppImage --appimage-extract
sed -i 's|^Exec=.*|Exec=upscayl|' squashfs-root/upscayl.desktop
}
package() {
install -Dm644 squashfs-root/usr/share/icons/hicolor/0x0/apps/upscayl.png "$pkgdir/usr/share/pixmaps/upscayl.png"
install -Dm644 squashfs-root/upscayl.desktop "$pkgdir/usr/share/applications/upscayl.desktop"
- install -Dm755 Upscayl-${pkgver}.AppImage "$pkgdir/usr/bin/$_pkgname"
+ install -Dm755 upscayl-${pkgver}-linux.AppImage "$pkgdir/usr/bin/$_pkgname"
}