summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2022-12-14 10:46:54 -0500
committerKevin MacMartin2022-12-14 10:46:54 -0500
commit409fa8298c84b4a1f586a63e9b91f62c9ffb4bab (patch)
treec5cdf4774c449a1cbfe358c302854b7c02bf088a
parent1d03a0006ebf0ff5739a56e373b8d1faa386cc29 (diff)
downloadaur-409fa8298c84b4a1f586a63e9b91f62c9ffb4bab.tar.gz
Use the internal .desktop file and icon
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
-rw-r--r--upscayl.desktop10
-rw-r--r--upscayl.pngbin62086 -> 0 bytes
4 files changed, 14 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7a2aa9c33ec..5542aaea8320 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = upscayl-bin
pkgdesc = Free and Open Source AI Image Upscaler
pkgver = 1.5.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/upscayl/upscayl
arch = i686
arch = x86_64
@@ -9,16 +9,13 @@ pkgbase = upscayl-bin
arch = armv7h
arch = aarch64
license = AGPL3
+ makedepends = util-linux
depends = fuse2
depends = zlib
provides = upscayl
conflicts = upscayl
options = !strip
source = https://github.com/upscayl/upscayl/releases/download/v1.5.5/Upscayl-1.5.5.AppImage
- source = upscayl.desktop
- source = upscayl.png
sha512sums = 161c864fce65009234c5950358b4869fbb0899d931d03e394431a9fe5027c00281705713c6fb0e33cd30f6d37687538e53167f6c3d116ee1749cff7cff8b5147
- sha512sums = 14ad6e6ec3f28e9bdaa393fe43e49ed642f963b4358a4b6cf380b59a4a1adaf2fef5bcd4cf752dd6bddb54341bef74d749073070c070280bf6529eff75d45181
- sha512sums = 66891568bc58d3788fb025afffb5088c5b84a73cc50ad109705c1fda5251b6b820763486c833bfb7aeccf7f7ec0b0939330c7565819ae78701d4d9f04fc56e47
pkgname = upscayl-bin
diff --git a/PKGBUILD b/PKGBUILD
index 14e1bc39881d..528a1bdc9be4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,28 @@
_pkgname=upscayl
pkgname=$_pkgname-bin
pkgver=1.5.5
-pkgrel=1
+pkgrel=2
pkgdesc='Free and Open Source AI Image Upscaler'
url='https://github.com/upscayl/upscayl'
license=('AGPL3')
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
depends=('fuse2' 'zlib')
+makedepends=('util-linux')
provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
+source=("https://github.com/upscayl/upscayl/releases/download/v${pkgver}/Upscayl-${pkgver}.AppImage")
+sha512sums=('161c864fce65009234c5950358b4869fbb0899d931d03e394431a9fe5027c00281705713c6fb0e33cd30f6d37687538e53167f6c3d116ee1749cff7cff8b5147')
-source=(
- "https://github.com/upscayl/upscayl/releases/download/v${pkgver}/Upscayl-${pkgver}.AppImage"
- "$_pkgname.desktop"
- "$_pkgname.png"
-)
-
-sha512sums=(
- '161c864fce65009234c5950358b4869fbb0899d931d03e394431a9fe5027c00281705713c6fb0e33cd30f6d37687538e53167f6c3d116ee1749cff7cff8b5147'
- '14ad6e6ec3f28e9bdaa393fe43e49ed642f963b4358a4b6cf380b59a4a1adaf2fef5bcd4cf752dd6bddb54341bef74d749073070c070280bf6529eff75d45181'
- '66891568bc58d3788fb025afffb5088c5b84a73cc50ad109705c1fda5251b6b820763486c833bfb7aeccf7f7ec0b0939330c7565819ae78701d4d9f04fc56e47'
-)
+prepare() {
+ [[ -d squashfs-root ]] && rm -rf squashfs-root
+ chmod 755 Upscayl-${pkgver}.AppImage
+ ./Upscayl-${pkgver}.AppImage --appimage-extract
+ sed -i 's|^Exec=.*|Exec=upscayl|' squashfs-root/upscayl.desktop
+}
package() {
- install -Dm644 $_pkgname.desktop "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install -Dm644 $_pkgname.png "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/0x0/apps/upscayl.png "$pkgdir/usr/share/pixmaps/upscayl.png"
+ install -Dm644 squashfs-root/upscayl.desktop "$pkgdir/usr/share/applications/upscayl.desktop"
install -Dm755 Upscayl-${pkgver}.AppImage "$pkgdir/usr/bin/$_pkgname"
}
diff --git a/upscayl.desktop b/upscayl.desktop
deleted file mode 100644
index 3c83c0c3f698..000000000000
--- a/upscayl.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Upscayl
-Comment=Free and Open Source AI Image Upscaler
-Exec=upscayl
-Icon=upscayl
-Terminal=false
-StartupNotify=false
-Categories=Graphics;RasterGraphics;
diff --git a/upscayl.png b/upscayl.png
deleted file mode 100644
index 1daffe33c3d2..000000000000
--- a/upscayl.png
+++ /dev/null
Binary files differ